Re: [Zope-dev] Product dev

2001-01-05 Thread Chris Withers
Shane Hathaway wrote: when a product has syntax errors. One of the first things I did at Digital Creations was make sure that got fixed. :-) Does this mean this bit from your average product's __init__.py isn't neeeded anymore? except: # If we can't register, complain! import

Re: [Zope-dev] Product dev

2001-01-05 Thread Shane Hathaway
Chris Withers wrote: Shane Hathaway wrote: when a product has syntax errors. One of the first things I did at Digital Creations was make sure that got fixed. :-) Does this mean this bit from your average product's __init__.py isn't neeeded anymore? except: # If we can't

Re: [Zope-dev] Product dev

2001-01-05 Thread Chris Withers
Shane Hathaway wrote: when a product has syntax errors. One of the first things I did at Digital Creations was make sure that got fixed. :-) Does this mean this bit from your average product's __init__.py isn't neeeded anymore? except: # If we can't register, complain!

Re: [Zope-dev] Product dev

2001-01-05 Thread Shane Hathaway
Chris Withers wrote: Shane Hathaway wrote: when a product has syntax errors. One of the first things I did at Digital Creations was make sure that got fixed. :-) Does this mean this bit from your average product's __init__.py isn't neeeded anymore? except: # If we

[Zope-dev] Product dev

2001-01-04 Thread Tim McLaughlin
I'm building a Product in Python and seem to be having some issues with the new registerClass method of Product registering. If I build it all fine as noted in Shane's recent HowTo, the product does not show up in the control panel. Then after much other chasing, I make a purposeful syntax

Re: [Zope-dev] Product dev

2001-01-04 Thread Dieter Maurer
Tim McLaughlin writes: I'm building a Product in Python and seem to be having some issues with the new registerClass method of Product registering. If I build it all fine as noted in Shane's recent HowTo, the product does not show up in the control panel. Then after much other chasing,

Re: [Zope-dev] Product dev

2001-01-04 Thread Shane Hathaway
Dieter Maurer wrote: For some problems during product import, Zope decides to keep the old state rather than show the error. I wonder whether the product's version.txt might have something to do with it. Remove version.txt and see if it has any effect. Then try creating a new