Re: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-06 Thread Fred L. Drake, Jr.
On Fri, 2003-10-03 at 17:27, Jamie Heilman wrote: In 2.3 you can no longer declare new classes in a Script object. It bitches about a lack of __name__ attribute. I haven't really had the time to look into it closely, but it does effect the examples shipped with zope, and actually its

RE: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-06 Thread Tim Peters
[Fred L. Drake, Jr.] In Python 2.3.x, when a class is defined the __name__ of the encompassing module is looked up. I suspect Python Scripts can be fixed by defining __name__ in the globals dictionary in which the code is executed. Thanks, Fred! I added this info to the collector entry:

Re: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-05 Thread Chris McDonough
OK, I will add this to the collector, thank you! On Fri, 2003-10-03 at 17:27, Jamie Heilman wrote: Chris McDonough wrote: OK, sounds like a slam dunk to me. I think its a fine idea (finally secure temporary files!), but let me present the first bug I've run into with 2.3 (I've been testing

[Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-04 Thread Florian Lindner
Chris McDonough wrote: Some people at ZC have made pretty compelling arguments to make Python 2.3.2 the recommended version of Python to use with Zope 2.7 final. I'm wondering if other people have a strong feeling about this either way. By the way: When is 2.7 supposed to be released? Thanks,

[Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread george donnelly
[Chris McDonough wrote ([EMAIL PROTECTED]) on 10/3/03 9:21 AM] Some people at ZC have made pretty compelling arguments to make Python 2.3.2 the recommended version of Python to use with Zope 2.7 final. I'm wondering if other people have a strong feeling about this either way. yes please. :)

[Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread BZ
No strong feeling other than I don't have it installed yet. I spent awhile playing with 2.7b2 and python 2.3 with no issues. BZ Some people at ZC have made pretty compelling arguments to make Python 2.3.2 the recommended version of Python to use with Zope 2.7 final. I'm wondering if other

RE: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread Tim Peters
[Chris McDonough] Some people at ZC have made pretty compelling arguments to make Python 2.3.2 the recommended version of Python to use with Zope 2.7 final. I'm wondering if other people have a strong feeling about this either way. [george donnelly] yes please. :) python 2.3 seems a lot

RE: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread Chris McDonough
OK, sounds like a slam dunk to me. I have changed the Zope 2.7 windows builder to use Python 2.3.2 and I have changed the source version configure script to look for 2.3.2 as it's optimal version. This all appears to work. Once an RPM is released for Python 2.3.2, I'll change the spec file for

RE: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread Fred L. Drake, Jr.
Chris McDonough writes: Currently, Zope still claims it works with 2.2.X (via the configure script's acceptable versions feature). Should we continue to make that claim true by not depending on any Python 2.3-specific features in the Zope core? I don't think there are a lot of

RE: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread Tim Peters
[Chris McDonough] Currently, Zope still claims it works with 2.2.X (via the configure script's acceptable versions feature). Actually, 2.2, 2.2.1, and 2.2.2 aren't acceptable for Zope even now, because of Zope-critical Python bugs first fixed in 2.2.3. There's no version of 2.2 with a fix for

Re: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread Jamie Heilman
Chris McDonough wrote: OK, sounds like a slam dunk to me. I think its a fine idea (finally secure temporary files!), but let me present the first bug I've run into with 2.3 (I've been testing with it). In 2.3 you can no longer declare new classes in a Script object. It bitches about a lack of

Re: [Zope-dev] Re: [Zope] Using 2.3.2 for Zope 2.7

2003-10-03 Thread Anthony Baxter
Fred L. Drake, Jr. wrote Requiring 2.3 (any flavor) would allow us to drop the copy of the logging package from Zope 2.7 and newer. There are greater benefits for Zope 3, where we have several modules and packages laying around that would no longer be needed (logging, csv, gettext).