Re: [Zope-dev] working with different requirements depending on python version

2012-07-01 Thread Chris Withers
On 30/06/2012 18:12, Tres Seaver wrote: How have other people solved this? For repoze.sendmail, I did two fixups for Python 2.5: - - I changed 'install_requires' in setup.py based on sys.version_info https://github.com/repoze/repoze.sendmail/blob/master/setup.py - - I pinned the verstion

[Zope-dev] working with different requirements depending on python version

2012-06-30 Thread Chris Withers
Hi All, While trying to debug another problem, I re-ran some Jenkins jobs for two of my packages, which promptly failed under Python 2.5: http://jenkins.simplistix.co.uk/job/testfixtures-buildout/ http://jenkins.simplistix.co.uk/job/checker-buildout/ Now, the issue here is that

Re: [Zope-dev] working with different requirements depending on python version

2012-06-30 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 06/30/2012 08:54 AM, Chris Withers wrote: Hi All, While trying to debug another problem, I re-ran some Jenkins jobs for two of my packages, which promptly failed under Python 2.5: http://jenkins.simplistix.co.uk/job/testfixtures-buildout/