Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-16 Thread Florent Guillaume
Shane Hathaway [EMAIL PROTECTED] wrote: Florent Guillaume wrote: What is the dependency on the python implementation, is it just _embed_permission_in_roles ? Didn't you succeed in patching the C version too in some earlier versions of VerboseSecurity ? Currently, the C code makes no

Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-15 Thread Florent Guillaume
I've written a patch against the Zope trunk that integrates the functionality of the VerboseSecurity product into the Zope core. Excellent, thanks. To enable verbose security, apply the patch, recompile and reinstall using make, then add the following lines to etc/zope.conf:

Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-15 Thread Shane Hathaway
Florent Guillaume wrote: What is the dependency on the python implementation, is it just _embed_permission_in_roles ? Didn't you succeed in patching the C version too in some earlier versions of VerboseSecurity ? Currently, the C code makes no attempt to raise verbose errors. I've never

Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-14 Thread Andreas Jung
--On 14. Juni 2005 09:52:33 -0600 Shane Hathaway [EMAIL PROTECTED] wrote: I've written a patch against the Zope trunk that integrates the functionality of the VerboseSecurity product into the Zope core. I've attached the patch, which is based on Subversion revision 30788. All Zope tests

Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-14 Thread Paul Winkler
On Tue, Jun 14, 2005 at 09:52:33AM -0600, Shane Hathaway wrote: Should the patch be included in Zope 2.8.1? ooo, yes please! -PW -- Paul Winkler http://www.slinkp.com ___ Zope-Dev maillist - Zope-Dev@zope.org

Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-14 Thread Shane Hathaway
Andreas Jung wrote: --On 14. Juni 2005 09:52:33 -0600 Shane Hathaway [EMAIL PROTECTED] wrote: This patch supercedes the VerboseSecurity product, so I don't plan to update the VerboseSecurity product for Zope 2.8. Should the patch be included in Zope 2.8.1? From me: +2 There is clearly

RE: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-14 Thread Brian Lloyd
-dev@zope.org Subject: Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9 Andreas Jung wrote: --On 14. Juni 2005 09:52:33 -0600 Shane Hathaway [EMAIL PROTECTED] wrote: This patch supercedes the VerboseSecurity product, so I don't plan to update the VerboseSecurity product for Zope 2.8

RE: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-14 Thread Andreas Jung
--On 14. Juni 2005 13:12:14 -0400 Brian Lloyd [EMAIL PROTECTED] wrote: +1 from me ;) Enough pro-votes to overrule Jim :-) I suggest to merge the stuff :-) -aj pgpfsD0fdOIrF.pgp Description: PGP signature ___ Zope-Dev maillist -

Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9

2005-06-14 Thread Shane Hathaway
: Re: [Zope-dev] Verbose security for Zope 2.8 or 2.9 Andreas Jung wrote: --On 14. Juni 2005 09:52:33 -0600 Shane Hathaway [EMAIL PROTECTED] wrote: This patch supercedes the VerboseSecurity product, so I don't plan to update the VerboseSecurity product for Zope 2.8. Should the patch be included