[Zope-dev] RE: [Zope] REQUIRING Python 2.1??

2001-04-13 Thread Brian Lloyd

 Second, I am MYSTIFIED (there's no better word) that DC is in such a rush
 to REQUIRE the use of Python 2.1 for Zope 2.4, when we're still
 waiting for
 Py 2.1 final to even come out. Why put all your eggs in that basket, and
 why force the community to choose between changing to a bleeding-edge
 Python or retiring to a frozen Zope rev?

 Does DC not realize that Python has OTHER applications besides Zope? and
 that for a given community site, changing Pythons might have unexpected
 side effects in systems whose developers are less gung-ho about
 rushing to
 2.1 than DC is?

You may have more than one Python installation on a machine. This in no
way forces you to move "all of your applications" to 2.1. The binary
releases in particular make this drop-dead easy; they come with a bundled
Python, and do not affect any other Python you may have in any way.


 I thought I'd set my mind at ease by reading the wiki Brian
 referred to --
 which is called "SupportPython21" although it should apparently have been
 named "RequirePython21" -- but all I could glean from their
 justifications
 was [1] it'll make i18n easier (wow, that's huge), [2] there's some other
 things with strings and such that "may" be useful, and [3] of course
 there's a raft of other potentially disruptive differences, but hey, at
 least we found a way to make i18n easier!

You've correctly pointed out that I have not captured all of
the reasoning. I'll try to correct that in the project docs. And
note that Zope is a pretty diverse community - just because i18n
is not very important to _you_ does not mean it is not important.
There are plenty who consider it hugely significant, and who
are at least as perturbed that we _haven't_ done this yet.


 Instead, for the sake of being able to let the Python
 developers stick a Zope logo on the 2.1 release, we are risking a
 boatload of trouble.

I'm curious where you came up with that assertion - the PythonLabs
guys have had absolutely nothing to do with this.


 On the basis of prior performance I do not expect this objection to make
 any difference in what DC does, but I needed to express it anyway.

You may find that making your objections in a less inflammatory
way will give them more impact. We are all for public debate -
that is why we are doing this in the open, in a public project
area on dev.zope.org.


Brian Lloyd[EMAIL PROTECTED]
Software Engineer  540.371.6909
Digital Creations  http://www.digicool.com




___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] RE: [Zope] REQUIRING Python 2.1??

2001-04-13 Thread anser

 You may have more than one Python installation on a machine. This in no
 way forces you to move "all of your applications" to 2.1. The binary
 releases in particular make this drop-dead easy; they come with a bundled
 Python, and do not affect any other Python you may have in any way.

right, but by the same token the binary releases won't require special 
warnings to people about upgrading to 2.1.

 And
 note that Zope is a pretty diverse community - just because i18n
 is not very important to _you_ does not mean it is not important.
 There are plenty who consider it hugely significant, and who
 are at least as perturbed that we _haven't_ done this yet.

The question is not whether i18n ought to be done, but whether you ought to 
require upgrading to Py 2.1 to achieve it.

 On the basis of prior performance I do not expect this objection to make
 any difference in what DC does, but I needed to express it anyway.

 You may find that making your objections in a less inflammatory
 way will give them more impact.

I do not know how one would measure "impact" in order to test this 
proposition. If "impact" means changing DC policy or software in any way, 
then I suspect as previously stated that hearts+flowers wouldn't get it 
done either.  If "impact" means that the question would get a response, 
well, this thread's existence may be a counterexample.

What I do know is that requiring an upgrade to a not-yet-gold Py release as 
a prerequisite to the next Zope release is unwise software policy.



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] RE: [Zope] REQUIRING Python 2.1??

2001-04-13 Thread Martijn Pieters

On Fri, Apr 13, 2001 at 12:10:52PM -0400, anser wrote:
  You may have more than one Python installation on a machine. This in no
  way forces you to move "all of your applications" to 2.1. The binary
  releases in particular make this drop-dead easy; they come with a bundled
  Python, and do not affect any other Python you may have in any way.
 
 right, but by the same token the binary releases won't require special 
 warnings to people about upgrading to 2.1.

We made no such warnings. We warn people that follow the bleeding-edge
head of the trunk taht we will be switching soon.

  And
  note that Zope is a pretty diverse community - just because i18n
  is not very important to _you_ does not mean it is not important.
  There are plenty who consider it hugely significant, and who
  are at least as perturbed that we _haven't_ done this yet.
 
 The question is not whether i18n ought to be done, but whether you ought to 
 require upgrading to Py 2.1 to achieve it.

Yes, we will require 2.1 to do that, because Unicode support in 1.5.2 is
not by far adequate for our needs. The pain of trying to support our own
Unicode libraries is too great to justify keeping to support 1.5.2. THis
is apart from the other advantages that Python 2.1 offers.

  On the basis of prior performance I do not expect this objection to make
  any difference in what DC does, but I needed to express it anyway.
 
  You may find that making your objections in a less inflammatory
  way will give them more impact.
 
 I do not know how one would measure "impact" in order to test this 
 proposition. If "impact" means changing DC policy or software in any way, 
 then I suspect as previously stated that hearts+flowers wouldn't get it 
 done either.  If "impact" means that the question would get a response, 
 well, this thread's existence may be a counterexample.
 
 What I do know is that requiring an upgrade to a not-yet-gold Py release as 
 a prerequisite to the next Zope release is unwise software policy.

That is not the policy. The Zope 2.4 release will require 2.1, and
development of that release will start *after* Python 2.1 goes gold. This
is clearly stated in the linked documents in the warning email.

The next stable release may very well (very probably) be a 2.3.3 release.
Which will still be a Python 1.5.2 release. I have the idea that you think
that either the 2.3.x line will switch to Python 2.1 now (and 2.3.3 is to be
released soon) or that no more development on the 2.3.x line will occur.

-- 
Martijn Pieters
| Software Engineer  mailto:[EMAIL PROTECTED]
| Digital Creations  http://www.digicool.com/
| Creators of Zope   http://www.zope.org/
-

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] RE: [Zope] REQUIRING Python 2.1??

2001-04-13 Thread Albert Langer

[anser]
I can't quite help wondering whether someone at DC has maybe gotten so
"into" the development of Py 2.1 that they just can't wait to use its new
stuff, whether it's objectively what's best for Zope or not.  The prudent
thing to do would have been to add features as needed using
1.5.2-compatible code, or at best to offer a "new18n" branch that requires
2.1, which people who are THAT desperate for i18n could choose to follow if
they wanted.  Then, say 6-12 months after 2.1 is gold, you could unify and
require it for 3.0.  Instead, for the sake of being able to let the Python
developers stick a Zope logo on the 2.1 release, we are risking a boatload
of trouble.

[albert]
As far as I can make out the strategy you advocate is more or less exactly
what they *did* do - so smoothly you didn't even notice.

The *big* leap is from 1.5.2 to 2.0 which has been out for quite a while.
I18N is *desperately* needed but had to be delayed because of the
compatability problems you are rightly concerned about. So even after
I18N became feasible with 2.0 the main branch was made compatible
with using 2.0 but binaries released with 1.5.2 to avoid risking a
boatload of trouble while enabling people desperate for I18N to start
using 2.0 and at the same time discover as much as possible of the
hiccups before general switchover.

Waiting for the "odd numbered release" is also a generally sound
policy. Essentially you are confusing that prudent delay in
completing the smoothly planned (and very clearly announced long ago)
switch from 1.5.2 to 2.x with a sudden rush to 2.1. Whatever
problems do occur will be overwhelmingly from the 2.x, not from
it being 2.1 in particular.


___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] RE: [Zope] REQUIRING Python 2.1??

2001-04-13 Thread Tom Neff

If what Albert says is true, then Zope 2.4 should REQUIRE Py 2.0 and 
SUPPORT Py 2.1, not REQUIRE Py 2.1.

--On Saturday, April 14, 2001 1:14 AM +1000 Albert Langer 
[EMAIL PROTECTED] wrote:
 The *big* leap is from 1.5.2 to 2.0 which has been out for quite a while.
 I18N is *desperately* needed but had to be delayed because of the
 compatability problems you are rightly concerned about. So even after
 I18N became feasible with 2.0 the main branch was made compatible
 with using 2.0 but binaries released with 1.5.2 to avoid risking a
 boatload of trouble while enabling people desperate for I18N to start
 using 2.0 and at the same time discover as much as possible of the
 hiccups before general switchover.

 Waiting for the "odd numbered release" is also a generally sound
 policy. Essentially you are confusing that prudent delay in
 completing the smoothly planned (and very clearly announced long ago)
 switch from 1.5.2 to 2.x with a sudden rush to 2.1. Whatever
 problems do occur will be overwhelmingly from the 2.x, not from
 it being 2.1 in particular.






___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



[Zope-dev] RE: [Zope] REQUIRING Python 2.1??

2001-04-13 Thread Steven D. Majewski



On Fri, 13 Apr 2001, Tom Neff wrote:

 If what Albert says is true, then Zope 2.4 should REQUIRE Py 2.0 and 
 SUPPORT Py 2.1, not REQUIRE Py 2.1.

But note what he said about "odd numbered releases". 

True to form, 2.0 adds a whole load of features, and 2.1 cleans up
after 2.0. ;-)  

True, there is a 2.0.1 bugfix-only release of 2.0 due out, which puts
some of the 2.1 fixes back into 2.0, but it's probably going to be
a lot simpler just to (at least officialy) support 2.1 .  

I think this probably has a lot more to do with Python's more rapid
release schedule since moving to SourceForge, than it does to someone
at DC being unable to wait. At the older, more leisurely release 
non-schedule, 2.1 would probably have been the 2.0.1 release: at the
current pace, Python is lapping itself!


-- Steve Majewski


___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )