Re: [Zope-dev] Memory Error

2003-06-23 Thread Andy McKay
There we go, occurred again.

Its definitely the manipulating of catalog results, all the crashes are 
happening on zcatalog searches. There is over 530 Megs of Memory free at 
the time.

But like I say its never occuring my other boxes so time to whip out 
some unit tests and the like ;)
--
  Andy McKay
  http://www.agmweb.ca

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Memory Error

2003-06-18 Thread Andy McKay
Thanks for the responses everyone.

This message occured more frequently when I was showing the 
getNewOrRandom slot which does a few catalog searches and mucks them 
around. I've turned off that slot and setup a nightly restart cron.

I'm waiting for it to happen again (it hasn't yet), but it looks like 
the BTrees and Catalog results could be a place to start.

Its got a gig of ram and about 500 mb is free most of the time 
apparently, but next time it happens I'll see if I can get more info.

Just have to hurry up and wait now ;) Or wait for runyaga to visit it, 
he seems to have this curse with it.
--
  Andy McKay
  http://www.agmweb.ca

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Memory Error

2003-06-17 Thread Sidnei da Silva
On Tue, Jun 17, 2003 at 08:47:57AM -0700, Andy McKay wrote:
| If you've visited ZopeZen you might have noticed this lovely error that 
| seems to occur intermittently..
| 
| [snip rest of traceback]
| * Module Products.CMFCore.CatalogTool, line 214, in searchResults
| * Module Products.ZCatalog.ZCatalog, line 619, in searchResults
| * Module Products.ZCatalog.Catalog, line 732, in searchResults
| * Module Products.ZCatalog.Catalog, line 480, in search
| * Module Products.PluginIndexes.common.UnIndex, line 365, in 
| _apply_index
| * Module ZODB.Connection, line 534, in setstate
| 
| MemoryError: (Also, an error occurred while attempting to render the 
| standard error message.)

Just for the records, we were getting some MemoryError's on NZO, which
were track down to some weird repr() handling on ZEO/ZODB code. There
were also some fixes on memory leaks (an exception on a tal:repeat
would leak some objects, plus there was one small leak on plone's
portal_form) but none seem to be entirely related to your
problem. However it could be a side effect of a memory leak. I
would recommend getting ZODB from the new ZODB-3_2-branch, and plone
from the Plone-1_0 branch. And if youre not afraid of running from
CVS, get Zope from the 2_6-branch ;)

[]'s
-- 
Sidnei da Silva (dreamcatcher) [EMAIL PROTECTED]
X3ng Web Technology http://www.x3ng.com.br
GNU/Linux user 257852
Debian GNU/Linux 3.0 (Sid) 2.4.20-powerpc ppc

Oh, so there you are!

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Memory Error

2003-06-17 Thread Dieter Maurer
Andy McKay wrote at 2003-6-17 08:47 -0700:
  If you've visited ZopeZen you might have noticed this lovely error that 
  seems to occur intermittently..
  
  [snip rest of traceback]
   * Module Products.CMFCore.CatalogTool, line 214, in searchResults
   * Module Products.ZCatalog.ZCatalog, line 619, in searchResults
   * Module Products.ZCatalog.Catalog, line 732, in searchResults
   * Module Products.ZCatalog.Catalog, line 480, in search
   * Module Products.PluginIndexes.common.UnIndex, line 365, in 
  _apply_index
   * Module ZODB.Connection, line 534, in setstate
  
  MemoryError: (Also, an error occurred while attempting to render the 
  standard error message.)

MemoryError would mean you have run out of virtual memory.

This may or may not be a Zope problem.


Dieter

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Memory Error

2003-06-17 Thread Casey Duncan
On Tuesday 17 June 2003 11:47 am, Andy McKay wrote:
 If you've visited ZopeZen you might have noticed this lovely error that 
 seems to occur intermittently..
 
 [snip rest of traceback]
  * Module Products.CMFCore.CatalogTool, line 214, in searchResults
  * Module Products.ZCatalog.ZCatalog, line 619, in searchResults
  * Module Products.ZCatalog.Catalog, line 732, in searchResults
  * Module Products.ZCatalog.Catalog, line 480, in search
  * Module Products.PluginIndexes.common.UnIndex, line 365, in 
 _apply_index
  * Module ZODB.Connection, line 534, in setstate
 
 MemoryError: (Also, an error occurred while attempting to render the 
 standard error message.)
 
 Its:
 
 Zope 2.6.1 (source release, python 2.1, linux2)
 python 2.1.3
 openbsd3
 
 I believe all the appropiate python stack patches are applied.

In my experience, (at least on FreeBSD) it would simply fall over when it ran 
out of stack space, I don't remember ever seeing MemoryError. But I may not 
have been paying close enough attention ;^)

Looks like its running out of memory when a BTree subobject is being loaded. 
Do you have any idea how much memory the process was using when you got the 
error?

-Casey


___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )