Re: [Zope-dev] ZCatalog FieldIndex Bug (Fix?)

2001-04-06 Thread Chris McDonough

You can run them by doing "python testCatalog.py -p"... some will fail due
to not having various files on the filesystem, but most should pass.

I haven't had time to actually even look at the bug in the bugreport.
Thanks for the possible fix to the bug that I don't understand yet, however!
;-)

- Original Message -
From: "Chris Withers" [EMAIL PROTECTED]
To: [EMAIL PROTECTED]; "Chris McDonough" [EMAIL PROTECTED]
Sent: Thursday, April 05, 2001 6:41 PM
Subject: [Zope-dev] ZCatalog FieldIndex Bug (Fix?)


 Chris Withers wrote:
  Correct me if I'm wrong, but if I query a field index with an empty
string, I
  expect to get returned all catalogued objects where that attribute's
value _is_
  the empty string.
 
  Anyway, this happens most of the time and I wish it happened all the
time.
  Basically, the only situation where this _doesn't_ happen is when _none_
of the
  objects catalogued in the field index have a value of the empty string,
which
  seems really bug and nasty to me ;-)

 I think I've got a solution, but I dunno if it's right. The patch is at
the end.
 How do I get the unit tests in ZCatalog/tests to run so I can check I
haven't
 screwed anything else up?

 cheers,

 Chris

 E:\Zope\2.3.1\lib\python\SearchIndexdiff -u unindex.py.old unindex.py
 --- unindex.py.old  Thu Apr 05 23:35:40 2001
 +++ unindex.py  Thu Apr 05 23:37:46 2001
 @@ -407,9 +407,9 @@

  if r is None:
  if anyTrue:
 -r=IISet()
 -else:
  return None
 +else:
 +r=IISet()

  return r, (id,)


 ___
 Zope-Dev maillist  -  [EMAIL PROTECTED]
 http://lists.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  http://lists.zope.org/mailman/listinfo/zope-announce
  http://lists.zope.org/mailman/listinfo/zope )



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] ZCatalog FieldIndex Bug (Fix?)

2001-04-06 Thread Chris Withers

Chris McDonough wrote:
 
 You can run them by doing "python testCatalog.py -p"... some will fail due
 to not having various files on the filesystem, but most should pass.

Ah... this doesn't work if you have Python 2.0 installed as your default python
and a Zope binary release ;-)
Zope needs python 1.5.2 ;-)

I got 8 fails before and 8 fails after applying the tests.

 I haven't had time to actually even look at the bug in the bugreport.
 Thanks for the possible fix to the bug that I don't understand yet, however!
 ;-)

Well, import the .zexp I attached earlier in this thread, and run the 'dotest'
Python Script.

cheers,

Chris

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] ZCatalog FieldIndex Bug (Fix?)

2001-04-06 Thread Chris Withers

Chris McDonough wrote:
 
  Chris McDonough wrote:
  
   You can run them by doing "python testCatalog.py -p"... some will fail
 due
   to not having various files on the filesystem, but most should pass.
 
  Ah... this doesn't work if you have Python 2.0 installed as your default
 python
  and a Zope binary release ;-)
  Zope needs python 1.5.2 ;-)
 
 Thanks, professor.  ;-)

:-P

 Will do!  Thanks very much for tracking this down and sorry to not be more
 helpful in the process.

Pleasure, I wish I could have provided a unit test, but such is life ;-)

cheers,

Chris

___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )



Re: [Zope-dev] ZCatalog FieldIndex Bug (Fix?)

2001-04-06 Thread Chris McDonough

 Chris McDonough wrote:
 
  You can run them by doing python testCatalog.py -p... some will fail
due
  to not having various files on the filesystem, but most should pass.

 Ah... this doesn't work if you have Python 2.0 installed as your default
python
 and a Zope binary release ;-)
 Zope needs python 1.5.2 ;-)

Thanks, professor.  ;-)

 I got 8 fails before and 8 fails after applying the tests.

Sounds good to me!!

  I haven't had time to actually even look at the bug in the bugreport.
  Thanks for the possible fix to the bug that I don't understand yet,
however!
  ;-)

 Well, import the .zexp I attached earlier in this thread, and run the
'dotest'
 Python Script.

Will do!  Thanks very much for tracking this down and sorry to not be more
helpful in the process.

- C



___
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )