Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-03-01 Thread Adam GROSZER
Hello,

 I also suggest dropping the test reports for the z3c.* packages:  they
 have been broken since the day they were added, AFAICT, which is a
 strong signal that they are not being maintained.

 The point of the daily reports is to *keep the board green*, so that
 when a new failure shows up, we *feel* motivated to fix it.  Cluttering
 the report with repeated-and-apparently-never-gonna-fix failures is
 demotivating, which is the opposite of the effect we intend.

They were *definitely* green before lxml 2.3 got released.
I think Marius worked on getting them green.

I don't think those problems are 
repeated-and-apparently-never-gonna-fix, because it's a matter of 
having lxml eggs/exe for all windows/python platforms. That is going to 
be a *blocker* for ZTK too sooner or later, because allmost all windows 
users are *not* able to compile.

The fix right now seems to be to push Sidnei to do the releases.

-- 
Best regards,
  Adam GROSZER
--
Quote of the day:
Do not make friends who are comfortable to be with. Make friends who 
will force you to lever yourself up.
- Thomas J. Watson, Sr.
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-03-01 Thread Adam GROSZER
Hello,

On Mon, 28 Feb 2011 14:08:29 -0500 you wrote:

 On Monday, February 28, 2011, Tres Seaver wrote:
 I also suggest dropping the test reports for the z3c.* packages:  they
 have been broken since the day they were added, AFAICT, which is a
 strong signal that they are not being maintained.

 The problem is merely that lxml cannot be installed. This is more a winbot
 setup problem than a package one. And the reason lxml cannot be built is
 because libxml is missing.

 This is really strange, since there are binaries available for lxml-2.3 for
 Python 2.6.

 http://pypi.python.org/pypi/lxml/2.3

 Does anyone with Windows Foo have any idea?

Those seem to be 32bit only, weird is that only 32bit bots fail.
Let it have one more day to clear up, maybe those eggs got released just 
after the bots ran.

OTOH, I definitely do *not* want to enable winbot to be able to compile 
lxml.

-- 
Best regards,
  Adam GROSZER
--
Quote of the day:
Fall seven times, stand up eight.
- Japanese Proverb
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-03-01 Thread Simon Elbaz
On Tue, Mar 1, 2011 at 10:27 AM, Adam GROSZER agroszer...@gmail.com wrote:

 Hello,

 On Mon, 28 Feb 2011 14:08:29 -0500 you wrote:
 
  On Monday, February 28, 2011, Tres Seaver wrote:
  I also suggest dropping the test reports for the z3c.* packages:  they
  have been broken since the day they were added, AFAICT, which is a
  strong signal that they are not being maintained.
 
  The problem is merely that lxml cannot be installed. This is more a
 winbot
  setup problem than a package one. And the reason lxml cannot be built is
  because libxml is missing.
 
  This is really strange, since there are binaries available for lxml-2.3
 for
  Python 2.6.
 
  http://pypi.python.org/pypi/lxml/2.3
 
  Does anyone with Windows Foo have any idea?

 Those seem to be 32bit only, weird is that only 32bit bots fail.
 Let it have one more day to clear up, maybe those eggs got released just
 after the bots ran.

 OTOH, I definitely do *not* want to enable winbot to be able to compile
 lxml.

 --
 Best regards,
  Adam GROSZER
 --
 Quote of the day:
 Fall seven times, stand up eight.
 - Japanese Proverb
 ___
 Zope-Dev maillist  -  Zope-Dev@zope.org
 https://mail.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  https://mail.zope.org/mailman/listinfo/zope-announce
  https://mail.zope.org/mailman/listinfo/zope )


The build of z3c.* packages on winbot could be tested like
http://dev.thehealthagency.com/buildbot/builders/zope2.13_win-py2.6%20slave-win/builds/161
buildhttp://dev.thehealthagency.com/buildbot/builders/zope2.13_win-py2.6%20slave-win/builds/161

Regards
Simon Elbaz
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-03-01 Thread Adam GROSZER
Hello,

On Tue, 1 Mar 2011 11:04:30 +0100 you wrote:

 The build of z3c.* packages on winbot could be tested like
 http://dev.thehealthagency.com/buildbot/builders/zope2.13_win-py2.6%20slave-win/builds/161
 build
 http://dev.thehealthagency.com/buildbot/builders/zope2.13_win-py2.6%20slave-win/builds/161

hm, that does not seem to have lxml as dependency

-- 
Best regards,
  Adam GROSZER
--
Quote of the day:
Defeat may serve as well as victory to shake the soul and let the glory out.
- Edwin Markham
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-03-01 Thread Simon Elbaz
On Tue, Mar 1, 2011 at 11:42 AM, Adam GROSZER agroszer...@gmail.com wrote:

 Hello,

 On Tue, 1 Mar 2011 11:04:30 +0100 you wrote:
 
  The build of z3c.* packages on winbot could be tested like
 
 http://dev.thehealthagency.com/buildbot/builders/zope2.13_win-py2.6%20slave-win/builds/161
  build
  
 http://dev.thehealthagency.com/buildbot/builders/zope2.13_win-py2.6%20slave-win/builds/161
 

 hm, that does not seem to have lxml as dependency

 --
 Best regards,
  Adam GROSZER
 --
 Quote of the day:
 Defeat may serve as well as victory to shake the soul and let the glory
 out.
 - Edwin Markham
 ___
 Zope-Dev maillist  -  Zope-Dev@zope.org
 https://mail.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  https://mail.zope.org/mailman/listinfo/zope-announce
  https://mail.zope.org/mailman/listinfo/zope )


Hello,
Sorry, I didn't expressed myself well.

I mean building the test with the same steps as in
http://dev.thehealthagency.com/buildbot/builders/zope2.13_win-py2.6%20slave-win/builds/161
:
- svn update
- svn info
- python.exe bootstrap.py
- bin\buildout.exe
- bin\test.exe

Regards
Simon
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-02-28 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

On 02/28/2011 06:58 AM, Zope Tests Summarizer wrote:

 Subject: FAILED : Zope Buildbot / zopetoolkit-1.1_win-py2.5 slave-win
 From: jdriessen at thehealthagency.com
 Date: Sun Feb 27 10:06:05 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033318.html

This is an build failure:  tests fail with import errors for BTrees, but
the buildout step does not show failure.


 Subject: FAILED : ZTK 1.0dev / Python2.4.6 Linux 64bit
 From: ccomb at free.fr
 Date: Sun Feb 27 22:13:21 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033369.html
 
 Subject: FAILED : ZTK 1.0dev / Python2.6.5 Linux 64bit
 From: ccomb at free.fr
 Date: Sun Feb 27 22:13:54 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033370.html
 
 Subject: FAILED : ZTK 1.0dev / Python2.5.5 Linux 64bit
 From: ccomb at free.fr
 Date: Sun Feb 27 22:14:06 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033371.html

The ZTK 1.0 dev builds blow up inside the unit tests for
zope.app.server, where one of the tests appears to hang, but not produce
output:

- -- % 
$ svn co $ZSVN/zopetoolkit/branches/1.0 ztk-1.0
$ cd ztk-1.0
$ /opt/Python-2.6.5/bin/python bootstrap  bin/buildout
...
$ bin/test-zopeapp-zope.app.server
all tests pass
$ bin/develop -c zope.app.server  bin/buildout
...
$ bin/test-zopeapp-zope.app.server
all tests still pass
$ bin/develop -c zope.*  bin/buildout
$ bin/test-zopeapp-zope.app.server -vvD
...
Running zope.testing.testrunner.layer.UnitTests tests:
  Set up zope.testing.testrunner.layer.UnitTests in 0.000 seconds.
  Running:
 test_config_without_handlers
(zope.app.server.tests.test_accesslog.TestAccessLogging)
...
 test_get_password_manager
(zope.app.server.tests.test_mkzopeinstance.InputCollectionTestCase)
- -- % 

I hope that is enough information for somebody who knows the zope.app
code to fix the tests.  If not, I suggest we drop the ZTK 1.0 tests,
given that we aren't changing that package set actively, and that we
don't have resources to keep the tests green.


 Subject: FAILED : winbot / z3c.form_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 22:26:08 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033372.html
 
 Subject: FAILED : winbot / z3c.rml_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 22:50:50 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033373.html
 
 Subject: FAILED : winbot / z3c.template_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 22:59:35 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033374.html
 
 Subject: FAILED : winbot / z3c.layer.ready2go_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:05:09 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033376.html
 
 Subject: FAILED : winbot / z3c.formui_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:06:47 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033377.html
 
 Subject: FAILED : winbot / z3c.tabular_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:09:10 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033378.html
 
 Subject: FAILED : winbot / z3c.contents_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:10:09 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033379.html
 
 Subject: FAILED : winbot / z3c.ptcompat_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:28:15 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033380.html
 
 Subject: FAILED : winbot / z3c.pdftemplate_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:32:28 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033381.html
 
 Subject: FAILED : winbot / z3c.coverage_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:33:48 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033382.html
 
 Subject: FAILED : winbot / z3c.macro_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:34:49 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033383.html
 
 Subject: FAILED : winbot / z3c.pagelet_py_265_32
 From: buildbot at winbot.zope.org
 Date: Sun Feb 27 23:39:04 EST 2011
 URL: http://mail.zope.org/pipermail/zope-tests/2011-February/033384.html


I also suggest dropping the test reports for the z3c.* packages:  they
have been broken since the day they were added, AFAICT, which is a
strong signal that they are not being maintained.

The point of the daily reports is to *keep the board green*, so that
when a new failure shows up, we *feel* motivated to fix it.  Cluttering
the report with repeated-and-apparently-never-gonna-fix failures is
demotivating, which is the opposite of 

Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-02-28 Thread Stephan Richter
On Monday, February 28, 2011, Tres Seaver wrote:
 I also suggest dropping the test reports for the z3c.* packages:  they
 have been broken since the day they were added, AFAICT, which is a
 strong signal that they are not being maintained.

The problem is merely that lxml cannot be installed. This is more a winbot 
setup problem than a package one. And the reason lxml cannot be built is 
because libxml is missing.

This is really strange, since there are binaries available for lxml-2.3 for 
Python 2.6.

http://pypi.python.org/pypi/lxml/2.3

Does anyone with Windows Foo have any idea?

Regards,
Stephan
-- 
Entrepreneur and Software Geek
Google me. Zope Stephan Richter
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] Zope Tests: 71 OK, 16 Failed

2011-02-28 Thread Simon Elbaz
On windows, after installing python 2.6.6 (
http://www.python.org/ftp/python/2.6.6/python-2.6.6.msi), the compilation
ends ok with the following dos commands:

set PATH=c:\Python26;%PATH%
cd /path/to/z3c.form-2.4.2
python.exe bootstrap.py
bin\buildout.exe

After that, running bin\test.exe ends with:

  Ran 75 tests with 1 failures and 19 errors in 30.907 seconds.
Tearing down left over layers:
  Tear down zope.testrunner.layer.UnitTests in 0.000 seconds.

Simon

On Mon, Feb 28, 2011 at 8:08 PM, Stephan Richter 
srich...@cosmos.phy.tufts.edu wrote:

 On Monday, February 28, 2011, Tres Seaver wrote:
  I also suggest dropping the test reports for the z3c.* packages:  they
  have been broken since the day they were added, AFAICT, which is a
  strong signal that they are not being maintained.

 The problem is merely that lxml cannot be installed. This is more a winbot
 setup problem than a package one. And the reason lxml cannot be built is
 because libxml is missing.

 This is really strange, since there are binaries available for lxml-2.3 for
 Python 2.6.

 http://pypi.python.org/pypi/lxml/2.3

 Does anyone with Windows Foo have any idea?

 Regards,
 Stephan
 --
 Entrepreneur and Software Geek
 Google me. Zope Stephan Richter
 ___
 Zope-Dev maillist  -  Zope-Dev@zope.org
 https://mail.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  https://mail.zope.org/mailman/listinfo/zope-announce
  https://mail.zope.org/mailman/listinfo/zope )

___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )