Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-21 Thread Jan-Jaap Driessen
Hi Marius, On 18 February 2011 17:34, Marius Gedminas mar...@gedmin.as wrote: On Fri, Feb 18, 2011 at 09:21:12AM +0100, Jan-Jaap Driessen wrote: Thank you for looking into this. I am kind of happy that the error can be reproduced on a different windows machine. Tres, It is indeed 'special'

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-19 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 02/18/2011 04:47 PM, Tres Seaver wrote: zope.dublincore.tests.test_timeannotators less strict? I am not a pypi owner of zope.dublincore, so Tres, could you do the honors? I made a stab at fixing the regex. If the dev checkouts start

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-18 Thread Jan-Jaap Driessen
On 18 February 2011 00:55, Simon Elbaz elbazsim...@gmail.com wrote: Hi, I have tried this code on Python 2.7.1 (r271:86832, Nov 27 2010, 18:30:46) [MSC v.1500 32 bit (Intel)] on win32. It seems that it is possible to have no milliseconds returned by datetime.now. while 1: ...    

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-18 Thread Adam GROSZER
Hello, On Thu, 17 Feb 2011 10:58:35 -0500 you wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 02/17/2011 06:58 AM, Zope Tests Summarizer wrote: Subject: FAILED : Zope Buildbot / zopetoolkit-1.1_win-py2.5 slave-win From: jdriessen at thehealthagency.com Date: Wed Feb 16 15:03:12

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-18 Thread Martijn Pieters
On Fri, Feb 18, 2011 at 10:39, Adam GROSZER agroszer...@gmail.com wrote: Windowze... We also have such a failure 1 in 50 buildbot runs. Tho very misterious how it could happen 3x in a row. If the failure is random, with a chance of 1 in 50, 3 times in a row is no mystery. It shows the failure

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-18 Thread Marius Gedminas
On Fri, Feb 18, 2011 at 09:21:12AM +0100, Jan-Jaap Driessen wrote: Thank you for looking into this. I am kind of happy that the error can be reproduced on a different windows machine. Tres, It is indeed 'special' that this error occurs only now. The windows builds for zope.dublincore

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-18 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 02/18/2011 03:21 AM, Jan-Jaap Driessen wrote: On 18 February 2011 00:55, Simon Elbaz elbazsim...@gmail.com wrote: Hi, I have tried this code on Python 2.7.1 (r271:86832, Nov 27 2010, 18:30:46) [MSC v.1500 32 bit (Intel)] on win32. It seems that

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-17 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 02/17/2011 06:58 AM, Zope Tests Summarizer wrote: Subject: FAILED : Zope Buildbot / zopetoolkit-1.1_win-py2.5 slave-win From: jdriessen at thehealthagency.com Date: Wed Feb 16 15:03:12 EST 2011 URL:

Re: [Zope-dev] Zope Tests: 72 OK, 15 Failed

2011-02-17 Thread Simon Elbaz
Hi, I have tried this code on Python 2.7.1 (r271:86832, Nov 27 2010, 18:30:46) [MSC v.1500 32 bit (Intel)] on win32. It seems that it is possible to have no milliseconds returned by datetime.now. while 1: ... datetime.now(pytz.utc) datetime.datetime(2011, 2, 17, 23, 48, 17, 984000,