Re: [Zope-dev] Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-09 Thread Tony McDonald
Thanks again for the reply Dieter, On 6 Feb 2004, at 21:14, Dieter Maurer wrote: REQUEST.RESPONSE is set up in ZServer.HTTPServer.zhttp_handler.continue_request. It should be impossible that is is None. Agreed. Maybe, we have a memory corruption. I have seen objects magically becoming None in

Re: [Zope-dev] Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-06 Thread Dieter Maurer
Tony McDonald wrote at 2004-2-5 19:29 +: ... Looks like RESPONSE is None. I do not see how this can happen... Exactly! - this is why I said I'd never seen this before. It's a 2.6.1 Data.fs that's been dropped into a stock 2.7.0rc2 release and I get this error. Whether or not RESPONSE

Re: [Zope-dev] Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-05 Thread Dieter Maurer
Tony McDonald wrote at 2004-2-5 12:43 +: ... We have an index_html (initially DTML document, then tried method) that can be created (located at /prototype/myporfolio/index_html), have it's security settings changed quite happily. Then when the object is called we get the error in the

Re: [Zope-dev] Zope2.7.0rc2 AttributeError: 'NoneType' object has no attribute 'setHeader'

2004-02-05 Thread Tony McDonald
Thanks for the response Dieter, On 5 Feb 2004, at 18:51, Dieter Maurer wrote: Tony McDonald wrote at 2004-2-5 12:43 +: ... We have an index_html (initially DTML document, then tried method) that can be created (located at /prototype/myporfolio/index_html), have it's security settings