Re: [Zope-dev] zope-tests - FAILED: 5, OK: 8

2013-07-18 Thread Wichert Akkerman
On Jul 17, 2013, at 12:41 , Marius Gedminas mar...@gedmin.as wrote:
 
 I'm somewhat ashamed to admit that I don't know how to do that.
 
 Normally I get setuptools with sudo apt-get install python-setuptools,
 or by creating a virtualenv.

I have setuptools 0.9.1 deb packages if you need them. One additional thing I 
noticed that you most also take care to never pin setuptools to another version 
than your OS might have installed or buildout will break.

Wichert.

___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] zope-tests - FAILED: 5, OK: 8

2013-07-17 Thread Marius Gedminas
On Tue, Jul 16, 2013 at 07:08:39PM -0400, Tres Seaver wrote:
 On 07/16/2013 06:53 AM, Marius Gedminas wrote:
  Perhaps manually installing setuptools = 0.7 into c:\python2*_64
  would fix the failing builds?

Further evidence for this suggestion: winbot's c:/python26_32/python.exe has

import setuptools
setuptools.__file__
   '\\setuptools-0.7.1-...'

and works fine, while winbot's c:/python26_64/python.exe has

import setuptools
setuptools.__file__
   '\\distribute-0.6.44-...'

and doesn't.

 +1.  Let's just get past the distribute / old setuptools mess and get on
 with our lives.

I'm somewhat ashamed to admit that I don't know how to do that.

Normally I get setuptools with sudo apt-get install python-setuptools,
or by creating a virtualenv.

IIRC there's some sort of ez_setup.py that you can run?  Never mind, I
can read the fine manual: https://pypi.python.org/pypi/setuptools/0.9.5#windows

So, here's what I did:

 - rdesktop'ed into winbot
 - Control Panel - Add/Remove Programs
 - removed Python 2.6 setuptools 0.6c11 (it said it was already removed,
   so I just OK'ed removing the add/remove programs item)
 - removed Python 2.7 setuptools 0.6c11 (this time it said it removed 18
   files and directories)
 - left setuptools 0.6c11 installers for Python 2.4 and 2.5 alone
   because meh
 - launched Git bash
 - cd /c/Python26_64/Lib/site-packages
 - rm -rf setuptools* distribute*
 - cd /tmp
 - curl https://bitbucket.org/pypa/setuptools/downloads/ez_setup.py  
ez_setup.py
 - /c/Python26_64/python ez_setup.py
 - cd /c/Python27_64/Lib/site-packages
 - rm -rf setuptools* distribute*
 - cd /tmp
 - /c/Python27_64/python ez_setup.py

And now I'm wondering if those control panel installers were about
32-bit or 64-bit installs, and I wonder if I broke Python27_32 by
removing all traces of setuptools form there.  Let's check:

   $ /c/Python27_32/python
import setuptools
setuptools.__file__
   '\\distribute-0.6.44-...'

Huh?  And no builds failed on py_270_win32?  I don't understand, and I
don't _want_ to understand.  Let's just see what buildbots report
tomorrow.

Marius Gedminas
-- 
http://pov.lt/ -- Zope 3/BlueBream consulting and development


signature.asc
Description: Digital signature
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] zope-tests - FAILED: 5, OK: 8

2013-07-17 Thread Adam Groszer
Hi,

Yah well just leave it. I'll try to get to it.
I'll stash a recent setuptools into all pythons.


On Wed, Jul 17, 2013 at 12:41 PM, Marius Gedminas mar...@gedmin.as wrote:

 On Tue, Jul 16, 2013 at 07:08:39PM -0400, Tres Seaver wrote:
  On 07/16/2013 06:53 AM, Marius Gedminas wrote:
   Perhaps manually installing setuptools = 0.7 into c:\python2*_64
   would fix the failing builds?

 Further evidence for this suggestion: winbot's c:/python26_32/python.exe
 has

 import setuptools
 setuptools.__file__
'\\setuptools-0.7.1-...'

 and works fine, while winbot's c:/python26_64/python.exe has

 import setuptools
 setuptools.__file__
'\\distribute-0.6.44-...'

 and doesn't.

  +1.  Let's just get past the distribute / old setuptools mess and get on
  with our lives.

 I'm somewhat ashamed to admit that I don't know how to do that.

 Normally I get setuptools with sudo apt-get install python-setuptools,
 or by creating a virtualenv.

 IIRC there's some sort of ez_setup.py that you can run?  Never mind, I
 can read the fine manual:
 https://pypi.python.org/pypi/setuptools/0.9.5#windows

 So, here's what I did:

  - rdesktop'ed into winbot
  - Control Panel - Add/Remove Programs
  - removed Python 2.6 setuptools 0.6c11 (it said it was already removed,
so I just OK'ed removing the add/remove programs item)
  - removed Python 2.7 setuptools 0.6c11 (this time it said it removed 18
files and directories)
  - left setuptools 0.6c11 installers for Python 2.4 and 2.5 alone
because meh
  - launched Git bash
  - cd /c/Python26_64/Lib/site-packages
  - rm -rf setuptools* distribute*
  - cd /tmp
  - curl https://bitbucket.org/pypa/setuptools/downloads/ez_setup.py 
 ez_setup.py
  - /c/Python26_64/python ez_setup.py
  - cd /c/Python27_64/Lib/site-packages
  - rm -rf setuptools* distribute*
  - cd /tmp
  - /c/Python27_64/python ez_setup.py

 And now I'm wondering if those control panel installers were about
 32-bit or 64-bit installs, and I wonder if I broke Python27_32 by
 removing all traces of setuptools form there.  Let's check:

$ /c/Python27_32/python
 import setuptools
 setuptools.__file__
'\\distribute-0.6.44-...'

 Huh?  And no builds failed on py_270_win32?  I don't understand, and I
 don't _want_ to understand.  Let's just see what buildbots report
 tomorrow.

 Marius Gedminas
 --
 http://pov.lt/ -- Zope 3/BlueBream consulting and development

 ___
 Zope-Dev maillist  -  Zope-Dev@zope.org
 https://mail.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  https://mail.zope.org/mailman/listinfo/zope-announce
  https://mail.zope.org/mailman/listinfo/zope )


___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] zope-tests - FAILED: 5, OK: 8

2013-07-17 Thread Adam Groszer
Done.

What I did is for every python version installed there:
- clean any remnants manually of setuptools/distribute in site-packages
- get a tarball of the latest setuptools (0.9.5), untarred it
- installed setuptools from the source:
C:\install\setuptools-0.9.5c:\Python33_64\python.exe setup.py install

as next I'll update c:\Python33_(32|64) to 3.3.2, because currently it's
just 3.3.0


On Wed, Jul 17, 2013 at 12:56 PM, Adam Groszer agros...@gmail.com wrote:

 Hi,

 Yah well just leave it. I'll try to get to it.
 I'll stash a recent setuptools into all pythons.


 On Wed, Jul 17, 2013 at 12:41 PM, Marius Gedminas mar...@gedmin.aswrote:

 On Tue, Jul 16, 2013 at 07:08:39PM -0400, Tres Seaver wrote:
  On 07/16/2013 06:53 AM, Marius Gedminas wrote:
   Perhaps manually installing setuptools = 0.7 into c:\python2*_64
   would fix the failing builds?

 Further evidence for this suggestion: winbot's c:/python26_32/python.exe
 has

 import setuptools
 setuptools.__file__
'\\setuptools-0.7.1-...'

 and works fine, while winbot's c:/python26_64/python.exe has

 import setuptools
 setuptools.__file__
'\\distribute-0.6.44-...'

 and doesn't.

  +1.  Let's just get past the distribute / old setuptools mess and get on
  with our lives.

 I'm somewhat ashamed to admit that I don't know how to do that.

 Normally I get setuptools with sudo apt-get install python-setuptools,
 or by creating a virtualenv.

 IIRC there's some sort of ez_setup.py that you can run?  Never mind, I
 can read the fine manual:
 https://pypi.python.org/pypi/setuptools/0.9.5#windows

 So, here's what I did:

  - rdesktop'ed into winbot
  - Control Panel - Add/Remove Programs
  - removed Python 2.6 setuptools 0.6c11 (it said it was already removed,
so I just OK'ed removing the add/remove programs item)
  - removed Python 2.7 setuptools 0.6c11 (this time it said it removed 18
files and directories)
  - left setuptools 0.6c11 installers for Python 2.4 and 2.5 alone
because meh
  - launched Git bash
  - cd /c/Python26_64/Lib/site-packages
  - rm -rf setuptools* distribute*
  - cd /tmp
  - curl https://bitbucket.org/pypa/setuptools/downloads/ez_setup.py 
 ez_setup.py
  - /c/Python26_64/python ez_setup.py
  - cd /c/Python27_64/Lib/site-packages
  - rm -rf setuptools* distribute*
  - cd /tmp
  - /c/Python27_64/python ez_setup.py

 And now I'm wondering if those control panel installers were about
 32-bit or 64-bit installs, and I wonder if I broke Python27_32 by
 removing all traces of setuptools form there.  Let's check:

$ /c/Python27_32/python
 import setuptools
 setuptools.__file__
'\\distribute-0.6.44-...'

 Huh?  And no builds failed on py_270_win32?  I don't understand, and I
 don't _want_ to understand.  Let's just see what buildbots report
 tomorrow.

 Marius Gedminas
 --
 http://pov.lt/ -- Zope 3/BlueBream consulting and development

 ___
 Zope-Dev maillist  -  Zope-Dev@zope.org
 https://mail.zope.org/mailman/listinfo/zope-dev
 **  No cross posts or HTML encoding!  **
 (Related lists -
  https://mail.zope.org/mailman/listinfo/zope-announce
  https://mail.zope.org/mailman/listinfo/zope )



___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] zope-tests - FAILED: 5, OK: 8

2013-07-16 Thread Marius Gedminas
On Tue, Jul 16, 2013 at 01:00:02AM +0200, Zope tests summarizer wrote:
 [1]FAILED  winbot / ZODB_dev py_265_win64
https://mail.zope.org/pipermail/zope-tests/2013-July/077848.html
 
 [2]FAILED  winbot / ZODB_dev py_270_win64
https://mail.zope.org/pipermail/zope-tests/2013-July/077850.html
 
 [3]FAILED  winbot / ztk_10 py_265_win64
https://mail.zope.org/pipermail/zope-tests/2013-July/077841.html
 
 [4]FAILED  winbot / ztk_11 py_265_win64
https://mail.zope.org/pipermail/zope-tests/2013-July/077844.html
 
 [5]FAILED  winbot / ztk_11 py_270_win64
https://mail.zope.org/pipermail/zope-tests/2013-July/077846.html

All of these fail with

  ImportError: No module named pkg_resources

All of them use c:\Python27_64\python.exe

Some of them use c:\buildmaster\bootstrap.py, and some of them use a local
bootstrap.py.  In all cases bootstrap downloads
http://pypi.python.org/packages/2.6/s/setuptools/setuptools-0.6c11-py2.6.egg

I went through the list of winbot builders that work on win64, and found
only this (and a few setuptools builders that don't use buildout):
http://winbot.zope.org/builders/BlueBream_dev%20py_270_win64/builds/219

This is BlueBream on Python 2.7 (win64).  It downloads
http://pypi.python.org/packages/source/d/distribute/distribute-0.6.34.tar.gz

Incidentally, BlueBream on Python 2.6 (win64) fails bootstrap with
pkg_resources.VersionConflict: (setuptools 0.6c11 
(c:\python26_64\lib\site-packages\setuptools-0.6c11-py2.6.egg), 
Requirement.parse('setuptools=0.7'))

Suggestion: compare the versions of setuptools in
c:\python2*_64\lib\site-packages with versions in
c:\python2*_32\lib\site-packages, see if there's a pattern.

Perhaps manually installing setuptools = 0.7 into c:\python2*_64 would
fix the failing builds?

Marius Gedminas
-- 
http://pov.lt/ -- Zope 3/BlueBream consulting and development


signature.asc
Description: Digital signature
___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] zope-tests - FAILED: 5, OK: 8

2013-07-16 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

On 07/16/2013 06:53 AM, Marius Gedminas wrote:
 Perhaps manually installing setuptools = 0.7 into c:\python2*_64
 would fix the failing builds?

+1.  Let's just get past the distribute / old setuptools mess and get on
with our lives.


Tres.
- -- 
===
Tres Seaver  +1 540-429-0999  tsea...@palladion.com
Palladion Software   Excellence by Designhttp://palladion.com
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iEYEARECAAYFAlHl0ncACgkQ+gerLs4ltQ4OnwCeMQxGaJC2DPeibq1mGbf4iTqW
2fsAoKvfK1zVOD7LY9vqbC8i2sCr7/Ju
=yL1D
-END PGP SIGNATURE-

___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )


Re: [Zope-dev] zope-tests - FAILED: 5, OK: 8

2013-05-10 Thread Tres Seaver
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

On 05/10/2013 09:00 PM, Zope tests summarizer wrote:
 [2]FAILED  winbot / ZODB_dev py_265_win32 
 https://mail.zope.org/pipermail/zope-tests/2013-May/074321.html
 
 
 [3]FAILED  winbot / ZODB_dev py_265_win64 
 https://mail.zope.org/pipermail/zope-tests/2013-May/074322.html
 
 
 [4]FAILED  winbot / ZODB_dev py_270_win32 
 https://mail.zope.org/pipermail/zope-tests/2013-May/074323.html
 
 
 [5]FAILED  winbot / ZODB_dev py_270_win64 
 https://mail.zope.org/pipermail/zope-tests/2013-May/074324.html

These are all Windows-only failures, due to my attempt to clean up the
use of 'tempfile.mktemp':  I have reverted that change, and expect those
tests to pass now.


Tres.
- -- 
===
Tres Seaver  +1 540-429-0999  tsea...@palladion.com
Palladion Software   Excellence by Designhttp://palladion.com
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iEYEARECAAYFAlGNz7kACgkQ+gerLs4ltQ4jSQCeOwKOlVul9Dykks4JyMeIozp8
jB0An0HW00rmSeXtKcsDGD0CNkdCIp2U
=3zmJ
-END PGP SIGNATURE-

___
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )