Re: [zope-pt] Maximização minimização e restauração de portlets

2006-09-18 Por tôpico JJ (Arnaldo Janz Júnior)
Tom,Ainda não usei mas, pelo que sei, o PlonePortlets [1], que já - bom, na minha opinião, demorou um bocado, mas deve ter lá seus motivos ... - tem proposta (em progresso) de ser incorporado à próxima versão do Plone [2], faz isso. [1] http://plone.org/products/ploneportlets[2]

[zope-pt] Problemas ao gravar registro?

2006-09-18 Por tôpico pythondeveloper
Salve galera. Estou tendo um problema ao gravar um registro no SGBD, quando tento gravar toda a string é alterada ficando assim Previsão de Grãos. O mais estranho é que quando mando gravar diretamente pela ZSql grava blzinha, mas pelo Plone não. O plone esta usando no default-charset

Re: [zope-pt] Problemas ao gravar registro?

2006-09-18 Por tôpico José Henrique
Aparentemente seu banco de dados não está configurado para gravar em utf-8. Zénrique. Em 18/09/06, pythondeveloper[EMAIL PROTECTED] escreveu: Salve galera. Estou tendo um problema ao gravar um registro no SGBD, quando tento gravar toda a string é alterada ficando assim Previsão de

Re: [zope-pt] Problemas ao gravar registro?

2006-09-18 Por tôpico Breno Alvernaz
Fernando,Você está gravando o registro no BD pelo ZSQL - BD ou pelo Python Script - ZSQL - BD?Eu aconselho à usar o Python Script - ZSQL - BD.Breno.pythondeveloper [EMAIL PROTECTED] escreveu:Salve galera. Estou tendo um problema ao gravar um registro no SGBD, quando tento gravar toda a

[zope-pt] (unknown)

2006-09-18 Por tôpico gracascheuermann
Como eu faço então para configurar ? -- Aparentemente seu banco de dados não está configurado para gravar em utf-8. Zénrique. Em 18/09/06, pythondeveloper[EMAIL PROTECTED] escreveu: Salve galera. Estou tendo um problema ao gravar um registro no SGBD, quando tento gravar toda a string é

Re: [zope-pt] (unknown)

2006-09-18 Por tôpico Walter Cruz
qual é o seu banco de dados?PostgreSQL? MySQL? outro?On 9/18/06, gracascheuermann [EMAIL PROTECTED] wrote:Como eu faço então para configurar ?--Aparentemente seu banco de dados não está configurado para gravar em utf-8. Zénrique.Em 18/09/06, pythondeveloper[EMAIL PROTECTED] escreveu: Salve

[zope-pt] IP via python no Archetype

2006-09-18 Por tôpico João Paulo Sinieghi
Boa tarde pessoal... Criei um Produto em Archetype e um dos fields eu quero colocar o IP da máquina do cliente como valor inicial do field. Então criei uma função dentro do meu Archetype: def pega_IP(self): ip = socket.gethostbyaddr(socket.gethostname()) ip_nome = ip[2]

[zope-pt] (unknown)

2006-09-18 Por tôpico gracascheuermann
MySQL qual é o seu banco de dados? PostgreSQL? MySQL? outro? On 9/18/06, gracascheuermann [EMAIL PROTECTED] wrote: Como eu faço então para configurar ? -- Aparentemente seu banco de dados não está configurado para gravar em utf-8. Zénrique. Em 18/09/06, pythondeveloper[EMAIL PROTECTED]

[zope-pt] Re: Problemas ao gravar registro?

2006-09-18 Por tôpico pythondeveloper
Como eu ja havia falado antes, estou usando PostgreSql7.4.1. Quando mando gravar pela ZSql na aba Test, grava blzinha e não altera as acentuações, mas quando mando gravar pelo form do CPT é que acontece o erro PrevisÃ#402;£o de GrÃ#402;£os, e além disso tenho um sistema ERP que usa essa

Re: [zope-pt] Problemas ao gravar registro?

2006-09-18 Por tôpico Fernando Paiva
Opa, Como eu disse eu criei um Zsql que da um INSERT em uma tabela, e criei o form no CPT, quando gravo um registro pelo CPT/CPY ele grava assim Previsão de Grãos, ja quando eu gravo pelo Zsql diretamente pela aba Test, grava normal. Quando mando o CPY imprimir o valor do input ele tbm

Re: [zope-pt] Problemas ao gravar registro?

2006-09-18 Por tôpico José Henrique
Fernando, Você consegue gravar no BD, por meio da ZMI, porque provavelmente seu Zope, está configurado para ISO8859-1. Para ver se é isso, verifique seu arquivo zope.conf. Se for isso, e você não puder alterar a configuração do seu BD, então uma possível solução seria codificar suas strings

[zope-pt] Re: Problemas ao gravar registro?

2006-09-18 Por tôpico pythondeveloper
Opa Zé. No zope.conf do zope2.8 tenho apenas essas linhas que se referem a encoding. rest-input-encoding utf-8 rest-output-encoding utf-8 Estas linhas estão comentadas #, ja removi os comentarios e não tive resultados. Estou tentando alterar o CPY assim variavel = request.get('variavel')

[zope-pt] Re: Problemas ao gravar registro?

2006-09-18 Por tôpico pythondeveloper
Encontrei esse exemplo do Rizzo. http://www.tchezope.org/Members/fabrizmat/artigos/zope/UnicodeEncodeError/view Mas quando carrego o interpretador continua exibindo 'iso-8859-1'. import sys sys.getdefaultencoding() 'iso-8859-1' aff, que coisa estranha :S []'s Fernando Paiva --- Em