Re: [ZWeb] svn server broken

2008-11-11 Thread Shane Hathaway
Martijn Faassen wrote:
 If it's possible to make http://svn.zope.org do a clear sorry, i'm
 not here instead of the current behavior where the browser is
 spinning when you try to access it, that might help. If this is too
 distracting currently, please ignore this message - I'm not even sure
 whether this fixes my issues.

You can often work around problems like this by adding fake host entries
to /etc/hosts on systems you control, e.g.:

  127.0.0.1 svn.zope.org

Windows has (had?) a similar facility.

Shane

___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-10 Thread Jim Fulton

On Nov 10, 2008, at 7:01 AM, Christian Theune wrote:

 On Mon, 2008-11-10 at 02:40 -0500, David Lawson wrote:
 Sorry, svn.zope.org experienced a hardware failure earlier in the day
 which we believed we had remediated, but which has re-surfaced as
 something more serious.  We're working on getting it resolved and
 should have it back up soon, hopefully before noon EST.

 I'm with Martijn here. I'm happy you take care of the machine, but  
 noon
 EST is a full working day in Europe without svn.zope.org. That's a lot
 of buildout processes hanging. So, please, pretty please, can you make
 the machine fail gracefully for the outside world and not have  
 dangling
 connections?


Unfortunately we can't. The file system on that machine isn't  
currently allowing writes. :(

Jim

--
Jim Fulton
Zope Corporation


___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-10 Thread Andrew Sawyers
If you blocked it at the load balancer or router, that would help in their
regard until the issue is fixed

Andrew


On 11/10/08 2:21 PM, Jim Fulton [EMAIL PROTECTED] wrote:

 
 On Nov 10, 2008, at 7:01 AM, Christian Theune wrote:
 
 On Mon, 2008-11-10 at 02:40 -0500, David Lawson wrote:
 Sorry, svn.zope.org experienced a hardware failure earlier in the day
 which we believed we had remediated, but which has re-surfaced as
 something more serious.  We're working on getting it resolved and
 should have it back up soon, hopefully before noon EST.
 
 I'm with Martijn here. I'm happy you take care of the machine, but
 noon
 EST is a full working day in Europe without svn.zope.org. That's a lot
 of buildout processes hanging. So, please, pretty please, can you make
 the machine fail gracefully for the outside world and not have
 dangling
 connections?
 
 
 Unfortunately we can't. The file system on that machine isn't
 currently allowing writes. :(
 
 Jim
 
 --
 Jim Fulton
 Zope Corporation
 
 
 ___
 Zope-web maillist  -  Zope-web@zope.org
 http://mail.zope.org/mailman/listinfo/zope-web


___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-10 Thread Christian Theune
On Mon, 2008-11-10 at 09:21 -0500, Jim Fulton wrote:
 On Nov 10, 2008, at 7:01 AM, Christian Theune wrote:
 
  On Mon, 2008-11-10 at 02:40 -0500, David Lawson wrote:
  Sorry, svn.zope.org experienced a hardware failure earlier in the day
  which we believed we had remediated, but which has re-surfaced as
  something more serious.  We're working on getting it resolved and
  should have it back up soon, hopefully before noon EST.
 
  I'm with Martijn here. I'm happy you take care of the machine, but  
  noon
  EST is a full working day in Europe without svn.zope.org. That's a lot
  of buildout processes hanging. So, please, pretty please, can you make
  the machine fail gracefully for the outside world and not have  
  dangling
  connections?
 
 
 Unfortunately we can't. The file system on that machine isn't  
 currently allowing writes. :(

Argh! You might be able to kill the processes that own the listen
socket ... 

-- 
Christian Theune · [EMAIL PROTECTED]
gocept gmbh  co. kg · forsterstraße 29 · 06112 halle (saale) · germany
http://gocept.com · tel +49 345 1229889 7 · fax +49 345 1229889 1
Zope and Plone consulting and development


signature.asc
Description: This is a digitally signed message part
___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-10 Thread Christian Theune
On Mon, 2008-11-10 at 02:40 -0500, David Lawson wrote:
 Sorry, svn.zope.org experienced a hardware failure earlier in the day  
 which we believed we had remediated, but which has re-surfaced as  
 something more serious.  We're working on getting it resolved and  
 should have it back up soon, hopefully before noon EST.

I'm with Martijn here. I'm happy you take care of the machine, but noon
EST is a full working day in Europe without svn.zope.org. That's a lot
of buildout processes hanging. So, please, pretty please, can you make
the machine fail gracefully for the outside world and not have dangling
connections?

Thanks!

Christian

-- 
Christian Theune · [EMAIL PROTECTED]
gocept gmbh  co. kg · forsterstraße 29 · 06112 halle (saale) · germany
http://gocept.com · tel +49 345 1229889 7 · fax +49 345 1229889 1
Zope and Plone consulting and development


signature.asc
Description: This is a digitally signed message part
___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-09 Thread Jim Fulton

On Nov 9, 2008, at 7:21 AM, Jens Vagelpohl wrote:

 -BEGIN PGP SIGNED MESSAGE-
 Hash: SHA1


 On Nov 9, 2008, at 13:05 , Michael Haubenwallner wrote:

 A 'svn up' at svn.zope.org returns an error atm:

 svn: Can't find a temporary directory: Error string not specified yet

 I have poked around a little bit and it appears there's a hard drive
 issue on the box. I have alerted the Zope Corp SAs and Jim, there's
 nothing I can do from here.


Thanks Jens.  We're investigating.

Jim

--
Jim Fulton
Zope Corporation


___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-09 Thread Jens Vagelpohl
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1


On Nov 9, 2008, at 13:05 , Michael Haubenwallner wrote:

 A 'svn up' at svn.zope.org returns an error atm:

  svn: Can't find a temporary directory: Error string not specified yet

I have poked around a little bit and it appears there's a hard drive  
issue on the box. I have alerted the Zope Corp SAs and Jim, there's  
nothing I can do from here.

jens



-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.8 (Darwin)

iEYEARECAAYFAkkW1eAACgkQRAx5nvEhZLIZyQCcCHYZgA248TtlNaQCETkK0iDh
zusAoJCqQL4EFZ+DbdhrScYY9mtowG/k
=OOnl
-END PGP SIGNATURE-
___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-09 Thread Christian Theune
On Sun, 2008-11-09 at 13:21 +0100, Jens Vagelpohl wrote:
 -BEGIN PGP SIGNED MESSAGE-
 Hash: SHA1
 
 
 On Nov 9, 2008, at 13:05 , Michael Haubenwallner wrote:
 
  A 'svn up' at svn.zope.org returns an error atm:
 
   svn: Can't find a temporary directory: Error string not specified yet
 
 I have poked around a little bit and it appears there's a hard drive  
 issue on the box. I have alerted the Zope Corp SAs and Jim, there's  
 nothing I can do from here.

Ah. That's why the KGS updates are lagging.

-- 
Christian Theune · [EMAIL PROTECTED]
gocept gmbh  co. kg · forsterstraße 29 · 06112 halle (saale) · germany
http://gocept.com · tel +49 345 1229889 7 · fax +49 345 1229889 1
Zope and Plone consulting and development


signature.asc
Description: This is a digitally signed message part
___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-09 Thread Martijn Faassen
Hi there,

Before noticing svn.zope.org was down, I noticed that buildouts seem
to be failing/hanging somewhere in httplib. I now suspect this is
possibly because various setup.py's have a 'url' entry that references
svn.zope.org and setuptools might go off and try to read it, resulting
in a hang of the buildout process.

If it's possible to make http://svn.zope.org do a clear sorry, i'm
not here instead of the current behavior where the browser is
spinning when you try to access it, that might help. If this is too
distracting currently, please ignore this message - I'm not even sure
whether this fixes my issues.

Regards,

Martijn
___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web


Re: [ZWeb] svn server broken

2008-11-09 Thread David Lawson
Sorry, svn.zope.org experienced a hardware failure earlier in the day  
which we believed we had remediated, but which has re-surfaced as  
something more serious.  We're working on getting it resolved and  
should have it back up soon, hopefully before noon EST.

--Dave
On Nov 10, 2008, at 2:36 AM, Martijn Faassen wrote:

 Hi there,

 Before noticing svn.zope.org was down, I noticed that buildouts seem
 to be failing/hanging somewhere in httplib. I now suspect this is
 possibly because various setup.py's have a 'url' entry that references
 svn.zope.org and setuptools might go off and try to read it, resulting
 in a hang of the buildout process.

 If it's possible to make http://svn.zope.org do a clear sorry, i'm
 not here instead of the current behavior where the browser is
 spinning when you try to access it, that might help. If this is too
 distracting currently, please ignore this message - I'm not even sure
 whether this fixes my issues.

 Regards,

 Martijn
 ___
 Zope-web maillist  -  Zope-web@zope.org
 http://mail.zope.org/mailman/listinfo/zope-web

Systems Administrator
Zope Corp.
540-361-1722
[EMAIL PROTECTED]



___
Zope-web maillist  -  Zope-web@zope.org
http://mail.zope.org/mailman/listinfo/zope-web