Currently, if you have an action defined with a label that
is not an identifier:

  @form.action(_("Return for changes"))
  def return_for_changes(form, action):
     ...

The submit button name will be converted to hex
(e.g. form.actions.52657475726e20666f72206368616e676573).

I propose that we use the action handler name instead
(e.g. form.actions.return_for_changes).

This is likely to affect tests that involve sample generated forms
or form input.  In the long run, it will make these tests more readable.

Any objections?

Jim

--
Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org
_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to