Re: [Zope-dev] Re: [Zope3-dev] Google Summer of Code

2007-03-14 Thread Martijn Pieters

On 3/14/07, Baiju M [EMAIL PROTECTED] wrote:

I think you added (by mistake?) this link instead:
http://pyre.third-bit.com/blog/archives/863.html


Whoops, indeed, that's not the right one. Blame late night
inattention, brought on by a better half asking when I was going to be
done. ;)


I found this one also useful:
http://primates.ximian.com/~federico/docs/summer-of-code-mentoring-howto/index.html


That's the correct link! Corrected on the Wiki. :) Thanks!

--
Martijn Pieters
___
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com



Re: [Zope-dev] Re: [Zope3-dev] Google Summer of Code

2007-03-14 Thread Baiju M

Hi,
   I have added a new page under this wiki page:
http://wiki.zope.org/zope3/SummerOfCode2007
to motivate students.  See the page here:
http://wiki.zope.org/zope3/Zope3UsingPython25
Please edit/correct that page details.

So far only four ideas are added to the wiki page.
No more ideas to add ?

Regards,
Baiju M

___
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com



[Zope3-dev] Re[2]: [Zope3-Users] correct display of Text field in a view

2007-03-14 Thread Adam Groszer
Hello Ivan,

I don't think that you'll need IMultiLineText and MultiLineText.
That's why IText and Text are there for. You'll have to register the
widget for IText or use it directly in your view with
CustomWidgetFactory.

In fact it's a good question why Z3 doesn't provide such a widget for
Text. The current widget is just Displaywidget which eats the
newlines.

BTW: br \ should be br /

Wednesday, March 14, 2007, 9:30:19 AM, you wrote:

 Darryl, Frank,

 thank you your answers, but finally i keep the widget solution
 instead of TextAreaWidget i inherited my widget from DisplayWidget, and
 of course used your replace solution.

 class IMultiLineText(IText):
 this field will be used for the comment because of the correct 
 display of html tags
   
 pass

 class MultiLineText(Text):
 the field implementation
 implements(IMultiLineText)

 class MultiLineTextWidget(DisplayWidget):
 the widget to display the description

 def __call__(self):
 return super(MultiLineTextWidget, 
 self).__call__().replace(\n,br \)



 Darryl Cousins wrote:
 On Fri, 2007-03-09 at 10:06 +0100, Ivan Horvath wrote:
   
 - modify the description widget data with 
 PlainTextToHTMLRenderer.render(), but then in the browser i can see
 only 
 encoded chars instead of br 
 

 Hi,

 As for Frank's suggestion try:

 p tal:content=structure view/description /

 when rendering the text2html content. That should allow the html tags
 through.

 Regards,
 Darryl



   




-- 
Best regards,
 Adammailto:[EMAIL PROTECTED]

___
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com



[Zope3-dev] Community opinion about search+filter

2007-03-14 Thread Adam Groszer
Hello,

I'd like to ask your opinion, your experiences about searching and
filtering in quite large object DBs.
We need to add search and filter functions to our current app, where
the user might be able to create quite _sophisticated_ filter criterias.
(The app is a pure Z3 app, subject is document management)

Currently we're looking at something based on catalog/indexes.
As I checked the most comfortable solution would be based on
hurry.query.
Some questions arose:
- Is it necessary/worth adding indexes on all attributes?
- How does the index perform on modification and retrieval?

The biggest problem is that this will be our first try, so we're
missing experiences and are a bit puzzled about the right solution.
Certain is that moving to RDB is not an option.

Thanks,

-- 
Best regards,
 Adam  mailto:[EMAIL PROTECTED]

___
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com



Re: [Zope3-dev] Community opinion about workflow engine

2007-03-14 Thread Philipp von Weitershausen

Stephan Richter wrote:

class Application(Contained, Persistent):
...
@apply
def stati():
See IApplication
def getStati(self):
return self._stati
def setStati(self, value):
removed = set(self._stati) - set(value)
added = set(value) - set(self._stati)
self._stati = tuple(value)
for item in removed:
zope.event.notify(StatusRemovedEvent(self, item))
for item in added:
zope.event.notify(StatusAddedEvent(self, item))
return property(getStati, setStati)


Apart from the quite confusing spelling of this property (I suggest 
something like http://cheeseshop.python.org/pypi/rwproperty for better 
readability), I just wanted to point out that stati is an incorrect 
Latin plural for status. The plural is simply status (the u being 
long in the plural, as opposed to being short in the singular). But as 
far as I know, the only accepted plural form in English is statuses.



--
http://worldcookery.com -- Professional Zope documentation and training

___
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com



Re: [Zope3-dev] Community opinion about search+filter

2007-03-14 Thread Baiju M

I think general questions can be posted to zope3-users list.
No need to cross-post it to zope3-dev list also.

Regards,
Baiju M
___
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com



[Zope3-dev] Re: [Zope3-Users] Community opinion about search+filter

2007-03-14 Thread Christophe Combelles

Adam Groszer a écrit :

Hello,

I'd like to ask your opinion, your experiences about searching and
filtering in quite large object DBs.
We need to add search and filter functions to our current app, where
the user might be able to create quite _sophisticated_ filter criterias.
(The app is a pure Z3 app, subject is document management)

Currently we're looking at something based on catalog/indexes.
As I checked the most comfortable solution would be based on
hurry.query.
Some questions arose:
- Is it necessary/worth adding indexes on all attributes?


it depends on what you need to search. You may want to index everything as a 
whole in each object, in which case you just need one index, based on an 
adapter's getsearchabletext method that returns some kind of concatenation of 
all attributes;
or you may want to be able to search in one particular attribute, so you have to 
create an index for this particular attribute.

The most important is deciding how is built the indices.
But I think there is no problem changing the indexation method, since reindexing 
is just a matter of clicking on a button, and waiting a some time.



- How does the index perform on modification and retrieval?


not sure to understand the question.

Christophe



The biggest problem is that this will be our first try, so we're
missing experiences and are a bit puzzled about the right solution.
Certain is that moving to RDB is not an option.

Thanks,



___
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com