[Zope3-dev] problems with Win buildinstall

2005-04-06 Thread Adam Groszer
I'm trying to build install the Zope 3 trunk on Win2K. I'm having some problems with it. May I post them here or is it too early for the upcoming release? Adam ___ Zope3-dev mailing list Zope3-dev@zope.org Unsub:

Re[6]: [Zope3-dev] problems with Win buildinstall

2005-04-07 Thread Adam Groszer
Hello Egon, Thank you, that's working. (never thought that it would be so simple) I've got MSVC6, so I can compile the pyd's. EF cd svn checkout dir EF python.exe bin\mkzopeinstance -u your user name:your EF password  -d the directory of your instance EF I forgot to write: you need the actual

Re[2]: [Zope3-dev] question about the FTP access log

2005-04-14 Thread Adam Groszer
Hello Stephan, OK, but the from viewpoint of a sysadmin wouldn't it be better to provide also the object retrieved? Imagine that you have some hundredrs of objects in a folder... Wednesday, April 13, 2005, 4:13:07 PM, you wrote: SR On Monday 11 April 2005 10:28, Adam Groszer wrote: The Zope3

[Zope3-dev] IService

2005-04-14 Thread Adam Groszer
I just tried the messageboard step08 example from Stephan's book. (Win32/current trunk) I know that the Service concept is deprecated, but I ran into an exception: File Y:\zope\svn_zope3\src\zope\app\site\service.py, line 48, in __init__ super(ServiceRegistration, self).__init__(name,

[Zope3-dev] ServerControlForm.html / Restart, Shutdown does not work

2005-07-16 Thread Adam Groszer
I think I found a bug. I'm using win2k, python 2.3.5, Zope trunk at 0. If I click Shutdown on the ServerControlForm.html it does not shutdown Zope, but responds with a simple You shut down the server. message in the browser and Zope is still working. I think the problem lies in the modified

[Zope3-dev] mail:queuedDelivery retrying forever?

2005-07-17 Thread Adam Groszer
As I'm checking through the zope book messageboard samples, I was so crazy that I entered an unknown e-mail address into the change subscriptions. It looks like that Zope is retrying to deliver the message forever... 2005-07-17T08:57:43 ERROR QueueProcessorThread Error while sending mail from

[Zope3-dev] checking zope3book examples

2005-07-17 Thread Adam Groszer
Dear All, I just checked through the messageboard sample of Stephan's book. I used win2k with python 2.3.5, Zope3 trunk version 0. checking with the tests, step10 failes with: from zope.app.file.interfaces import IFile, IFileContent ImportError: cannot import name IFileContent checking

Re[2]: [Zope3-dev] ServerControlForm.html / Restart, Shutdown does not work

2005-07-19 Thread Adam Groszer
Hello Tim, Monday, July 18, 2005, 6:38:12 PM, you wrote: snip TP Another: did this actually work before? The only place I've found TP that set LoopCallback.exit_status is TP zope/app/server/servercontrol.py, TP and both methods there have TODO: ... does not work yet comments TP (in both Zope

Re[4]: [Zope3-dev] ServerControlForm.html / Restart, Shutdown does not work

2005-07-19 Thread Adam Groszer
Hello Tim, Tuesday, July 19, 2005, 8:18:01 PM, you wrote: [Tim Peters] None of the above appears to have anything to do with LoopCallback, though, so if any of that used to work but doesn't anymore, there's a cause outside of the changes I made to LoopCallback. Best guess is that the stuff

[Zope3-dev] How to shutdown Zope3 gracefully?

2005-07-19 Thread Adam Groszer
[Adam Groszer] What do you say, can there be any data loss if I use the Shutdown button? Does Zope write everything out to disc before it quits? [Tim Peters] It didn't look to me like there's any code in Zope3 now supporting controlled (graceful) shutdown, although this is the first time I

[Zope3-dev] How to resolve bi-directionally navigable association?

2005-08-08 Thread Adam Groszer
Sorry for the crosspost, may I have some expert advice on the following: As the subject sais, how can I resolve bi-directionally navigable association in Z3? Both objects have to have references of each other, that means that also the schemas have to have references. class IItem(interface):

[Zope3-dev] typo

2005-08-10 Thread Adam Groszer
I found a typo in src/zope/app/applicationcontrol/browser/runtimeinfo.pt:42 as of rev=37741 FileSytem encoding -- Best regards, Adam mailto:[EMAIL PROTECTED] -- ___ Zope3-dev mailing list Zope3-dev@zope.org Unsub:

Re: [Zope3-dev] Re: typo

2005-08-13 Thread Adam Groszer
Hello Derrick, Can you please also look at #: src/zope/app/component/browser/tools.py:80 #: src/zope/app/component/browser/tools.py:83 Tools successufully installed. (I'm translating the PO file and can't do the mods myself) Thursday, August 11, 2005, 9:18:51 PM, you wrote: Fixed, thanks. --

[Zope3-dev] typos, English and German

2005-08-22 Thread Adam Groszer
Here are some typos I found during translating to Hungarian. There are some typos and also some logical errors: - zope.schema.Int field with default = *u'default'*. that should be I think zope.schema.Int field with default = *10*. - No interpreter named \${*lang_name*}\ was found. Ein

[Zope3-dev] problems with browser:widget

2005-08-24 Thread Adam Groszer
I'm having problems with using browser:widget. I have an interface: class ISzerep(Interface): name = TextLine( title=uSzerep nev, description=uSzerep nev, required=True ) szemelyek = List( title=uHozzarendelt szemelyek,

Re: [Zope3-dev] Proposed widget/schema work for the Rivah sprint (Thursday and Friday this week)

2005-08-30 Thread Adam Groszer
Dear Gary and Stephan, Would you please have a look at my messages with the subject [Zope3-dev] problems with browser:widget I'm also having problems with CustomWidgetFactory, but in an other usecase. -- Best regards, Adam mailto:[EMAIL PROTECTED] --

Re[2]: [Zope3-dev] Proposed widget/schema work for the Rivah sprint (Thursday and Friday this week)

2005-08-30 Thread Adam Groszer
branch gets into it, or the problem is not present in the release just don't care about my mail. Tuesday, August 30, 2005, 4:21:40 PM, you wrote: On Aug 30, 2005, at 2:43 AM, Adam Groszer wrote: Dear Gary and Stephan, Would you please have a look at my messages with the subject [Zope3

[Zope3-dev] how-to fool XML-RPC publisher

2005-08-30 Thread Adam Groszer
Dear All, Is there any way to fool the Z3 XML-RPC publisher to unmarshall strings *always* as unicode? I think the problem is that xmlrpclib tries to convert all strings to str, but in Z3, all strings should be stored as unicode. Even better that zope.schema enforces unicode also. So my exposed

Re[2]: [Zope3-dev] how-to fool XML-RPC publisher

2005-08-31 Thread Adam Groszer
a hint where to look? Wednesday, August 31, 2005, 12:24:53 PM, you wrote: SR On Tuesday 30 August 2005 11:55, Adam Groszer wrote: Is there any way to fool the Z3 XML-RPC publisher to unmarshall strings *always* as unicode? I think the problem is that xmlrpclib tries to convert all strings to str

Re: [Zope3-dev] Proposed widget/schema work for the Rivah sprint (Thursday and Friday this week)

2005-09-01 Thread Adam Groszer
Dear Gary, Maybe not too late, I have here one more thing to look at: It happened that the szerepek attribute of the object implementing the ISzemely interface was left by default at a value None. As I tried to modify the object with a standard generated editform, the exception below came. I

Re: [Zope3-dev] Functional tests failing on Windows

2005-09-20 Thread Adam Groszer
Hello Tim, Happened to me also on W2k... I didn't have time, I just removed the \package-includes\zope.app.pagelet-meta.zcml (and some others too as I remember) as a quick solution. Tuesday, September 20, 2005, 5:17:55 PM, you wrote: A release candidate for Python 2.4.2 is getting made, and I

Re[2]: [Zope3-dev] Debugging Zope

2005-10-11 Thread Adam Groszer
Hello Florian, I'm using Activestate Komodo for that. It's working quite well. Well, sometimes it has glitches and it's not free. Tuesday, October 11, 2005, 4:56:25 PM, you wrote: SR On Saturday 08 October 2005 07:24, Florian Lindner wrote: what tools do you use for debugging your Zope

Re[2]: [Zope3-dev] Performance regression test, (was: [Zope3-checkins] ... added a pystone performance unit tester)

2005-10-11 Thread Adam Groszer
Hello Stephan, +1 on that. Linux also fell in that trap not far ago that people kept adding stuff and it slowed down the system. Tuesday, October 11, 2005, 5:01:31 PM, you wrote: On Tuesday 11 October 2005 04:04, Tarek Ziadé wrote: So, the main idea of the work we did last week on this topic

[Zope3-dev] XMLRPC broken?

2005-10-22 Thread Adam Groszer
I'm wondering if the XMLRPC server is broken on the trunk or just I'm missing something? My app was surely working before the twisted integration. Since then I had a HDD crash and tried it now with a fresh checkout. the request and response captured with TCPwatch looks like this: [00:00.000 -

Re[2]: [Zope3-dev] zope.wfmc UML

2005-10-25 Thread Adam Groszer
Hello Stephan, I did it with Sparx Enterprise Architect, is just a package export not the complete model. It's currently xmi 1.1, but if you need EA can export xmi 1.0 or xmi 1.2. Monday, October 24, 2005, 11:18:15 PM, you wrote: On Monday 24 October 2005 16:40, Jim Fulton wrote:   I tried

Re[2]: [Zope3-dev] zope.wfmc UML

2005-10-27 Thread Adam Groszer
: Adam Groszer wrote: Dear Jim, I tried to sketch an UML diagram from the zope.wfmc package. Can you please have a look if it is half way correct? If I ignore the attributes, it looks pretty reasonable. The picture is a bit incomplete because it doesn't show work items, which are, after

Re[4]: [Zope3-dev] zope.wfmc UML

2005-10-27 Thread Adam Groszer
, but it is a _must_. Thursday, October 27, 2005, 2:25:53 PM, you wrote: On Thursday 27 October 2005 07:49, Adam Groszer wrote: I tried to keep it simple, but you're right I missed the work items. Now I updated the model also with the attributes and methods by using pyreverse. I hope it did

Re[2]: [Zope3-dev] How to provide some default utilities for sub-site

2005-11-04 Thread Adam Groszer
and it will work. Regards, Dominik Adam Groszer wrote: I'd like to provide some default utilities for my sub-site. As I checked there is the nice ensureUtility method but as it turns out it failes with ... Module szscreen.app, line 339, in __init__ 'WorkflowUtility', WorkflowUtility, 'wfu

Re[2]: [Zope3-dev] How to provide some default utilities for sub-site

2005-11-04 Thread Adam Groszer
zope.app.container.interfaces.IObjectAddedEvent DH / DH def App_boot(obj, event): DH if not ISite.providedBy(obj): DHhelper.addSiteManager(obj) DH helper.addLocalUtility(obj, 'wfu', 'WorkflowUtility', WorkflowUtility()) DH Regards, DH Dominik DH Adam Groszer wrote: Hello Dominik, I tried it using

[Zope3-dev] zope.app.appsetup.bootstrap proposal

2005-11-04 Thread Adam Groszer
I think (that may be stupid, because I'm not an expert) that the module is not 100% consistent, once it is checking on the passed folder's SiteManager (in ensureUtility) and then tries to add the utility to a maybe completely different SM (in addUtility). I propose a change to

Re[4]: [Zope3-dev] ServerControlForm.html / Restart, Shutdown does not work

2005-11-12 Thread Adam Groszer
Hello Stephan, done that, it's issue No 485 Saturday, November 12, 2005, 12:54:21 PM, you wrote: SR On Friday 04 November 2005 11:50, Adam Groszer wrote: I think I have something for tomorrow's bug day. It is not working again. I have the current trunk and brand new instance. SR Could you

Re: [Zope3-dev] Workflow support

2005-11-16 Thread Adam Groszer
Hello Alec, Look for zope.wfmc, the Z3ecm project (http://www.z3lab.org/) has built a package on top of that: ecm.workflow. Tuesday, November 15, 2005, 6:56:37 PM, you wrote: AM Hi List, AM I may have brought this up before, but what is the current status of AM workflow in Zope 3? As I recall,

Re[2]: [Zope3-dev] RFC: CustomWidgetFactory and widgets having different __init__ signature

2005-11-17 Thread Adam Groszer
Hello Dominik, Your solution looks good. I would propose, that we still mark the widgets with different __init__ signatures with something to be able to wrap them into different factories in metaconfigure.py to make like a bit easier. What I have in mind: itemswidgets.py: class

[Zope3-dev] widget framework missing a registration?

2005-12-13 Thread Adam Groszer
The widget framework is missing a widget registration for zope.app.form.interfaces.IDisplayWidget for zope.schema.interfaces.IList, zope.schema.interfaces.IVocabularyTokenized that means if the field is read-only no widget is displayed. Is that by intention? If I add view

[Zope3-dev] how to manipulate interfaces?

2005-12-13 Thread Adam Groszer
I have a schema where for one attribute (processDef) the user should be able to modify it only at the time he adds the object. This is a quick hack to spare some lines of code, but it is not working as expected. Modifying derived interface modifies the base too. Is that the expected behavior? How

Re: [Zope3-dev] Certification: Support platforms different from Linux?

2005-12-14 Thread Adam Groszer
Hello Christian, Wednesday, December 14, 2005, 10:30:46 AM, you wrote: ... So my question is: Does anybody think it will be a problem for Zope beeing CC certified only on Linux? Cheers, Christian I'll say maybe a small survey should be done how many people are using other OS's. One more

Re[2]: [Zope3-dev] how to manipulate interfaces?

2005-12-14 Thread Adam Groszer
, 2:20:48 PM, you wrote: On Tuesday 13 December 2005 05:41, Adam Groszer wrote: IDocTypeEditForm.getDescriptionFor('processDef').readonly=True IDocType.getDescriptionFor('processDef').readonly True IDocTypeEditForm.getDescriptionFor('processDef').readonly True This is correct Python

Re[2]: [Zope3-dev] widget bug?!?

2006-01-04 Thread Adam Groszer
Hello Stephan, Seems like you smashed it, now a ComponentLookupError exception is coming which seems adequate. Tuesday, January 3, 2006, 8:00:49 PM, you wrote: On Thursday 15 December 2005 08:17, Adam Groszer wrote: If I make a schema which has no registered widget, then no exception

Re[2]: [Zope3-dev] widget framework missing a registration?

2006-01-05 Thread Adam Groszer
PM, you wrote: On Tuesday 13 December 2005 05:06, Adam Groszer wrote: Is that by intention? No. Though we would need it for the set as well. Feel free to check this ion, preferably with a test. Regards, Stephan -- Best regards, Adammailto:[EMAIL PROTECTED

Re[4]: [Zope3-dev] widget framework missing a registration?

2006-01-08 Thread Adam Groszer
think is it still reasonable? Friday, January 6, 2006, 2:44:06 PM, you wrote: On Thursday 05 January 2006 05:45, Adam Groszer wrote: I can provide diff's. That would be great! BTW, the little overview in the CSV file is great. Maybe you can repost it as plain text in another E-mail? Regards

[Zope3-dev] Z3 widgets overview

2006-02-03 Thread Adam Groszer
Hello, I had some time to finalize the widgets overview. You can download it from here in various formats: http://www.zope.org/Members/adamg/widget -- Best regards, Adam mailto:[EMAIL PROTECTED] -- Quote of the day: A journey of a thousand miles begins with a cash

[Zope3-dev] annoying exception - amateur mistake

2006-03-07 Thread Adam Groszer
Hi there, I had a nicely working app with interfaces.py:: class IVersion(IVersionable, INonVersionedData, IPhysicallyLocatable): ... orig_file_ref = Attribute(uoriginal file) pdf_file_ref = Attribute(uPDF file) configure.zcml:: content class=.version.Version ...

[Zope3-dev] Re[2]: SVN: Zope3/trunk/src/zope/wfmc/ Preparations for persistent WFMC,

2006-04-29 Thread Adam Groszer
out of it. Saturday, April 29, 2006, 5:52:39 PM, you wrote: Adam Groszer wrote: Log message for revision 67734: Preparations for persistent WFMC, as discussed at the SwissSprint Changed: U Zope3/trunk/src/zope/wfmc/process.py U Zope3/trunk/src/zope/wfmc/xpdl.py Hi Adam

Re: [Zope3-dev] Google SoC Project

2006-05-07 Thread Adam Groszer
Hey Stephan, I'd have there one idea that may be not so easy to implement, but would help a lot for developers of Z3 and even python. The idea is to dynamically reload modules while running the app. The most beautiful solution would do this by looking at the last modified date of the .py file. If

Re[2]: [Zope3-dev] Re: Google SoC Project

2006-05-09 Thread Adam Groszer
Hello Jim, Tuesday, May 9, 2006, 1:22:30 PM, you wrote: [snip] JF Python simply does not support a general robust reload, other than JF restart. [snip] What about pushing the problem then to the lower level, to Python itself. I think all developers are fighting the same problem, so all Python

Re: reloading modules (was Re: [Zope3-dev] Re: Google SoC Project)

2006-05-10 Thread Adam Groszer
Hi Shane, Please have a look at http://www.pythomnic.org/. As I get it, it puts proxies around 'imported' modules. My idea would be, without thinking it any further/deeper is what about putting proxies before any imported stuff. Modules, callables, variables, everything and evaluate the

[Zope3-dev] vocabulary BBB

2006-05-16 Thread Adam Groszer
Hi there, I'm working on removing BBB warnings of our current app for 3.3. For the vocabulay directive it was possible to give the factory some parameters like this: vocabulary name=doctype factory=..vocab.ContainerVocabulary containerName=doctype / Now, with the utility

[Zope3-dev] [ANN] win32-trunk-pyds

2006-05-18 Thread Adam Groszer
Hello *, I just put the compiled pyd's for win32 users to http://www.zope.org/Products/Zope3/, into a relase called 'Trunk'. -- Best regards, Adam mailto:[EMAIL PROTECTED] -- Quote of the day: I pronounce it as certain that there was never a truly great man that was

Re[2]: [Zope3-dev] [ANN] win32-trunk-pyds

2006-05-20 Thread Adam Groszer
Hi Tim, Sorry for this small confusion. If you don't mind, I'll do it. (The thing started as I became the compiler of the win32 release and the pyd's are just a by-product of the release.) I'll do my best to keep it up to date, but if I should miss something, please drop a mail. Friday, May

[Zope3-dev] weird problem with pytz+DC

2006-05-25 Thread Adam Groszer
Hi there, I've run into the following problem when trying to use zc.datetimewidget in my app: IZopeDublinCore.modified value is a datetime, but it is having a tzinfo(0) as I check it, instead of pytz.utc. That's weird, because timeannotators.py sets it as dc.modified = datetime.now(pytz.utc) But

[Zope3-dev] SVN: Zope3/branches/3.3/ Fixed issues 648 and 593: uploading files with non-ASCII filenames now works.

2006-06-19 Thread Adam Groszer
Hi Marius, Your fix of browser.py causes problems for me using hurry.file when running functional test with zope.testbrowser. The problem is that aFieldStorage.filename is already unicode and it cannot be decoded again. Do you mind if I add an if isinstance(aFieldStorage.filename, unicode):

Re[2]: [Zope3-dev] Re: SVN: Zope3/branches/3.3/ Fixed issues 648 and 593: uploading files with non-ASCII filenames now works.

2006-06-19 Thread Adam Groszer
Hello Benji, Marius, Sorry, entwarnung It is hurry.file causing the the problem, it is doing def _toFormValue(self, value): if value == self.context.missing_value: return self._missing return FileUpload(FakeFieldStorage(value.filename, value.data)) and this

[Zope3-dev] zc.datetimewidget+UTC exception

2006-07-17 Thread Adam Groszer
Hi there, Anybody tried to use the above? For me it raises Module zope.app.form.utility, line 348, in getWidgetsData Module zope.app.form.browser.widget, line 295, in getInputValue Module zc.datetimewidget.datetimewidget, line 123, in _toFieldValue res = normalizeDateTime(res,

Re[2]: [Zope3-dev] zc.datetimewidget+UTC exception

2006-07-17 Thread Adam Groszer
, 0, tzinfo=UTC) Monday, July 17, 2006, 7:55:02 PM, you wrote: GP On Jul 17, 2006, at 12:53 PM, Adam Groszer wrote: Hi there, Anybody tried to use the above? For me it raises Module zope.app.form.utility, line 348, in getWidgetsData Module zope.app.form.browser.widget, line 295

[Zope3-dev] SVN weirdness

2006-08-10 Thread Adam Groszer
Hello, Seems like the svn:external behaves wrong on my win2K box, using TortoiseSVN 1.3.5, Build 6804 - 32 Bit: If I update /src/zope using svn+ssh://svnzope/repos/main/Zope3/trunk/src/zope -- or -- /src/zope/testing (that's an svn:external in the above tree) using

[Zope3-dev] Re: Tim, new pyd zip file needed

2006-08-21 Thread Adam Groszer
Hello Roger, Just uploaded to http://www.zope.org/Products/Zope3/Trunk Hope that the 3.3.0b2 pyds are OK for you. Monday, August 21, 2006, 12:08:15 PM, you wrote: RI Hi Tim or Adam RI Can you generate a new *.pyd zip download? RI Regards RI Roger Ineichen RI _ RI

[Zope3-dev] possible bug in zope.wfmc

2006-09-10 Thread Adam Groszer
Hello, I think I found a bug in zope.wfmc. Let's say the ReviewPublish and ReviewReject transitions are guarded by conditions. --- --| Publish | -- -- / --- | Author |--| Review |---

Re[2]: [Zope3-dev] possible bug in zope.wfmc

2006-09-11 Thread Adam Groszer
in zope.wfmc. I think finishing the whole process is definitely bad behaviour. But what's correct? Please give a hint what should be done. Monday, September 11, 2006, 4:00:01 PM, you wrote: JF On Sep 10, 2006, at 9:00 AM, Adam Groszer wrote: Hello, I think I found a bug in zope.wfmc. Let's say

[Zope3-dev] how to provide z.a.s.LogoutSupported for different applications in one instance

2006-09-11 Thread Adam Groszer
Hi, It's piece of cake making the [Logout] to appear with adapter for=zope.publisher.interfaces.browser.IBrowserRequest factory=zope.app.security.LogoutSupported / How do I do this if I have several different applications in one instance? They start to complain about

Re[3]: [Zope3-dev] possible bug in zope.wfmc

2006-09-12 Thread Adam Groszer
, you wrote: JF On Sep 10, 2006, at 9:00 AM, Adam Groszer wrote: Hello, I think I found a bug in zope.wfmc. Let's say the ReviewPublish and ReviewReject transitions are guarded by conditions. --- --| Publish

Re[2]: [Zope3-dev] how to provide z.a.s.LogoutSupported for different applications in one instance

2006-09-13 Thread Adam Groszer
Hello Stephan, Simple, effective, great. Thanks. Monday, September 11, 2006, 7:45:42 PM, you wrote: On Monday 11 September 2006 13:23, Adam Groszer wrote: The solution might be simple, but at this late time I don't see it. Any help is welcome. No, the solution was not even possible (easily

Re[4]: [Zope3-dev] possible bug in zope.wfmc

2006-09-19 Thread Adam Groszer
Hi Roger, Tuesday, September 19, 2006, 12:08:20 PM, you wrote: Update - Final is guarded by review_result == 'accepted' Update - Issue is guarded by transitionName == 'update_issue' Update - Review is guarded by transitionName == 'update_review' RI Is this (Update - Final) not a end

Re: [Zope3-dev] Heads up: Zope 3.2.2 on Saturday

2006-09-28 Thread Adam Groszer
Hello Philipp, Thursday, September 28, 2006, 3:48:34 PM, you wrote: By the way, it'd be cool if someone could do the Windows release. See http://dev.zope.org/Zope3/ZopeWindowsRelease for more info. I'm raising my hand. Doing it is OK, Updating the wiki page will take some time. -- Best

Re: [Zope3-dev] Heads up: Zope 3.2.2 on Saturday

2006-09-28 Thread Adam Groszer
Hello Philipp, BTW, correct me if I'm wrong, bugfixes go into: /repos/main/Zope3/branches/3.2 and /repos/main/Zope3/branches/3.3 Releases get built from: /repos/main/Zope3/tags/Zope-3.2.2 and /repos/main/Zope3/tags/Zope-3.3.1 -- Best regards, Groszer Adam -- Quote of the day: Feast, and your

[Zope3-dev] help, Z3.2.2 build fails on win32 with ZConfig

2006-10-05 Thread Adam Groszer
Hello, I built Z3.2.2 on win32, but after installing the result and creating an instance it fails. I don't have a clou where and what to look for. C:\zopeinstbin\runzope Error: 'formatter' is not a known key name (line 103 in file:/C|/zopeinst/etc/zope.conf) For help, use

Re[2]: [Zope3-dev] help, Z3.2.2 build fails on win32 with ZConfig

2006-10-05 Thread Adam Groszer
Hello Martijn, Thursday, October 5, 2006, 6:34:11 PM, you wrote: I actually reported this issue for Zope 3.2.1 earlier this week. It's very unfortunate that Zope 3.2.2 went out of the door shortly afterward without a fix for this. :( I see you found the issue too: The 3.2.2 win32 isn't there

[Zope3-dev] Re[2]: help, Z3.2.2 build fails on win32 with ZConfig

2006-10-06 Thread Adam Groszer
Hello Philipp, Friday, October 6, 2006, 9:06:39 AM, you wrote: I'm suspecting that Adam, who built the 3.2.x releases, was executing the wrong command when building the tarball, because zope.conf.in on the 3.2.x branch doesn't contain the formatter line. It's zope.conf.in on the 3.3.x

[Zope3-dev] Re[2]: help, Z3.2.2 build fails on win32 with ZConfig

2006-10-06 Thread Adam Groszer
Hello Philipp, Thanks Baiju. It looks like the instructions aren't complete here. You should be specifying -r 3.2.2 here so that it looks at the tag. Lot better :-) now it works. Now I start the upload. -- Best regards, Adammailto:[EMAIL PROTECTED] -- Quote of

[Zope3-dev] Re[4]: help, Z3.2.2 build fails on win32 with ZConfig

2006-10-06 Thread Adam Groszer
Hello Baiju, done Friday, October 6, 2006, 12:38:59 PM, you wrote: Can you update ZopeWindowsRelease wiki page also? -- Best regards, Adammailto:[EMAIL PROTECTED] -- Quote of the day: There is no better or more blessed bondage than to be a prisoner of hope. -

[Zope3-dev] zope.testbrowser + unicode URL

2006-10-09 Thread Adam Groszer
Hello, Happened to pass a unicode instead of str URL to browser.open(). That caused a nasty exception in Cookie.py. Might be worth an assert()? -- Best regards, Adam -- Quote of the day: Look and you will find it-what is unsought will go undetected. - Sophocles

[Zope3-dev] how to override zope.app.securitypolicy sanely

2006-10-11 Thread Adam Groszer
Hi, For our application the standard securitypolicy was fine. Until today. Now a requirement came up that the object permissions have to depend _also_ on an object state (the object's property). As I checked my friend is the zope.app.securitypolicy.zopepolicy.py. Securitypolicy gets set in the

Re[2]: [Zope3-dev] Opaque error, help

2006-11-09 Thread Adam Groszer
Hello Shane, SH For me, the value is in the comfort of a transparent database. I want SH to know exactly what Zope is storing. FileStorage makes that fairly hard. There is half-baked solution at z3c.zodbbrowser. Without knowing your exact requirements, I suggest you take a look. -- Best

[Zope3-dev] z3c.widget.flashupload and compression? [bit OT]

2006-11-14 Thread Adam Groszer
Hello, I'm a little bit offtopic with my question here. We had here the idea to implement a compression algorhitm in the above package to save some precious upload bandwith. I'm not a flash professional, google did not spit out straightforward solutions. Any ideas, pointers, help is

[Zope3-dev] Heads up: bugs in zope.app.catalog?

2006-11-17 Thread Adam Groszer
Hello, I found that z.a.catalog, AttributeIndex fails to remove the previous value/object from the index IF the new value is None. The next thing is if the index contains the object, but the value somehow dropped out of the forward index, the unindex breaks. Anybody noticed these already? I

Re[2]: [Zope3-dev] Heads up: bugs in zope.app.catalog?

2006-11-17 Thread Adam Groszer
Hello Christian, Working on them. Friday, November 17, 2006, 12:39:37 PM, you wrote: Got any tests? -- Best regards, Adammailto:[EMAIL PROTECTED] -- Quote of the day: He became what we are that He might make us what He is. - Athanasius (speaking of Jesus of

Re[2]: [Zope3-dev] Heads up: bugs in zope.app.catalog?

2006-11-17 Thread Adam Groszer
. Suggestions? At the moment the AttributeIndex works like this. Friday, November 17, 2006, 12:46:29 PM, you wrote: CT Hi Adam, CT Adam Groszer wrote: Working on them. CT That's great! I'd be happy to see your checkins then. It would be good CT if you took the time to backport this to 3.3 and 3.2

Re[2]: [Zope3-dev] Heads up: bugs in zope.app.catalog?

2006-11-17 Thread Adam Groszer
Hello Christian, Yep, I also vote for indexing None. Seems like somebody wanted to avoid the `None object is not callable` exception. Friday, November 17, 2006, 1:22:42 PM, you wrote: Hi, Adam Groszer wrote: Hello Christian, Yep, but... What is the `good` behaviour regarding None values

[Zope3-dev] RFC: should z.a.c.attribute.AttributeIndex index None values?

2006-11-17 Thread Adam Groszer
Hello, Solutions: a: No, do not keep None values in the catalog the current implementation works like this you are unable to ask the catalog for objects having None properties b: Yes, keep None values in the catalog you can ask the catalog for objects having None properties c: Let's

Re[2]: [Zope3-dev] z3c.widget.flashupload and compression? [bit OT]

2006-11-17 Thread Adam Groszer
. I already found an open source java applet which could be extended. Friday, November 17, 2006, 12:47:11 PM, you wrote: Hi, Adam Groszer wrote: Hello, I'm a little bit offtopic with my question here. We had here the idea to implement a compression algorhitm in the above package to save

Re[2]: [Zope3-dev] RFC: should z.a.c.attribute.AttributeIndex index None values?

2006-11-17 Thread Adam Groszer
Hello Gary, OK, my mistake. Then I'll do like a). Friday, November 17, 2006, 4:46:09 PM, you wrote: GP On Nov 17, 2006, at 10:23 AM, Adam Groszer wrote: Hello, Solutions: a: No, do not keep None values in the catalog the current implementation works like this you are unable to ask

Re[3]: [Zope3-dev] RFC: should z.a.c.attribute.AttributeIndex index None values?

2006-11-17 Thread Adam Groszer
Hello, Two more questions remain open, but I think they are easy to answer. In case the field is callable but the method to be called is None OR The method is not None but raises an exception while getting the value In both cases the previous value should be removed from the index? I think yes.

Re[5]: [Zope3-dev] RFC: should z.a.c.attribute.AttributeIndex index None values?

2006-11-17 Thread Adam Groszer
, 2006, 5:20:19 PM, you wrote: On Nov 17, 2006, at 11:13 AM, Adam Groszer wrote: Hello, Two more questions remain open, but I think they are easy to answer. In case the field is callable but the method to be called is None Yes, remove from index. OR The method is not None but raises

Re: [Zope3-dev] OrderedMultiSelectWidget problem reloaded

2006-11-23 Thread Adam Groszer
Hi Dominik, Thursday, November 23, 2006, 11:53:42 PM, you wrote: That was quite a long time ago, I'm trying to dig the pieces together. Afterwards I have seen that Adam reported already OrderedMultiSelectWidget problems (http://www.zope.org/Collectors/Zope3-dev/451). This issue was deferred

Re: [Zope3-dev] WFMC in core?

2006-12-14 Thread Adam Groszer
Hello Christian, It seems that the activity has the attribute, but it's not declared in the interface. z.wfmc interface was/is quite out of sync with the implementation I think. I already fixed some, but looks like there are still some lurking. Thursday, December 14, 2006, 12:09:21 AM, you

Re[2]: [Zope3-dev] RE: [SpringCleaning07]

2006-12-19 Thread Adam Groszer
Hello Stephan, Tuesday, December 19, 2006, 2:53:33 PM, you wrote: zope.wfmc SR +1, but please make it very easily available. People do use this code in SR production; Zope Corp. and Adam Groszer come to mind. Yes, here :-) If it would be moved out of the feature-freeze-on-the-trunk jail I

[Zope3-dev] z3+squid+Unauthorized = weirdness

2006-12-20 Thread Adam Groszer
Hello, Just happened the following: zope3 server | | squid proxy / \ / \ / \ userA userB Both my users are sitting behind a squid proxy/firewall. That is a usual out-of-the-box SuSe linux firewall/proxy config. Each request goes through the squid proxy. userA does

Re[2]: [Zope3-dev] z3+squid+Unauthorized = weirdness

2007-01-02 Thread Adam Groszer
, December 20, 2006, 3:05:10 PM, you wrote: On Wed, Dec 20, 2006 at 02:36:59PM +0100, Adam Groszer wrote: Hello, Just happened the following: zope3 server | | squid proxy / \ / \ / \ userA userB Both my users are sitting behind a squid proxy/firewall

[Zope3-dev] RFC on wfmc issue 699, 700, 701

2007-01-02 Thread Adam Groszer
Hello, In short: I would classify 699 and 700 as new features, 701 as bugfix. For more details read on. Issue 699 I hope if I change the event classes, by adding the interfaces existing code won't break. As stated by philikon this is not a show stopper so I would

Re[2]: [Zope3-dev] Builbot mail not working ?

2007-01-10 Thread Adam Groszer
Hello Christian, Yay, shame on me. I was the one who added the no cache stuff to /src/zope/app/exception/browser/unauthorized.py. I'm crippled here until tomorrow without SVN access, so somebody please fix it or revert my changes. Wednesday, January 10, 2007, 11:00:35 AM, you wrote: CT Hi, CT

Re: [Zope3-dev] Tests failing

2007-01-11 Thread Adam Groszer
Hello Benji, Shame on me, I was that. I'm working on it now. I have the problem on Win32, when running test.py -vf: IOError: [Errno 2] No such file or directory: 'U:\\zope\\svn_zope33\\zopeskel\\etc\\securitypolicy.zcml' It's not there. Am I doing something wrong? Wednesday, January 10, 2007,

[Zope3-dev] Re[2]: help with test.py -vf

2007-01-11 Thread Adam Groszer
Hello Philipp, It's not there. In the SVN repo also not. That's why I'm puzzled. Thursday, January 11, 2007, 4:43:17 PM, you wrote: Adam Groszer wrote: Hello, I have the problem on Win32, when running test.py -vf: IOError: [Errno 2] No such file or directory: 'U:\\zope\\svn_zope33

[Zope3-dev] Re[4]: help with test.py -vf

2007-01-11 Thread Adam Groszer
Hello Philipp, Works, thanks. Thursday, January 11, 2007, 4:56:18 PM, you wrote: PvW On 11 Jan 2007, at 16:51 , Adam Groszer wrote: It's not there. In the SVN repo also not. That's why I'm puzzled. PvW Right, now I remember. You need to execute python setup.py PvW install_data --install-dir

[Zope3-dev] Re[2]: Zope 3.3.1

2007-01-14 Thread Adam Groszer
Hello Philipp, Let's try. Hope that .../repos/main/Zope3/tags/3.3.1 is the right one. Sunday, January 14, 2007, 3:24:45 PM, you wrote: PvW Philipp von Weitershausen wrote: Christian Theune wrote: after the initial Zope 3.3 release, we fixed quite a few bugs. I think it's time for a 3.3.1

[Zope3-dev] Re[4]: Zope 3.3.1

2007-01-15 Thread Adam Groszer
Hello Philipp, .../repos/main/Zope3/branches/3.3 fails too on the same test. Buildbot seems to sleep these days. I ran into that with one of by fixes too. Monday, January 15, 2007, 10:37:52 AM, you wrote: On 15 Jan 2007, at 09:47 , Groszer Adam wrote: Hello Philipp, I have one failure here:

[Zope3-dev] Re[2]: Zope 3.3.1

2007-01-15 Thread Adam Groszer
Hello Michael, Win32, looking into that... Monday, January 15, 2007, 3:15:25 PM, you wrote: On Monday 15 January 2007 13:23, Philipp von Weitershausen wrote: On 15 Jan 2007, at 11:02 , Adam Groszer wrote: Hello Philipp, .../repos/main/Zope3/branches/3.3 fails too on the same test

Re: [Zope3-dev] attribute index indexing None if returned from callable

2007-01-17 Thread Adam Groszer
Hello Jürgen, Yep, +1. Did some changes around the subject but seems like it was not enough. The outcome of the story was the same: None should not get indexed. Wednesday, January 17, 2007, 1:35:04 PM, you wrote: If a callable is used to provide the value for an attribute index in

[Zope3-dev] Re[2]: Zope 3.3.1

2007-02-13 Thread Adam Groszer
Hello Philipp, Tuesday, February 13, 2007, 11:00:35 AM, you wrote: PvW Adam, can you make the installer for 3.3.1 again, upload it (w/o PvW publishing it) so that we can try to reproduce it on our machines? I have the one from jan 15. at hand. Is it OK? I can start uploading now. Otherwise I

Re: [Zope3-dev] Zope3 C++

2007-03-08 Thread Adam Groszer
Hello Roger, It's done. http://www.zope.org/Products/Zope3/Trunk/swrelease_contents Friday, March 9, 2007, 1:56:54 AM, you wrote: Hi Adam Can you build new *.pyd files and zip them? Regards Roger Ineichen _ Projekt01 GmbH www.projekt01.ch Boesch 65 6331

Re: [Zope3-dev] Community opinion about workflow engine

2007-03-13 Thread Adam Groszer
Hello Godefroid, I'm having a bit biased view, because I know just zope.wfmc and have the luck developing a pure Z3 application. I think with zope.wfmc you have - WFMC/XPDL support, you can shine with standards and big companies love standards - because it's XPDL support there's a graphical

[Zope3-dev] Re[2]: [Zope3-Users] correct display of Text field in a view

2007-03-14 Thread Adam Groszer
Hello Ivan, I don't think that you'll need IMultiLineText and MultiLineText. That's why IText and Text are there for. You'll have to register the widget for IText or use it directly in your view with CustomWidgetFactory. In fact it's a good question why Z3 doesn't provide such a widget for Text.

  1   2   >