[Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Peter Koppatz
Hi, I installed a fresh virtualenv | zopeproject unsing z3c.form and got the following error: No such file or directory: '/Users/peter/temp/buildout-eggs/ z3c.form-1.7.2-py2.4.egg/z3c/form/meta.zcml' The older installation with z3c.form-1.7.0 works fine and there is a meta.zcml in it.

[Zope3-Users] Re: [Zope3-dev] z3c.form 1.0.0 released!

2008-01-23 Thread john saponara
In order to try z3c.form under windows (winxpprosp2), I tried Stephan's instructions below but got an error during the buildout step: ImportError: No module named schemaless (Complete command sequence and error message is attached.) I deviated from the instructions in only two ways: 1. I

Re: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Martijn Pieters
On Jan 23, 2008 10:12 AM, Peter Koppatz [EMAIL PROTECTED] wrote: What has changed between 1.7.0 and 1.7.2? ls -al | wc -l 1.7.0 -- 76 1.7. 2 -- 47 there are no *-txt , *.zcml anymore! Someone must have built the release tarball from a fresh SVN export; setup.py does not include txt and

Re: [Zope3-Users] Re: [Zope3-dev] z3c.form 1.0.0 released!

2008-01-23 Thread Christophe Combelles
john saponara a écrit : In order to try z3c.form under windows (winxpprosp2), I tried Stephan's instructions below but got an error during the buildout step: ImportError: No module named schemaless (Complete command sequence and error message is attached.) I deviated from the

AW: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Roger Ineichen
Hi all, Stephan, Philipp Sorry about that... PhiliKON told me that this is fixed a couple month ago. That was the reason I tried to lay eggs again. But now it seems that we have rumbled eggs again. Seems that setuptools(?) is buggy and still doesn't work on a windows box. Philipp, right? Or do

Re: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Martijn Pieters
On Jan 23, 2008 1:20 PM, Roger Ineichen [EMAIL PROTECTED] wrote: Sorry about that... PhiliKON told me that this is fixed a couple month ago. That was the reason I tried to lay eggs again. But now it seems that we have rumbled eggs again. Seems that setuptools(?) is buggy and still doesn't

AW: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Roger Ineichen
Hi Martijn Betreff: Re: [Zope3-Users] z3c-form meta.zcml error On Jan 23, 2008 1:20 PM, Roger Ineichen [EMAIL PROTECTED] wrote: Sorry about that... PhiliKON told me that this is fixed a couple month ago. That was the reason I tried to lay eggs again. But now it seems that we have

Re: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Martijn Pieters
On Jan 23, 2008 2:04 PM, Roger Ineichen [EMAIL PROTECTED] wrote: No, I see the exact same thing on Mac and Linux; you need to explicitly include .zcml and .txt files in MANIFEST.in; that file doesn't exist; just create one next to setup.py, and include 2 lines: global-include *.txt

Re: [Zope3-Users] Buildout and the Data.fs

2008-01-23 Thread Jim Fulton
On Jan 23, 2008, at 1:19 AM, Jeff Shell wrote: When developing and/or deploying using Buildout, how do you deal with the Data.fs? I'm particularly concerned with running on different environments (desktop development, server development, staging, deployment) as I don't want the Data.fs to be

Re: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Philipp von Weitershausen
On 23 Jan 2008, at 14:22 , Martijn Pieters wrote: On Jan 23, 2008 2:04 PM, Roger Ineichen [EMAIL PROTECTED] wrote: No, I see the exact same thing on Mac and Linux; you need to explicitly include .zcml and .txt files in MANIFEST.in; that file doesn't exist; just create one next to setup.py, and

Re: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Martijn Pieters
On Jan 23, 2008 6:11 PM, Philipp von Weitershausen [EMAIL PROTECTED] wrote: Yes, MANIFEST.in is a distutils feature. It's also described in my book, by the way. However, setuptools makes the usage of MANIFEST.in unnecessary when you're operating within a subversion checkout. In such a case,

Re: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Stephan Richter
On Wednesday 23 January 2008, Philipp von Weitershausen wrote: I distinctly remember there being a Windows-related bug in setuptools,   but IIRC, it was about line endings in one of the EGG-INFO files   within ZIP files, or something like that. That one was fixed a while   ago. Not sure

Re: [Zope3-Users] zmi menu error

2008-01-23 Thread Marius Gedminas
On Mon, Jan 14, 2008 at 06:01:27PM +0100, Christophe Combelles wrote: john saponara a écrit : I get reasonable edit screens for my car and driver classes when I use a url like limoService/car1/edit.html but when I try to add the edit screens as zmi menu entries I get an error: File

Re: Fwd: [Zope3-Users] z3c-form meta.zcml error

2008-01-23 Thread Stephan Richter
On Wednesday 23 January 2008, Martijn Pieters wrote: On Jan 23, 2008 10:12 AM, Peter Koppatz [EMAIL PROTECTED] wrote: What has changed between 1.7.0 and 1.7.2? ls -al | wc -l 1.7.0 -- 76 1.7. 2 -- 47 there are no *-txt , *.zcml anymore! Someone must have built the release tarball