Re: [Zope] have problem with managing objects within a external product

2007-03-12 Thread Maciej Wisniowski
I found out what my problem is. in my code I please baseclass Item before Folder class ShpProjectClass(Item, Folder, Persistent, Implicit, CatalogAware): when I change the order, it worked normally class ShpProjectClass(Folder, Item, Persistent, Implicit, CatalogAware): but I don't

Re: [Zope] Two mysql / timestamp related fixes

2007-03-12 Thread Gaute Amundsen
On Friday 09 March 2007 16:22, Tino Wildenhain wrote: Gaute Amundsen schrieb: On Friday 09 March 2007 09:40, Tino Wildenhain wrote: Gaute Amundsen schrieb: On Thursday 08 March 2007 17:27, Tino Wildenhain wrote: Gaute Amundsen schrieb: Hi. snip 1 ) First I got a ValueError

[Zope] problem with manage_importObject

2007-03-12 Thread Fabio Marcone
Hi to all! I have a problem using manage_importObject?file=... with zope2.9. In particular: object is successfully imported but if I shutdown and then reboot the server, I don't see anymore imported object. If I import the same object using web form Import/Export I have not this strange behavior.

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Andreas Jung
--On 12. März 2007 11:00:33 +0100 Fabio Marcone [EMAIL PROTECTED] wrote: Hi to all! I have a problem using manage_importObject?file=... with zope2.9. In particular: object is successfully imported but if I shutdown and then reboot the server, I don't see anymore imported object. I don't

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Jens Vagelpohl
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 I have a problem using manage_importObject?file=... with zope2.9. In particular: object is successfully imported but if I shutdown and then reboot the server, I don't see anymore imported object. If I import the same object using web form

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Fabio Marcone
Jens Vagelpohl wrote: I have a problem using manage_importObject?file=... with zope2.9. In particular: object is successfully imported but if I shutdown and then reboot the server, I don't see anymore imported object. If I import the same object using web form Import/Export I have not this

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Jens Vagelpohl
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 perhaps this is the problem... in fact /var/lib/zope2.9/instance/myinstance/var is empty after importObject operation using python script. but the commit has been introduced in zope 2.9? The need to commit a transaction has been part of the ZODB

[Zope] Data.fs MySQL DB Blown Up!

2007-03-12 Thread tonylabarbara
Hi; Forgive the long (but necessary) background. I bought a new 500 GB hard drive for my server located on the other side of the world. I accidentally entered an erroneous command to copy everything from the old HD to the new one and ended up corrupting the OS. However, the *first* thing that

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Eric Bréhault
Hello, What about just doing the import yourself: container._importObjectFromFile(f) (rather than using the ZMI's manage_importObject method through a zope client connection) ? Eric BREHAULT On 3/12/07, Fabio Marcone [EMAIL PROTECTED] wrote: Jens Vagelpohl wrote: I have a problem using

Re: [Zope] Data.fs MySQL DB Blown Up!

2007-03-12 Thread Jens Vagelpohl
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 12 Mar 2007, at 12:54, [EMAIL PROTECTED] wrote: My server farm tells me it has nothing whatsoever to do with the hard drive or the OS, that both are in perfect condition. I say that's nonsense! What do you think? Sorry, without knowing

Re: [Zope] Lost user credentials

2007-03-12 Thread Garito
Hi Andreas! What kind of information do you need? On my last messages to the list I send the tracebacks and some other information (need to resend them?) Could you point me what details do you need? Thank you so much for you interest! 2007/3/12, Andreas Jung [EMAIL PROTECTED]: --On 12.

[Zope] Installation problems

2007-03-12 Thread Calder Coalson
Hi, I'm attempting to install Zope on Mac OS X and having problems. I'm sure the documentation is sufficient for most people, but I really don't understand how to run Zope. I performed the install instructions, (correctly, I think). I've got a Zope folder in my home directory, and a

[Zope] call exthernal method

2007-03-12 Thread javi lopez
hello: how to call exthernal method from script python in zope Thanks.. ___ Zope maillist - Zope@zope.org http://mail.zope.org/mailman/listinfo/zope ** No cross posts or HTML encoding! ** (Related lists -

Re: [Zope] call exthernal method

2007-03-12 Thread Andreas Jung
--On 12. März 2007 16:34:34 +0100 javi lopez [EMAIL PROTECTED] wrote: hello: how to call exthernal method from script python in zope Thanks.. By calling it like *any* other object in Zope: result = context.name_of_method(parameters) -aj pgp4nSWQuze43.pgp Description: PGP signature

Re: [Zope] call exthernal method

2007-03-12 Thread Claudio Battaglino
javi lopez ha scritto: hello: how to call exthernal method from script python in zope Thanks.. context.myExternalMethod() cld. ___ Zope maillist - Zope@zope.org http://mail.zope.org/mailman/listinfo/zope ** No cross posts or HTML

Re: [Zope] Installation problems

2007-03-12 Thread Andreas Jung
--On 12. März 2007 10:31:17 -0500 Calder Coalson [EMAIL PROTECTED] wrote: Hi, I'm attempting to install Zope on Mac OS X and having problems. I'm sure the documentation is sufficient for most people, but I really don't understand how to run Zope. I performed the install instructions,

[Zope] Redirecting

2007-03-12 Thread tonylabarbara
Hi; I have a Web site I'm building a shopping cart for that is built with a basic site template and an iframe where all the page-by-page info goes. I need to redirect the iframe to the address below, but when I use the current incantation, it replaces not just the iframe but the whole page! Can

Re: [Zope] Redirecting

2007-03-12 Thread Andreas Jung
--On 12. März 2007 11:55:52 -0400 [EMAIL PROTECTED] wrote: Hi; I have a Web site I'm building a shopping cart for that is built with a basic site template and an iframe where all the page-by-page info goes. I need to redirect the iframe to the address below, but when I use the current

Re: [Zope] Redirecting

2007-03-12 Thread tonylabarbara
Ugh. JS redirects create problems with the search engines. What I really want to do is fill the hole in the doughnut, to use a radio advertising term. That is, I have code before the page data referenced below, and I have code after it. I want to write the stuff referenced below into the hole.

Re: [Zope] Redirecting

2007-03-12 Thread Jonathan
- Original Message - From: [EMAIL PROTECTED] To: zope@zope.org Sent: Monday, March 12, 2007 11:55 AM Subject: [Zope] Redirecting Hi; I have a Web site I'm building a shopping cart for that is built with a basic site template and an iframe where all the page-by-page info goes. I

Re: [Zope] Redirecting

2007-03-12 Thread Andreas Jung
--On 12. März 2007 12:13:53 -0400 [EMAIL PROTECTED] wrote: Ugh. JS redirects create problems with the search engines. What I really want to do is fill the hole in the doughnut, to use a radio advertising term. What you want is not of interest in this particular case. You can perform a

Re: [Zope] Redirecting (fwd)

2007-03-12 Thread Andreas Jung
Please keep the discussion on the list :-) -aj Forwarded Message Date: 12. März 2007 12:39:05 -0400 From: [EMAIL PROTECTED] To: [EMAIL PROTECTED] Subject: Re: [Zope] Redirecting This is OT at this point so I'm writing you off list. I can't find a JS command point

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Fabio Marcone
Eric Bréhault wrote: Hello, What about just doing the import yourself: container._importObjectFromFile(f) (rather than using the ZMI's manage_importObject method through a zope client connection) ? Eric BREHAULT On 3/12/07, Fabio Marcone [EMAIL PROTECTED] wrote: Jens Vagelpohl

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Andreas Jung
--On 12. März 2007 18:51:57 +0100 Fabio Marcone [EMAIL PROTECTED] wrote: well, I have no container because my script python is not an external method or a script python in zope. I try with: import Zope2 Zope2.configure(...) app=Zope2.app() app.manage_delObjects(ids=index_html)

Re: [Zope] Lost user credentials

2007-03-12 Thread Garito
Could any charitable soul take pity on this poor sinner, please...? 2007/3/12, Garito [EMAIL PROTECTED]: Hi Andreas! What kind of information do you need? On my last messages to the list I send the tracebacks and some other information (need to resend them?) Could you point me what details do

Re: [Zope] Lost user credentials

2007-03-12 Thread Andreas Jung
If you create a new posting, you should include all related information. I don't go hunting for information somewhere else. -aj --On 12. März 2007 18:56:28 +0100 Garito [EMAIL PROTECTED] wrote: Could any charitable soul take pity on this poor sinner, please...? 2007/3/12, Garito [EMAIL

Re: [Zope] Lost user credentials

2007-03-12 Thread Dennis Allison
I did not catch the original post and so don't know any of the details, but it sounds like a problem with the logging system, not a loss of credentials. We had long ago and resolved with the list's help. This patch is still in use with Zope 2.9.X. You need to patch

Re: [Zope] Lost user credentials

2007-03-12 Thread Garito
Sorry the gmail response send only to the original poster not to the list (sorry Andreas) The original post: The question then (sorry): I have a product called Yanged This product has overrided: __bobo_traverse__ who returns some objects and sometime a wrapper object with the HTML code to the

Re: [Zope] Lost user credentials

2007-03-12 Thread Dieter Maurer
Garito wrote at 2007-3-12 04:04 +0100: ... In my code I don't use nothing about security and nothing is changed on zmi's security tab But when I launch a method (Borrar if you remember) the user who launches the action is anonymous not the logged one Your problem description is too terse to say

Re: [Zope] Lost user credentials

2007-03-12 Thread Garito
To Dennis: I use Zope 2.9.5 final. Is this version concern 2007/3/12, Dieter Maurer [EMAIL PROTECTED]: Garito wrote at 2007-3-12 04:04 +0100: ... In my code I don't use nothing about security and nothing is changed on zmi's security tab But when I launch a method (Borrar if you remember) the

Re: [Zope] Data.fs MySQL DB Blown Up!

2007-03-12 Thread Dieter Maurer
[EMAIL PROTECTED] wrote at 2007-3-12 07:54 -0400: Forgive the long (but necessary) background. I bought a new 500 GB hard drive for my server located on the other side of the world. I accidentally entered an erroneous command to copy everything from the old HD to the new one and ended up

Re: [Zope] Lost user credentials

2007-03-12 Thread Garito
Fuck$%ing gmail Sorry all for this stupidity To Dennis: I use Zope 2.9.5 final. Is this version concern with this bug? To Dieter: I use HTTP authentication method (at least I suppose that). I don't change anything about the default configuration nor use any cookie at least What I wonder is

Re: [Zope] problem with manage_importObject

2007-03-12 Thread Fabio Marcone
thanks, I solved using Zope2 and transaction modules like Jens wrote me. Fabio Andreas Jung wrote: --On 12. März 2007 18:51:57 +0100 Fabio Marcone [EMAIL PROTECTED] wrote: well, I have no container because my script python is not an external method or a script python in zope. I try

Re: [Zope] Lost user credentials

2007-03-12 Thread Dennis Allison
On Mon, 12 Mar 2007, Garito wrote: To Dennis: I use Zope 2.9.5 final. Is this version concern Reviewing your reposted description of the problem, the patch I sent does not appear applicable. -- ___ Zope maillist - Zope@zope.org

Re: [Zope] Lost user credentials

2007-03-12 Thread Garito
Thanks Dennis! 2007/3/12, Dennis Allison [EMAIL PROTECTED]: On Mon, 12 Mar 2007, Garito wrote: To Dennis: I use Zope 2.9.5 final. Is this version concern Reviewing your reposted description of the problem, the patch I sent does not appear applicable. -- -- Mis Cosas:

[Zope] Re: Lost user credentials

2007-03-12 Thread Josef Meile
To Dieter: I use HTTP authentication method (at least I suppose that). I don't change anything about the default configuration nor use any cookie at least What you get when you authenticate: a pop-up window (HTTP authentication) or an html form (Cookie based authentication)? What I wonder is

Re: [Zope] Re: Lost user credentials

2007-03-12 Thread Garito
2007/3/12, Josef Meile [EMAIL PROTECTED]: To Dieter: I use HTTP authentication method (at least I suppose that). I don't change anything about the default configuration nor use any cookie at least What you get when you authenticate: a pop-up window (HTTP authentication) or an html form

[Zope] 'int' object has no attribute 'objectValues'

2007-03-12 Thread tonylabarbara
Hi; I've written this PT: span tal:define=batch here/quotes/objectValues; num python:len(batch) p tal:replace=python:here.randomNumber(num) / /span ...which calls this external method: import random def randomNumber(num): return random.random(num) ...and throws this error: Error Type:

Re: [Zope] 'int' object has no attribute 'objectValues'

2007-03-12 Thread Maciej Wisniowski
span tal:define=batch here/quotes/objectValues; num python:len(batch) p tal:replace=python:here.randomNumber(num) / /span Check what here/quotes is evaluating to. Seems that it is int. -- Maciej Wisniowski ___ Zope maillist - Zope@zope.org

[Zope-Checkins] SVN: Zope/trunk/lib/python/Products/PageTemplates/ZRPythonExpr.py Collector #2289: restored compatibility with PTProfiler

2007-03-12 Thread Andreas Jung
Log message for revision 73151: Collector #2289: restored compatibility with PTProfiler Changed: U Zope/trunk/lib/python/Products/PageTemplates/ZRPythonExpr.py -=- Modified: Zope/trunk/lib/python/Products/PageTemplates/ZRPythonExpr.py

[Zope-Checkins] SVN: Zope/trunk/doc/CHANGES.txt Collector #2289: restored compatibility with PTProfiler

2007-03-12 Thread Andreas Jung
Log message for revision 73152: Collector #2289: restored compatibility with PTProfiler Changed: U Zope/trunk/doc/CHANGES.txt -=- Modified: Zope/trunk/doc/CHANGES.txt === --- Zope/trunk/doc/CHANGES.txt 2007-03-12 17:23:13

Re: [Zope-dev] Early processing of request body (was: Proposal for optimized Blob handling)

2007-03-12 Thread Christian Theune
Hi, Am Samstag, den 10.03.2007, 07:36 +0100 schrieb Dieter Maurer: Christian Theune wrote at 2007-3-7 22:05 +0100: ... If 5 seconds are spend in the application thread to untangle mime data which has nothing application-specific about it and then only 100ms or so in the application itself,

[Zope-dev] Views on catalog results

2007-03-12 Thread Martijn Pieters
Hi all, This weekend I had fun with creating views for catalog results. In order to do this, I had to: - Create an ICatalogResult interface and use a five:implements directive to configure ZCatalog.CatalogBrains.AbstractCatalogBrain as implementing it. - Set Five.traversable.Traversable as a

Re: [Zope-dev] Upcoming Zope releases (fwd)

2007-03-12 Thread Andreas Jung
Please stay on the list! Bugs that are not reported through the bugtracker don't exist by definition :-) So the answer is: no. -aj Forwarded Message Date: 12. März 2007 12:16:15 +0100 From: M. Krainer [EMAIL PROTECTED] To: Andreas Jung [EMAIL PROTECTED] Subject: Re:

[Zope-dev] Zope Tests: 5 OK

2007-03-12 Thread Zope Tests Summarizer
Summary of messages to the zope-tests list. Period Sun Mar 11 12:00:00 2007 UTC to Mon Mar 12 12:00:00 2007 UTC. There were 5 messages: 5 from Zope Unit Tests. Tests passed OK --- Subject: OK : Zope-2.7 Python-2.3.6 : Linux From: Zope Unit Tests Date: Sun Mar 11 21:58:04 EDT 2007

[Zope-dev] Re: [Zope-CMF] CMF Tests: 9 OK, 2 Unknown

2007-03-12 Thread Jens Vagelpohl
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Subject: UNKNOWN : CMF-2.1 Zope-trunk Python-2.4.4 : Linux From: CMF Unit Tests Date: Sun Mar 11 22:42:15 EDT 2007 URL: http://mail.zope.org/pipermail/cmf-tests/2007-March/004319.html Subject: UNKNOWN : CMF-trunk Zope-trunk Python-2.4.4 : Linux