[Zope] Opening uploaded file

2008-06-26 Thread sujitha mary
hi, I have an uploaded file in home folder.i have a page which has an internal link to that file.But when i click the link a dialogue box is opened saying this is ASC file what you want firefox to do with this file.two options open,save is there.. But I need to display it in my page when user

[Zope] unicode support

2008-06-26 Thread Garry Saddington
I am using Zope 2.9 connected to a Posgres DB via psycopg. My database encoding is UTF8. I am getting the following error when users try to insert text in the database containing £ signs: ERROR: invalid byte sequence for encoding UTF8: 0xa3 This is due to the encoding of a £ sign in the text

Re: [Zope] unicode support

2008-06-26 Thread Andreas Jung
--On 26. Juni 2008 14:09:50 + Garry Saddington [EMAIL PROTECTED] wrote: I am using Zope 2.9 connected to a Posgres DB via psycopg. My database encoding is UTF8. I am getting the following error when users try to insert text in the database containing £ signs: ERROR: invalid byte

Re: [Zope] unicode support

2008-06-26 Thread Peter Bengtsson
Make the form input tags look like this: input name=mystring:utf-8:ustring / then you'll be certain to get it into Zope as unicode under utf-8. 2008/6/26 Garry Saddington [EMAIL PROTECTED]: I am using Zope 2.9 connected to a Posgres DB via psycopg. My database encoding is UTF8. I am getting

Re: [Zope] Opening uploaded file

2008-06-26 Thread Andreas Jung
--On 26. Juni 2008 11:45:47 +0100 sujitha mary [EMAIL PROTECTED] wrote: hi, I have an uploaded file in home folder.i have a page which has an internal link to that file.But when i click the link a dialogue box is opened saying this is ASC file what you want firefox to do with this file.two

Re: [Zope] unicode support

2008-06-26 Thread Garry Saddington
On Thursday 26 June 2008 15:12, Andreas Jung wrote: --On 26. Juni 2008 14:09:50 + Garry Saddington [EMAIL PROTECTED] wrote: I am using Zope 2.9 connected to a Posgres DB via psycopg. My database encoding is UTF8. I am getting the following error when users try to insert text in the

[Zope] ZcxOracleDA, LocalFS, ZMySQLDA

2008-06-26 Thread Jeff Peterson
I upgraded my Zope server to 2.11.0 from 2.8.7. To do that I needed to update the above 3 products. I am not sure of the process to get the products updated so others can use them. Any guidance is appreciated. -- Jeffrey D Peterson Webmaster Crary Industries, Inc.

Re: [Zope] unicode support

2008-06-26 Thread Peter Bengtsson
I would advice against relying on default-zpublisher-encoding. I never used that. By specifying the encoding like this variablename:utf8:ustring you override whatever default-zpublisher-encoding was set to. If you rely on default-zpublisher-encoding your product isn't installable somewhere in

Re: [Zope] ZcxOracleDA, LocalFS, ZMySQLDA

2008-06-26 Thread Andreas Jung
--On 26. Juni 2008 17:03:27 -0500 Jeff Peterson [EMAIL PROTECTED] wrote: I upgraded my Zope server to 2.11.0 from 2.8.7. To do that I needed to update the above 3 products. I am not sure of the process to get the products updated so others can use them. What is your problem? Like in our

Re: [Zope] unicode support

2008-06-26 Thread Andreas Jung
--On 26. Juni 2008 22:05:06 + Garry Saddington [EMAIL PROTECTED] wrote: On Thursday 26 June 2008 15:12, Andreas Jung wrote: --On 26. Juni 2008 14:09:50 + Garry Saddington [EMAIL PROTECTED] wrote: I am using Zope 2.9 connected to a Posgres DB via psycopg. My database encoding is

[Zope-dev] Release zope.app.container 3.5.4?

2008-06-26 Thread Christian Theune
Hi, I saw that ccomb fixed bug #227617 a few days ago (thanks!) and that he also backported it to the 3.5 branch. zope.app.container has a couple of bugfixes aggregated already and I'd like to do a release. Any objections? Christian -- Christian Theune · [EMAIL PROTECTED] gocept gmbh co. kg

[Zope-dev] ZPublisher XMLRPC decoding

2008-06-26 Thread Christian Theune
Hi, the publisher normally converts the arguments given with a request into a type that is easy to use. For example unicode conversion happens automatically. XMLRPC defines specific helper types to represent objects for the XMLRPC wire protocol. Automatic conversion happens for all XMLRPC

[Zope-dev] Zope Tests: 5 OK

2008-06-26 Thread Zope Tests Summarizer
Summary of messages to the zope-tests list. Period Wed Jun 25 11:00:00 2008 UTC to Thu Jun 26 11:00:00 2008 UTC. There were 5 messages: 5 from Zope Tests. Tests passed OK --- Subject: OK : Zope-2.8 Python-2.3.6 : Linux From: Zope Tests Date: Wed Jun 25 21:04:18 EDT 2008 URL:

Re: [Zope-dev] ZPublisher XMLRPC decoding

2008-06-26 Thread Stephan Richter
On Thursday 26 June 2008, Christian Theune wrote: Comments? +1 Regards, Stephan -- Stephan Richter Web Software Design, Development and Training Google me. Zope Stephan Richter ___ Zope-Dev maillist - Zope-Dev@zope.org

[Zope-dev] zope.app.security 3.5.1 ZCML changes

2008-06-26 Thread Fred Drake
Someone changed the ZCML that registers the gopherlib module (why???) to this: !-- This package has been deprecated in Python 2.5; let's use a cheap way of detecting Python 2.5 by checking whether the package regex exists, which has been deleted in that version. -- module

Re: [Zope-dev] zope.app.security 3.5.1 ZCML changes

2008-06-26 Thread Fred Drake
On Thu, Jun 26, 2008 at 12:33 PM, Stephan Richter [EMAIL PROTECTED] wrote: I did as you were aware of. :-) I wasn't, because I didn't look. Note also that I wasn't asking who; I don't think that matters. The gopherlib module was there before, I just shut up the deprecation warning. Using

Re: [Zope-dev] Zope 3 on Python 2.5, Zope 3 releases

2008-06-26 Thread Paul Carduner
On Thu, Jun 26, 2008 at 1:06 PM, Martijn Faassen [EMAIL PROTECTED] wrote: Hi there, I'm curious about the plans of Zope 3 on Python 2.5. * Are people using Zope 3 with Python 2.5 already? What are your experiences? We are using Python 2.5 fully for the last several months now and have

Re: [Zope-dev] zope.app.security 3.5.1 ZCML changes

2008-06-26 Thread Stephan Richter
On Thursday 26 June 2008, Fred Drake wrote: The gopherlib module was there before, I just shut up the deprecation warning. Using Python 2.4.4, I get a deprecation warning for *regex*.  So you shut up the deprecation warning for Python 2.5 by introducing one for Python 2.4. Okay, I did not

Re: [Zope-dev] Zope 3 on Python 2.5, Zope 3 releases

2008-06-26 Thread Tim Cook
On Thu, 2008-06-26 at 13:14 -0700, Paul Carduner wrote: On Thu, Jun 26, 2008 at 1:06 PM, Martijn Faassen [EMAIL PROTECTED] wrote: Hi there, I'm curious about the plans of Zope 3 on Python 2.5. * Are people using Zope 3 with Python 2.5 already? What are your experiences? We are

Re: [Zope-dev] Zope 3 on Python 2.5, Zope 3 releases

2008-06-26 Thread Paul Carduner
On Thu, Jun 26, 2008 at 6:11 PM, Tim Cook [EMAIL PROTECTED] wrote: On Thu, 2008-06-26 at 13:14 -0700, Paul Carduner wrote: On Thu, Jun 26, 2008 at 1:06 PM, Martijn Faassen [EMAIL PROTECTED] wrote: Hi there, I'm curious about the plans of Zope 3 on Python 2.5. * Are people using Zope 3