[Zope] VIRTUAL_URL Failure

2005-11-04 Thread George Lee
Hi, On my Plone site, in CookieCrumbler.py, VIRTUAL_URL is not found in the request variable even though I have a Virtual Host Monster. This means that when logging in, the came_from URL that my site directs to becomes something ugly like

Re: [Zope] VIRTUAL_URL Failure

2005-11-08 Thread George Lee
that there's a VHM installed and doesn't? Peace, George Peace, George On 11/8/05, Chris Withers [EMAIL PROTECTED] wrote: George Lee wrote: On my Plone site, in CookieCrumbler.py, VIRTUAL_URL is not found in the request variable even though I have a Virtual Host Monster. This means

Re: [Zope] VIRTUAL_URL Failure

2005-11-09 Thread George Lee
Two main questions: (1) Does anybody *have* good documentation on VIRTUAL_URL and how it interacts with CookieCrumbler and VirtualHostMonster? (2) Does anyone know how to debug VirtualHostMonster or other Python libraries while running a Zope instance (it lives in Python not in Zope, so I

Re: [Zope] VIRTUAL_URL Failure

2005-11-09 Thread George Lee
(2) Does anyone know how to debug VirtualHostMonster or other Python libraries while running a Zope instance (it lives in Python not in Zope, so I don't know if I change the code there if those changes will actually get executed)? Oh wait it is in a Zope product, scratch that. Peace,

[Zope] Re: VIRTUAL_URL Failure

2005-11-09 Thread George Lee
The correct thing to use in a recent Zope is REQUEST['ACTUAL_URL']. Florent This gives something like http://ip:port/path/to/subdomain though rather than http://subdomain.mydomain.org ... what if anything gives the latter? Peace, George ___ Zope

Re: [Zope] Re: VIRTUAL_URL Failure

2005-11-09 Thread George Lee
I fear you fight a CookieCrumbler bug. Vicious monsters, indeed. Thanks for the REQUEST['URL'] tip. It's a pretty good workaround for now, although not exactly right. If I am going to an object http://here.org/object with default page or default method default, then REQUEST['URL'] equals

[Zope] Reprise -- Manager Proxy Role ineffective for deleting/moving objects

2005-11-18 Thread George Lee
security should suffice. On 9/9/05, Dieter Maurer [EMAIL PROTECTED] wrote: George Lee wrote at 2005-9-8 23:57 -0400: ... Is it okay to just replace sm.checkPermission with _checkPermission from CMFCore.utils or is that not okay? Yes. But, please file a bug report as well. Also Dieter I

[Zope] External Methods, Proxy Roles, and Executable Security

2005-11-18 Thread George Lee
problems! Is this a right expectation / and a bug, or a wrong expectation? Peace, George On 11/18/05, George Lee [EMAIL PROTECTED] wrote: I forget if I submitted a collector issue about this before, but I didn't see it. I just posted one at http://www.zope.org/Collectors/CMF/396: Title

[Zope] Re: External Methods, Proxy Roles, and Executable Security

2005-11-18 Thread George Lee
p.s. This is in the context of a external method in a workflow scripts folder, if that helps. Peace, George On 11/19/05, George Lee [EMAIL PROTECTED] wrote: In CMFCore 1.5.4: If a low-security-clearance user calls an external method that pastes an object from a PortalFolder, he gets

Re: [Zope] External Methods, Proxy Roles, and Executable Security

2005-11-20 Thread George Lee
change!). Peace, George On 11/19/05, Dieter Maurer [EMAIL PROTECTED] wrote: George Lee wrote at 2005-11-19 00:46 -0500: In CMFCore 1.5.4: If a low-security-clearance user calls an external method that pastes an object from a PortalFolder, he gets an error because the following line

[Zope] Products have incorrect home attribute

2006-01-17 Thread George Lee
After migrating to a new server, several of my Zope products have an incorrect home attribute that specifies where they live on the filesystem. However, when I try to change these attributes using an external method, the attributes do not change. Any help? Peace, George

[Zope] Re: Products have incorrect home attribute

2006-01-18 Thread George Lee
I asked the same question a couple of days ago (see wrong directoy in Control_Panel.Products..home) and no, they aren't reset at zope restart, and deleting the pyc files doesn't help either. Thanks, didn't see the previous conversation. =) I'll do the delete the Products objects trick

[Zope] Re: Newbee interfaces and implementations

2006-01-18 Thread George Lee
So you recommend that I should just skip them as long as I'm on Zope2? I would be happy with that. I find them confusing when they don't really interface with but just document my methods. Some of the reasons interfaces can be helpful are (1) for documentation purposes and clarity for code

[Zope] SOLUTION -- Products have incorrect home attribute

2006-01-19 Thread George Lee
After migrating to a new server, several of my Zope products have an incorrect home attribute that specifies where they live on the filesystem. However, when I try to change these attributes using an external method, the attributes do not change. Any help? Peace, George Turns out it was

[Zope] Re: major problems placing authentication on an extranet site-security flaw?

2006-02-11 Thread George Lee
michael nt milne [EMAIL PROTECTED] writes: HiI have major problems here trying to set-up authentication over a whole Plone site using Zope. I'm not going to get involved in the large Zope security discussion but I will post an additional something to plone-users in reply to the more narrow

[Zope] Re: major problems placing authentication on an extranet site-security flaw?

2006-02-11 Thread George Lee
Scratch that, looking more closely at the thread it looks like you followed the make site private documentation and it worked. Peace, George ___ Zope maillist - Zope@zope.org http://mail.zope.org/mailman/listinfo/zope ** No cross posts or HTML

[Zope] Re: Question about Zope and security

2006-03-29 Thread George Lee
I'd rather encrypt passwords with a hash and reset the password if the users have lost it. Is it possible to do that in Zope? Isn't there an option in GRUF to encrypt passwords? Although I don't think that affects the user's sending of passwords over the Web. Peace, George