[Zope] ZODBC configuration problems

2000-11-28 Thread paul_s_johnson
Alas, I am but a Zope newbie and need help getting my database connections to work. I have previously configured the ODBC Data Source Administrator to link Access mdbs with the PERL DBI module and it has worked with no problems. I have installed the ZODBC product and in the Zope database

[Zope] Help with Nested ZSQL methods

2000-11-29 Thread paul_s_johnson
I thought I saw this answer to this one time on http://www.zope.org once, but for the life of me I cannot seem to find it. I have two ZSQL methods, both tested and work. ZSQL method 1 === method id= sql_get_schedules SELECT * FROM Schedules WHERE JobID = dtml-var JobID

[Zope] Large XML files

2000-12-05 Thread paul_s_johnson
I am testing the possibilities of delivering the content of XML Documents through the Zope environment. Unfortunately, some of the proposed file are rather large (up to 760KB) and just uploading them and viewing them on our current Zope server is prohibitively slow. Our server, running Z2 is a

[Zope] MySQL connection woes

2001-01-09 Thread paul_s_johnson
After following several howtos, tracking numerous threads from this list, and spending several days losing my mind, I sense that I am finally getting closer to having Zope and MySQL talking to each other. SETUP: I am running on Linux with Redhat with MySQL 3.22.32 and ZMySQLDA with

RE: [Zope] MySQL connection woes

2001-01-09 Thread paul_s_johnson

RE: [Zope] MySQL connection woes

2001-01-09 Thread paul_s_johnson
One other bizarre symptom: when I test the database connection with a INSERT query it works and inserts data into the designated MySQL table in the query, although there is no indication that it is working in Zope. I changed the user table for the MySQL user cited in the connection string so

[Zope] MySQLDA and MySQL-python - patch needed?

2001-01-10 Thread paul_s_johnson
My Zope-MySQL connection is still not quite working. It appears that the request from Zope is reaching MySQL and it if is an UPDATE or INSERT query it executes properly on the MySQL side. However, SELECT queries and similar are not getting their information back to Zope from MySQL. Is there some

RE: [Zope] MySQLDA and MySQL-python - patch needed?

2001-01-11 Thread paul_s_johnson
Paul S. Johnson URS Corporation 700 Third Street South Minneapolis, MN 55415-1199 612-373-6389

RE: [Zope] MySQLDA and MySQL-python - patch needed?

2001-01-11 Thread paul_s_johnson
-Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of [EMAIL PROTECTED] Sent: Wednesday, January 10, 2001 9:30 AM To: [EMAIL PROTECTED] Subject: [Zope] MySQLDA and MySQL-python - patch needed? My Zope-MySQL connection is still not quite working. It

Re: [Zope] Help getting zope to do frames!

2001-01-11 Thread paul_s_johnson
To properly reference your frames by their absolute urls, instead of this: frame name="A" src="dtml-var top" frame name="B" src="dtml-var main" Try this: frame name="A" src="dtml-var "top.absolute_url()"" frame name="B" src="dtml-var "main.absolute_url()"" -PSJ

[Zope] Re: MySQLDA and MySQL-python - patch needed?

2001-01-15 Thread paul_s_johnson
Brian, I finally got it working. Here's what I did: I uninstalled all of ZMySQLDA and MySQL-python (formerly MySQLdb - this name change didn't help any although in the big picture it probably needed to be done) deleting any trace of it. I then followed all the directions starting from here: