Re: [Zope] Re: Lost user credentials

2007-03-13 Thread Garito

Any idea then?

2007/3/12, Garito [EMAIL PROTECTED]:




2007/3/12, Josef Meile [EMAIL PROTECTED]:

  To Dieter: I use HTTP authentication method (at least I suppose that).
 I
  don't change anything about the default configuration nor use any
 cookie
  at least
 What you get when you authenticate: a pop-up window (HTTP
 authentication) or an html form (Cookie based authentication)?


Finally I use HTTP authentication method (pop-up window)

 What I wonder is CrearFuncionalidad works ok but not BorrarFuncionalidad
  who are launched both in the same way
 In the original thread:
 http://mail.zope.org/pipermail/zope/2007-March/170794.html

 you said:

 The question I can't understand is when BorrarFuncionalidad ask for a
 login and password I put my user that is manager and owner but the
 login don't work (it ask again and again)
 
 Both scripts has the same parent and the same security permissions

 How are you defining the permissions: by checking the Acquire
 permission settings? checkbox or are you implicit defining a role for
 that permission? In the first case zope will scan the folder hierarchy
 till it finds a folder where the permission is defined. In the worst
 case it will reach the root folder where the permission must be either
 enabled or disabled. So, it can be that somewhere the Delete Objects
 permission was disabled for the Manager and Authenticated roles. If
 I were you, I would try to implicit define the Delete objects
 permission in the folder where you want to delete the objects and see if
 the problem persists.


I use Acquire permissions (I don't touch anything)
If Manager couldn't delete object at this folder I couldn't delete any
object with ZMI but I can

In your last reply to the other thread:
 http://mail.zope.org/pipermail/zope/2007-March/170806.html

 you asked:
 
 I'm using prototype to launch some actions via AJAX
 Could be this the problem?
 How can I conservate the user who launch the actions between AJAX calls?

 

 I have never used AJAX, so, I don't know if the user credentials get
 lost during the call of your AJAX code. Perhaps other people can help
 here.

 Regards
 Josef


 Out-topic:
 Fuck$%ing gmail
 Sorry all for this stupidity
 Then try to use another newsreader like Thunderbird (multi platform). If
 you are on windows you could also try Outlook Express as well.


Sure. But the real question is don't use gmail at least
I try Google Apps for your domain but this was a big error
I'm in the process to install a linux server with all my needs but I'm
newbie with it
For now I disable the hotkeys on gmail to avoid to send unconcluded
messages (as before) . Sorry for the inconveniences (now I need to be
subscribed to this list with two accounts because my main one don't receive
some messages from this list

Thanks!!!

___
 Zope maillist  -   Zope@zope.org
 http://mail.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )




--
Mis Cosas: http://blogs.sistes.net/Garito





--
Mis Cosas: http://blogs.sistes.net/Garito
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


[Zope] Re: Lost user credentials

2007-03-12 Thread Josef Meile
To Dieter: I use HTTP authentication method (at least I suppose that). I 
don't change anything about the default configuration nor use any cookie 
at least
What you get when you authenticate: a pop-up window (HTTP 
authentication) or an html form (Cookie based authentication)?


What I wonder is CrearFuncionalidad works ok but not BorrarFuncionalidad 
who are launched both in the same way

In the original thread:
http://mail.zope.org/pipermail/zope/2007-March/170794.html

you said:

The question I can't understand is when BorrarFuncionalidad ask for a 
login and password I put my user that is manager and owner but the 
login don't work (it ask again and again)


Both scripts has the same parent and the same security permissions

How are you defining the permissions: by checking the Acquire 
permission settings? checkbox or are you implicit defining a role for 
that permission? In the first case zope will scan the folder hierarchy 
till it finds a folder where the permission is defined. In the worst 
case it will reach the root folder where the permission must be either 
enabled or disabled. So, it can be that somewhere the Delete Objects 
permission was disabled for the Manager and Authenticated roles. If 
I were you, I would try to implicit define the Delete objects 
permission in the folder where you want to delete the objects and see if 
the problem persists.


In your last reply to the other thread:
http://mail.zope.org/pipermail/zope/2007-March/170806.html

you asked:

I'm using prototype to launch some actions via AJAX
Could be this the problem?
How can I conservate the user who launch the actions between AJAX calls?


I have never used AJAX, so, I don't know if the user credentials get 
lost during the call of your AJAX code. Perhaps other people can help here.


Regards
Josef


Out-topic:
Fuck$%ing gmail
Sorry all for this stupidity
Then try to use another newsreader like Thunderbird (multi platform). If 
you are on windows you could also try Outlook Express as well.

___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Re: Lost user credentials

2007-03-12 Thread Garito

2007/3/12, Josef Meile [EMAIL PROTECTED]:


 To Dieter: I use HTTP authentication method (at least I suppose that). I
 don't change anything about the default configuration nor use any cookie
 at least
What you get when you authenticate: a pop-up window (HTTP
authentication) or an html form (Cookie based authentication)?



Finally I use HTTP authentication method (pop-up window)


What I wonder is CrearFuncionalidad works ok but not BorrarFuncionalidad
 who are launched both in the same way
In the original thread:
http://mail.zope.org/pipermail/zope/2007-March/170794.html

you said:

The question I can't understand is when BorrarFuncionalidad ask for a
login and password I put my user that is manager and owner but the
login don't work (it ask again and again)

Both scripts has the same parent and the same security permissions

How are you defining the permissions: by checking the Acquire
permission settings? checkbox or are you implicit defining a role for
that permission? In the first case zope will scan the folder hierarchy
till it finds a folder where the permission is defined. In the worst
case it will reach the root folder where the permission must be either
enabled or disabled. So, it can be that somewhere the Delete Objects
permission was disabled for the Manager and Authenticated roles. If
I were you, I would try to implicit define the Delete objects
permission in the folder where you want to delete the objects and see if
the problem persists.



I use Acquire permissions (I don't touch anything)
If Manager couldn't delete object at this folder I couldn't delete any
object with ZMI but I can

In your last reply to the other thread:

http://mail.zope.org/pipermail/zope/2007-March/170806.html

you asked:

I'm using prototype to launch some actions via AJAX
Could be this the problem?
How can I conservate the user who launch the actions between AJAX calls?


I have never used AJAX, so, I don't know if the user credentials get
lost during the call of your AJAX code. Perhaps other people can help
here.

Regards
Josef


Out-topic:
Fuck$%ing gmail
Sorry all for this stupidity
Then try to use another newsreader like Thunderbird (multi platform). If
you are on windows you could also try Outlook Express as well.



Sure. But the real question is don't use gmail at least
I try Google Apps for your domain but this was a big error
I'm in the process to install a linux server with all my needs but I'm
newbie with it
For now I disable the hotkeys on gmail to avoid to send unconcluded messages
(as before) . Sorry for the inconveniences (now I need to be subscribed to
this list with two accounts because my main one don't receive some messages
from this list

Thanks!!!

___

Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )





--
Mis Cosas: http://blogs.sistes.net/Garito
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )