Re: [Zope] Zope utf-8 problem using MySQL

2008-03-23 Thread Dieter Maurer
Hugo Ramos wrote at 2008-3-21 20:36 +:
 ...
I retrive the data using a Z MySQL Database Connection and the
corresponding Z SQL Method.
Everything works fine but the only way to get the utf-8 data is using
SET NAMES 'utf-8' before the select statement.

This indicates that your MySQL client library did not understand that 
it should use utf-8 by default. Verify, that your
configuration to this end is in effect for the Zope process.



-- 
Dieter
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Zope utf-8 problem using MySQL

2008-03-22 Thread Tino Wildenhain

Hugo Ramos wrote:

yellow,

It's a question of taste... I use a Macbook Pro/Leopard laptop instead
of a PC/win32 laptop... Also a question of taste! :-)


Guess you got the taste thing a bit wrong ;-) MySQL is the PC/win32
in your picture :-)

Cheers
Tino
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Zope utf-8 problem using MySQL

2008-03-22 Thread Hugo Ramos
What would you recommend? :-)


On Sat, Mar 22, 2008 at 8:49 AM, Tino Wildenhain [EMAIL PROTECTED] wrote:
 Hugo Ramos wrote:
   yellow,
  
   It's a question of taste... I use a Macbook Pro/Leopard laptop instead
   of a PC/win32 laptop... Also a question of taste! :-)

  Guess you got the taste thing a bit wrong ;-) MySQL is the PC/win32
  in your picture :-)

  Cheers
  Tino




-- 
Hugo Ramos
IT Project Manager
http://www.hugoramos.eu/
[EMAIL PROTECTED]
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Zope utf-8 problem using MySQL

2008-03-22 Thread Tino Wildenhain

Hugo Ramos wrote:

What would you recommend? :-)


What should the database do for you? How did
you select?

T.
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Zope utf-8 problem using MySQL

2008-03-21 Thread Dieter Maurer
Hugo Ramos wrote at 2008-3-19 18:11 +:
 ...
The problem is that when retrieving data from a table the
international chars become alien symbols...

How do you retrieve the data?

You should check the data immediately when you receive it
from the database. If it is already wrong at this place,
you know there is a problem with your database access -- maybe
your utf-8 configuration is ineffective for some reason.



-- 
Dieter
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Zope utf-8 problem using MySQL

2008-03-21 Thread Tino Wildenhain

Hugo Ramos wrote:

Yellow ppl,

I'm using Zope 2.10.5 + MySQL 5.0.51a + MySQL-python-1.2.2.


Why? I mean, is there a special business reason to use MySQL?
Just curious...


T.
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Zope utf-8 problem using MySQL

2008-03-21 Thread Hugo Ramos
yellow,

I retrive the data using a Z MySQL Database Connection and the
corresponding Z SQL Method.
Everything works fine but the only way to get the utf-8 data is using
SET NAMES 'utf-8' before the select statement.

I wonder what is wrong... Is it possible to centralize this utf-8
setting in 1 place instead of using it on *EVERY* Z SQL Method???

Thanks
Hugo



On Fri, Mar 21, 2008 at 7:50 PM, Dieter Maurer [EMAIL PROTECTED] wrote:
 Hugo Ramos wrote at 2008-3-19 18:11 +:
   ...

 The problem is that when retrieving data from a table the
  international chars become alien symbols...

  How do you retrieve the data?

  You should check the data immediately when you receive it
  from the database. If it is already wrong at this place,
  you know there is a problem with your database access -- maybe
  your utf-8 configuration is ineffective for some reason.



  --
  Dieter




-- 
Hugo Ramos
IT Project Manager
http://www.hugoramos.eu/
[EMAIL PROTECTED]
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Zope utf-8 problem using MySQL

2008-03-21 Thread Hugo Ramos
yellow,

It's a question of taste... I use a Macbook Pro/Leopard laptop instead
of a PC/win32 laptop... Also a question of taste! :-)


Thanks
Hugo


On Fri, Mar 21, 2008 at 8:23 PM, Tino Wildenhain [EMAIL PROTECTED] wrote:
 Hugo Ramos wrote:
   Yellow ppl,
  
   I'm using Zope 2.10.5 + MySQL 5.0.51a + MySQL-python-1.2.2.

  Why? I mean, is there a special business reason to use MySQL?
  Just curious...


  T.




-- 
Hugo Ramos
IT Project Manager
http://www.hugoramos.eu/
[EMAIL PROTECTED]
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )