Re: [Zope] z2.py with -a option: ZServer FTP server not listening on correct ip address

2000-07-19 Thread Tino Wildenhain



Joseph Wayne Norton wrote:
 
 I'm using the following start file:
 
 #! /bin/sh
 reldir=`dirname $0`
 PYTHONHOME=`cd $reldir; pwd`
 export PYTHONHOME
 exec /usr/local/bin/python \
   $PYTHONHOME/z2.py -u zope -a zope.domain.com -w 80 -f 8021 -F 8080 \
   -D "$@"
 
 and for simply testing purposes, I have defined the following hosts in
 my /etc/hosts file:
 
# localhost
127.0.0.1namaste localhost
# zope
127.0.0.40   zope-prd.domain.com zope.domain.com
^^^
whats 127.0.0.40 supposed to be? It cant for sure be the IP address
of the host, since it shares the netmask with localhost.

You should use one of the following nets to recruit your IP-addresses
from:

# RFC 1918 specifies that these networks are "internal".
# 10.0.0.0  10.255.255.255
# 172.16.0.0172.31.255.255
# 192.168.0.0   192.168.255.255

HTH
Tino Wildenhain

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )




[Zope] z2.py with -a option: ZServer FTP server not listening on correct ip address

2000-07-18 Thread Joseph Wayne Norton

I'm using the following start file:

#! /bin/sh
reldir=`dirname $0`
PYTHONHOME=`cd $reldir; pwd`
export PYTHONHOME   
exec /usr/local/bin/python \
  $PYTHONHOME/z2.py -u zope -a zope.domain.com -w 80 -f 8021 -F 8080 \
  -D "$@"

and for simply testing purposes, I have defined the following hosts in
my /etc/hosts file:

   # localhost
   127.0.0.1namaste localhost
   # zope 
   127.0.0.40   zope-prd.domain.com zope.domain.com 

and the following information was displayed after starting zope:

bash-2.03# ./start
--
2000-07-18T14:36:17 INFO(0) ZServer Medusa (V1.13.4.1) started at Tue Jul 18 
23:36:17 2000
Hostname: zope-prd.domain.com
Port:80

--
2000-07-18T14:36:17 INFO(0) ZServer FTP server started at Tue Jul 18 23:36:17 
2000
Authorizer:None
Hostname: namaste
Port: 8021
--
2000-07-18T14:36:17 INFO(0) ZServer FastCGI Server (V1.0) started at Tue Jul 
18 23:36:17 2000
IP  : zope.domain.com
Port: 8080
Socket path : None

--
2000-07-18T14:36:17 INFO(0) ZServer Monitor Server (V1.5) started on port 8099

I was expecting the ZServer FTP to be listening on either
zope-prd.domain.com or zope.domain.com IP addresses, but it is
listening on my localhost instead.  I also haven't tried yet, but I'm
not sure what ip address the ZServer Monitor is listening on.

Is this a bug, a feature, or problem with my setup on linux?

thanks,

- joe n.

--
Joseph Norton

[EMAIL PROTECTED]
+81-3-3822-6936
2-10-7 Tabata, Kita-ku, Tokyo 114-0014, Japan (〒114-0014  
東京都北区田端2丁目10-7)

___
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )