Re: [Zope] Accesing python module

2005-06-05 Thread Tino Wildenhain
Am Sonntag, den 05.06.2005, 16:39 -0400 schrieb Leticia Larrosa:
 Hi:
  I installed the PyXml package, and appear in the c:\Python24\Lib
 \site-packages folder and i want to import a module of that library
 from an external method:
 import xml.dom.ext
 But i can't import from an external method any of the modules that are
 in the Lib\site-packages folder of my python instalation.
 Why can't import them?
 By default an external method have acces to modules that are in Lib
 \site-packages of a Python installation?
 I use Zope 2.7.6 
 for windows and Python2.4 (c:\Python24\Lib\site-packages !)
 The error that i get is:
...

Zope on windows is packaged with own and right version 
of python, which is 2.3 for all current Zopes.

So you need to use the package for python 2.3
and not 2.4. Next, since zope has own python,
you either copy the module to zopes python
or change startzope.bat to refer to your
installed python2.3.

You cannot just point to or use 2.4, since 
zopes extension classes are compiled for 2.3.



___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Accesing python module

2005-06-05 Thread Leticia Larrosa


Thanks to Tino Wildenhain.Tino Wildenhain wrote: Zope on 
windows is packaged with own and right version  of python, which is 
2.3 for all current Zopes.Zope on Debian (for example) too?
-Original Message-From: Tino Wildenhain 
[EMAIL PROTECTED]To: Leticia Larrosa 
[EMAIL PROTECTED]Cc: 
zope@zope.orgDate: Sun, 05 Jun 2005 23:13:06 +0200Subject: Re: 
[Zope] Accesing python module Am Sonntag, den 05.06.2005, 16:39 
-0400 schrieb Leticia Larrosa:  Hi:  I 
installed the "PyXml" package, and appear in the "c:\Python24\Lib 
 \site-packages" folder and i want to import a module of that library
  from an external method:  "import xml.dom.ext" 
 But i can't import from an external method any of the modules that
 are  in the "Lib\site-packages" folder of my python 
instalation.  Why can't import them?  By default an 
external method have acces to modules that are in "Lib  
\site-packages" of a Python installation?  I use Zope 2.7.6 
  for windows and Python2.4 ("c:\Python24\Lib\site-packages" !)
  The error that i get is: ...  Zope on 
windows is packaged with own and right version  of python, which is 
2.3 for all current Zopes.  So you need to use the package 
for python 2.3 and not 2.4. Next, since zope has own python, 
you either copy the module to zopes python or change startzope.bat 
to refer to your installed python2.3.  You cannot 
just point to or use 2.4, since  zopes extension classes are 
compiled for 2.3.
___ Zope maillist 
- 
Zope@zope.org 
http://mail.zope.org/mailman/listinfo/zope **  No cross 
posts or HTML encoding! ** (Related lists -  
http://mail.zope.org/mailman/listinfo/zope-announce 
http://mail.zope.org/mailman/listinfo/zope-dev )  

___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Accesing python module

2005-06-05 Thread Andreas Pakulat
On 05.Jun 2005 - 17:33:49, Leticia Larrosa wrote:
 Thanks to Tino Wildenhain.
 
 Tino Wildenhain wrote:
  Zope on windows is packaged with own and right version 
  of python, which is 2.3 for all current Zopes.
 
 Zope on Debian (for example) too?

Yes, Debian packages for zope27 depend on python2.3 so they'll install
those packages as well. 

Andreas

-- 
Go to a movie tonight.  Darkness becomes you.
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Accesing python module

2005-06-05 Thread Tino Wildenhain
Am Sonntag, den 05.06.2005, 17:33 -0400 schrieb Leticia Larrosa:
 Thanks to Tino Wildenhain.
 
 Tino Wildenhain wrote:
  Zope on windows is packaged with own and right version 
  of python, which is 2.3 for all current Zopes.
 
 Zope on Debian (for example) too?

of course :-) Also on netbsd, freebsd, aix,
solaris, c=64 (oups ;))

Well in fact there is development towards
2.4 but it will take its time to become
stable and secure. Zope security depends
much on the specifics of python and newer
versions may have differences there.

___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )