Re: [Zope] Internet Explorer does not follows redirect, while Firefox does

2006-06-02 Thread Kees de Brabander
I guess your response means it does not solve your problem. However, I won't
be able to help you further. It's just a trick that worked for me. Your use
case must be different then.
cb
- Original Message - 
From: Marco Bizzarri [EMAIL PROTECTED]
To: Kees de Brabander [EMAIL PROTECTED]
Cc: Zope Users Mailing List zope@zope.org
Sent: Thursday, June 01, 2006 12:49 PM
Subject: Re: [Zope] Internet Explorer does not follows redirect,while
Firefox does


 Ok, I've been able to experiment. All my pages have the following in
 the head section:

 meta http-equiv=Cache-Control content=no-cache
 meta http-equiv=Pragma content=no-cache
 meta http-equiv=Expires content=Date.Now
 meta http-equiv=Pragma-directive content=no-cache
 meta http-equiv=cache-directive content=no-cache

 Also, I added, before every redirect, the following:

 request.get('RESPONSE').setHeader('pragma', 'no-cache')

 Any suggestion?

 On 5/31/06, Kees de Brabander [EMAIL PROTECTED] wrote:
  Either
dtml-call RESPONSE.setHeader('pragma','no-cache')
  or
dtml-call RESPONSE.setHeader('Expires',(_.DateTime()-1).rfc822())
  or both in the head section of your page will do the trick.
  cb
 
  - Original Message -
  From: Marco Bizzarri [EMAIL PROTECTED]
  To: Zope Users Mailing List zope@zope.org
  Sent: Wednesday, May 31, 2006 7:33 AM
  Subject: [Zope] Internet Explorer does not follows redirect,while
Firefox
  does
 
 
   Hi all.
  
   I don't think this is a specific Zope problem. However, I'm
   experiencing it in a Zope context, and this is why I'm here asking.
  
   In a custom Zope application, we have a problem with Internet
Explorer.
  
   The application follows a page - submit - redirect - page cycle.
  
   To state more clearly: the page presented to the user can have a link.
   When the user clicks on the link, something is done, and eventually
   the user is redirected to the same page which will display different
   data based on the results of its previous click.
  
   The problem is that when IE sees that the result page has the same URL
   as the first page  it does not reload the page and instead shows me
   the cached version.
  
   The problem is not shown with Firefox.
  
   As far as I can understand, this is an HTTP header issue, but I would
   like to know if anyone already has experienced this problem, and has
   some solution about it.
  
   Regards
   Marco
   --
   Marco Bizzarri
   http://notenotturne.blogspot.com/
   ___
   Zope maillist  -  Zope@zope.org
   http://mail.zope.org/mailman/listinfo/zope
   **   No cross posts or HTML encoding!  **
   (Related lists -
http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )
  
 
 


 -- 
 Marco Bizzarri
 http://notenotturne.blogspot.com/


___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Internet Explorer does not follows redirect, while Firefox does

2006-06-02 Thread Gabriel Genellina

At Thursday 1/6/2006 07:49, Marco Bizzarri wrote:


Ok, I've been able to experiment. All my pages have the following in
the head section:

   meta http-equiv=Cache-Control content=no-cache
   meta http-equiv=Pragma content=no-cache
   meta http-equiv=Expires content=Date.Now
   meta http-equiv=Pragma-directive content=no-cache
   meta http-equiv=cache-directive content=no-cache

Also, I added, before every redirect, the following:

   request.get('RESPONSE').setHeader('pragma', 'no-cache')

Any suggestion?


The browser might ignore the meta tag inside the document; 
REQUEST.RESPONSE.setHeader() is safer.
Your Expires header does not appear to be correct; try Expires: 0 
(anyway it should have the same effect since invalid dates are 
considered already expired).



Gabriel Genellina
Softlab SRL  




_ 
Horóscopos, Salud y belleza, Chistes, Consejos de amor: 
el contenido más divertido para tu celular está en Yahoo! Móvil. 
Obtenelo en http://movil.yahoo.com.ar

___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Internet Explorer does not follows redirect, while Firefox does

2006-06-02 Thread Marco Bizzarri

Thanks Kees, I will check today and I will report if this solves the issue :-).

Regards
Marco

On 5/31/06, Kees de Brabander [EMAIL PROTECTED] wrote:

Either
  dtml-call RESPONSE.setHeader('pragma','no-cache')
or
  dtml-call RESPONSE.setHeader('Expires',(_.DateTime()-1).rfc822())
or both in the head section of your page will do the trick.
cb

- Original Message -
From: Marco Bizzarri [EMAIL PROTECTED]
To: Zope Users Mailing List zope@zope.org
Sent: Wednesday, May 31, 2006 7:33 AM
Subject: [Zope] Internet Explorer does not follows redirect,while Firefox
does


 Hi all.

 I don't think this is a specific Zope problem. However, I'm
 experiencing it in a Zope context, and this is why I'm here asking.

 In a custom Zope application, we have a problem with Internet Explorer.

 The application follows a page - submit - redirect - page cycle.

 To state more clearly: the page presented to the user can have a link.
 When the user clicks on the link, something is done, and eventually
 the user is redirected to the same page which will display different
 data based on the results of its previous click.

 The problem is that when IE sees that the result page has the same URL
 as the first page  it does not reload the page and instead shows me
 the cached version.

 The problem is not shown with Firefox.

 As far as I can understand, this is an HTTP header issue, but I would
 like to know if anyone already has experienced this problem, and has
 some solution about it.

 Regards
 Marco
 --
 Marco Bizzarri
 http://notenotturne.blogspot.com/
 ___
 Zope maillist  -  Zope@zope.org
 http://mail.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://mail.zope.org/mailman/listinfo/zope-announce
  http://mail.zope.org/mailman/listinfo/zope-dev )






--
Marco Bizzarri
http://notenotturne.blogspot.com/
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Internet Explorer does not follows redirect, while Firefox does

2006-06-01 Thread Marco Bizzarri

Ok, I've been able to experiment. All my pages have the following in
the head section:

   meta http-equiv=Cache-Control content=no-cache
   meta http-equiv=Pragma content=no-cache
   meta http-equiv=Expires content=Date.Now
   meta http-equiv=Pragma-directive content=no-cache
   meta http-equiv=cache-directive content=no-cache

Also, I added, before every redirect, the following:

   request.get('RESPONSE').setHeader('pragma', 'no-cache')

Any suggestion?

On 5/31/06, Kees de Brabander [EMAIL PROTECTED] wrote:

Either
  dtml-call RESPONSE.setHeader('pragma','no-cache')
or
  dtml-call RESPONSE.setHeader('Expires',(_.DateTime()-1).rfc822())
or both in the head section of your page will do the trick.
cb

- Original Message -
From: Marco Bizzarri [EMAIL PROTECTED]
To: Zope Users Mailing List zope@zope.org
Sent: Wednesday, May 31, 2006 7:33 AM
Subject: [Zope] Internet Explorer does not follows redirect,while Firefox
does


 Hi all.

 I don't think this is a specific Zope problem. However, I'm
 experiencing it in a Zope context, and this is why I'm here asking.

 In a custom Zope application, we have a problem with Internet Explorer.

 The application follows a page - submit - redirect - page cycle.

 To state more clearly: the page presented to the user can have a link.
 When the user clicks on the link, something is done, and eventually
 the user is redirected to the same page which will display different
 data based on the results of its previous click.

 The problem is that when IE sees that the result page has the same URL
 as the first page  it does not reload the page and instead shows me
 the cached version.

 The problem is not shown with Firefox.

 As far as I can understand, this is an HTTP header issue, but I would
 like to know if anyone already has experienced this problem, and has
 some solution about it.

 Regards
 Marco
 --
 Marco Bizzarri
 http://notenotturne.blogspot.com/
 ___
 Zope maillist  -  Zope@zope.org
 http://mail.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://mail.zope.org/mailman/listinfo/zope-announce
  http://mail.zope.org/mailman/listinfo/zope-dev )






--
Marco Bizzarri
http://notenotturne.blogspot.com/
___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Internet Explorer does not follows redirect, while Firefox does

2006-06-01 Thread Cliff Ford
I have forgotten the exact details, but some time back I found it 
necessary to pad out the body of the redirect page in order to make IE 
perform as intended. It may have been for an older version of IE, and 
the padding just needed to be a certain number of bytes. I think I came 
across a later reference to the problem. Have you googled for info? 
Padding follows.


Cliff

!--
Testing an unusual feature of IE
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
xx xx xxx xx xx x xx
--


Marco Bizzarri wrote:

Ok, I've been able to experiment. All my pages have the following in
the head section:

   meta http-equiv=Cache-Control content=no-cache
   meta http-equiv=Pragma content=no-cache
   meta http-equiv=Expires content=Date.Now
   meta http-equiv=Pragma-directive content=no-cache
   meta http-equiv=cache-directive content=no-cache

Also, I added, before every redirect, the following:

   request.get('RESPONSE').setHeader('pragma', 'no-cache')

Any suggestion?

On 5/31/06, Kees de Brabander [EMAIL PROTECTED] wrote:


Either
  dtml-call RESPONSE.setHeader('pragma','no-cache')
or
  dtml-call RESPONSE.setHeader('Expires',(_.DateTime()-1).rfc822())
or both in the head section of your page will do the trick.
cb

- Original Message -
From: Marco Bizzarri [EMAIL PROTECTED]
To: Zope Users Mailing List zope@zope.org
Sent: Wednesday, May 31, 2006 7:33 AM
Subject: [Zope] Internet Explorer does not follows redirect,while Firefox
does


 Hi all.

 I don't think this is a specific Zope problem. However, I'm
 experiencing it in a Zope context, and this is why I'm here asking.

 In a custom Zope application, we have a problem with Internet Explorer.

 The application follows a page - submit - redirect - page cycle.

 To state more clearly: the page presented to the user can have a link.
 When the user clicks on the link, something is done, and eventually
 the user is redirected to the same page which will display different
 data based on the results of its previous click.

 The problem is that when IE sees that the result page has the same URL
 as the first page  it does not reload the page and instead shows me
 the cached version.

 The problem is not shown with Firefox.

 As far as I can understand, this is an HTTP header issue, but I would
 like to know if anyone already has experienced this problem, and has
 some solution about it.

 Regards
 Marco
 --
 Marco Bizzarri
 http://notenotturne.blogspot.com/
 ___
 Zope maillist  -  Zope@zope.org
 http://mail.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://mail.zope.org/mailman/listinfo/zope-announce
  http://mail.zope.org/mailman/listinfo/zope-dev )







___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
http://mail.zope.org/mailman/listinfo/zope-announce

http://mail.zope.org/mailman/listinfo/zope-dev )


Re: [Zope] Internet Explorer does not follows redirect, while Firefox does

2006-05-31 Thread Kees de Brabander
Either
  dtml-call RESPONSE.setHeader('pragma','no-cache')
or
  dtml-call RESPONSE.setHeader('Expires',(_.DateTime()-1).rfc822())
or both in the head section of your page will do the trick.
cb

- Original Message - 
From: Marco Bizzarri [EMAIL PROTECTED]
To: Zope Users Mailing List zope@zope.org
Sent: Wednesday, May 31, 2006 7:33 AM
Subject: [Zope] Internet Explorer does not follows redirect,while Firefox
does


 Hi all.

 I don't think this is a specific Zope problem. However, I'm
 experiencing it in a Zope context, and this is why I'm here asking.

 In a custom Zope application, we have a problem with Internet Explorer.

 The application follows a page - submit - redirect - page cycle.

 To state more clearly: the page presented to the user can have a link.
 When the user clicks on the link, something is done, and eventually
 the user is redirected to the same page which will display different
 data based on the results of its previous click.

 The problem is that when IE sees that the result page has the same URL
 as the first page  it does not reload the page and instead shows me
 the cached version.

 The problem is not shown with Firefox.

 As far as I can understand, this is an HTTP header issue, but I would
 like to know if anyone already has experienced this problem, and has
 some solution about it.

 Regards
 Marco
 -- 
 Marco Bizzarri
 http://notenotturne.blogspot.com/
 ___
 Zope maillist  -  Zope@zope.org
 http://mail.zope.org/mailman/listinfo/zope
 **   No cross posts or HTML encoding!  **
 (Related lists -
  http://mail.zope.org/mailman/listinfo/zope-announce
  http://mail.zope.org/mailman/listinfo/zope-dev )


___
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )