Re: [Zorba-coders] [Merge] lp:~zorba-coders/zorba/fots_driver into lp:zorba

2012-11-15 Thread Ghislain Fourny
Hi Sorin,

That looks very good!

I have the feeling the code for eval:assert-any-of could be simplified along 
the lines of:

let $results :=
  for $tmp in $expResult/*
  return result{
    for $r in eval:check-assertion($result,
        $tmp,
        $code,
        $errorDescription,
        $showResult)
    return item{$r}/item
  } /result
where every $result in $results satisfies $result/item
return concat(#xA;Assert-any-of returned: ,
    string-join(util:serialize-result($results/data(item)),
    ' '))

to avoid the redundant call of eval:check-assertion.
-- 
https://code.launchpad.net/~zorba-coders/zorba/fots_driver/+merge/133988
Your team Zorba Coders is subscribed to branch lp:zorba.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp


Re: [Zorba-coders] [Merge] lp:~zorba-coders/zorba/fots_driver into lp:zorba

2012-11-15 Thread Ghislain Fourny
There are a few occurrences of

if ($cond)
then ()
else $result

which can probably be simplified along the lines of:

$result[$cond]

-- 
https://code.launchpad.net/~zorba-coders/zorba/fots_driver/+merge/133988
Your team Zorba Coders is subscribed to branch lp:zorba.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp


Re: [Zorba-coders] [Merge] lp:~zorba-coders/zorba/zorba-error_printer_in_api into lp:zorba

2012-11-15 Thread William Candillon
Review: Approve


-- 
https://code.launchpad.net/~zorba-coders/zorba/zorba-error_printer_in_api/+merge/134405
Your team Zorba Coders is subscribed to branch lp:zorba.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp


Re: [Zorba-coders] [Merge] lp:~zorba-coders/zorba/zorba-error_printer_in_api into lp:zorba

2012-11-15 Thread Matthias Brantner
Review: Approve

I approve but I want to make sure the same or similar functionality (maybe 
without XML printing) is not already available in the API. Hence, I added Paul.
-- 
https://code.launchpad.net/~zorba-coders/zorba/zorba-error_printer_in_api/+merge/134405
Your team Zorba Coders is subscribed to branch lp:zorba.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp


Re: [Zorba-coders] [Merge] lp:~zorba-coders/zorba/zorba-error_printer_in_api into lp:zorba

2012-11-15 Thread Paul J. Lucas
Review: Disapprove

It's a stupid API.  There's no reason to have a class with a single static 
member function.  If you're going to make it public, it needs to be better.  
Two things come to mind:

1. (Trivial) Simply make it a global function -- no need for a class.

2. (Less trivial) Create a (real) ErrorPrinter class that holds the 
configuration parameters; then using operator, you can write an 
XQueryException to it.

3. Regardless, the indentation parameter should be an unsigned int (not a 
bool): it will specify a multiplier for the amount of indentation (where 0 = 
none).

BTW: It should take a ZorbaException, not an XQueryException.
-- 
https://code.launchpad.net/~zorba-coders/zorba/zorba-error_printer_in_api/+merge/134405
Your team Zorba Coders is subscribed to branch lp:zorba.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp