Re: [gentoo-user] Inconsistency in portage automake package versioning

2014-11-17 Thread gevisz
2014-11-18 2:04 GMT+02:00 Neil Bothwick n...@digimed.co.uk: On Tue, 18 Nov 2014 00:55:09 +0200, Gevisz wrote: You have both installed, 1.13.4 is just the latest. Give eix a try, it will make your life better. In this case equery also works: $ equery l automake * Searching

Re: [gentoo-user] Can't emerge mozilla-firefox-1.0.6-r2

2005-07-24 Thread Richard Fish
Jules Colding wrote: This could be a shot in the dark, but I think that you should remerge your autoconf and automake packages to see if that affects this. I'll be doing that. OK, I get a segfault doing that: ## snip ### test -z /usr/share/automake-1.9

[gentoo-user] openldap-2.4.24 fails to compile

2012-02-20 Thread Joseph
I have automake-1.9.6-r3 installed but emerging openldap fails, it seems to me it has something to do with this bug: https://bugs.gentoo.org/show_bug.cgi?id=403261 I have all three versions installed: equery list automake * Searching for automake ... [IP-] [ ] sys-devel/automake-1.9.6-r3

Re: [gentoo-user] Inconsistency in portage automake package versioning

2014-11-17 Thread Neil Bothwick
On Tue, 18 Nov 2014 00:55:09 +0200, Gevisz wrote: You have both installed, 1.13.4 is just the latest. Give eix a try, it will make your life better. In this case equery also works: $ equery l automake * Searching for automake ... [IP-] [ ] sys-devel/automake-1.11.6-r1sys

Re: [gentoo-user] Inconsistency in portage automake package versioning

2014-11-17 Thread Michael Orlitzky
On 11/17/2014 04:29 PM, Gevisz wrote: In today's system update I was advised to update sys-devel/automake from version 1.11.6 to version 1.11.6-r1. However, just after the update the system reported that sys-devel/automake has version 1.13.4. Is it only me who think that something is wrong

Re: [gentoo-user] emerge gnome looking for automake-1.7

2005-05-01 Thread Scott Taylor
On Mon, 2005-05-02 at 01:15 +1000, Richard Watson wrote: # emerge sys-dev/automake-1.7 Calculating dependencies !!! Problem in sys-dev/automake-1.7 dependencies. !!! Specific key requires an operator (sys-dev/automake-1.7) (try adding an '=') exceptions add an '=', like so: emerge

[gentoo-user] automake 1.4

2011-03-18 Thread Kraus Philipp
Hello, I would like to emerge a new automake version. At this time emerge shows the 1.11.1 version but I need the version 1.4. I have found a security information that the package is masked because a vulnerabily. I need only the 1.4 version to compiling a source, after compiling I can

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Rafa Griman
with WANT_AUTOMAKE=1.12 emerge -1a libpaper Can you list the autoconf, automake and automake-wrapper versions you've got installed? Just to ckech your versions with mine. The latest testing release of each, I've nothing masked. % qlist -ICv auto sys-devel/autoconf-2.13 sys-devel/autoconf-2.69

Re: [gentoo-user] How many automake?

2007-10-19 Thread ??????
try this: emerge --clean automake Scrolling my package db I found I have installed many automakes. Here is the list: drwxr-xr-x 2 root root 664 16 ott 10:36 automake-1.10 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.4_p6 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.5 drwxr-xr-x

[gentoo-user] Problems with aclocal

2013-05-01 Thread Rafa Griman
/autoconf-2.69:2.5 # equery list automake * Searching for automake ... [IP-] [ ] sys-devel/automake-1.10.3:1.10 [IP-] [ ] sys-devel/automake-1.11.6:1.11 [IP-] [ ] sys-devel/automake-1.12.6:1.12 [IP-] [ ] sys-devel/automake-1.13.1:1.13 # equery list automake-wrapper * Searching for automake

[gentoo-user] emerge gnome looking for automake-1.7

2005-05-01 Thread Richard Watson
Hi - emerge gnome is now giving me the following error am-wrapper: /usr/bin/automake-1.7 is missing or not executable please try emerging the correct version I checked /usr/bin and automake-1.7 is not present. 1.5 and 1.9 are but when I ... # emerge sys-dev/automake-1.7 Calculating

Re: [gentoo-user] openldap-2.4.24 fails to compile

2012-02-20 Thread Pandu Poluan
On Feb 21, 2012 1:57 AM, Joseph syscon...@gmail.com wrote: I have automake-1.9.6-r3 installed but emerging openldap fails, it seems to me it has something to do with this bug: https://bugs.gentoo.org/show_bug.cgi?id=403261 I have all three versions installed: equery list automake

Re: [gentoo-user] Can't emerge mozilla-firefox-1.0.6-r2

2005-07-24 Thread Jules Colding
that can show the problem so you might very well be correct. This could be a shot in the dark, but I think that you should remerge your autoconf and automake packages to see if that affects this. I'll be doing that. OK, I get a segfault doing that: ## snip ### test -z

[gentoo-user] How many automake?

2007-10-19 Thread econti
Scrolling my package db I found I have installed many automakes. Here is the list: drwxr-xr-x 2 root root 664 16 ott 10:36 automake-1.10 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.4_p6 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.5 drwxr-xr-x 2 root root 936 9 feb 2006

Re: [gentoo-user] How many automake?

2007-10-19 Thread ??????
Scrolling my package db I found I have installed many automakes. Here is the list: drwxr-xr-x 2 root root 664 16 ott 10:36 automake-1.10 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.4_p6 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.5 drwxr-xr-x 2 root root 936 9 feb 2006

Re: [gentoo-user] Re: Multiple versions of automake?

2010-03-10 Thread Tanstaafl
On 2010-03-10 1:45 PM, Nikos Chantziaras wrote: And this means multiple automake versions on the system are perfectly normal. Ok, that's what I needed to hear... :) Thanks Nikos... -- Charles

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Neil Bothwick
On Thu, 2 May 2013 16:43:05 +0200, Rafa Griman wrote: I just tried rebuilding libpaper and got the aclocal errors (more specifically, the error about AM_CONFIG_HEADER being obsolete). But it worked with WANT_AUTOMAKE=1.12 emerge -1a libpaper Can you list the autoconf, automake

Re: [gentoo-user] Inconsistency in portage automake package versioning

2014-11-17 Thread Gevisz
On Mon, 17 Nov 2014 16:46:48 -0500 Michael Orlitzky m...@gentoo.org wrote: On 11/17/2014 04:29 PM, Gevisz wrote: In today's system update I was advised to update sys-devel/automake from version 1.11.6 to version 1.11.6-r1. However, just after the update the system reported that sys-devel

Re: [gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-06-09 Thread Bo Ørsted Andresen
On Saturday 09 June 2007 08:44:23 Kent Fredric wrote: %=sys-devel/automake-1.9 %=sys-devel/automake-1.9 %=sys-devel/automake-1.9 Why that syntax ? Well , we have a dilemour, if we were to change the way package atoms were named, it  would break /craploads/ of the stuff already available

[gentoo-user] automake fails when emerging

2006-11-03 Thread Cosmin Rentea
Hi, I'm having a problem with automake while emerging several packages. For instance: * Running eautoreconf in '/var/tmp/portage/mono-1.1.13.8.1/work/mono-1.1.13.8.1/libgc' ... * Running aclocal ... [ ok ] * Running libtoolize --copy --force --automake

[gentoo-user] Inconsistency in portage automake package versioning

2014-11-17 Thread Gevisz
In today's system update I was advised to update sys-devel/automake from version 1.11.6 to version 1.11.6-r1. However, just after the update the system reported that sys-devel/automake has version 1.13.4. Is it only me who think that something is wrong here? The commands and their output

RE: [gentoo-user] emerge gnome looking for automake-1.7

2005-05-01 Thread Richard Watson
did you try to use only emerge automake Hi - Yes I did. Afterwards # ls /usr/bin/automak* /usr/bin/automake /usr/bin/automake-1.9 If I then rerun # emerge gtk+ I get the same error. It seems I must have automake-1.7 to continue. I'm really stuck at the moment so any help would be really

Re: [gentoo-user] emerge gnome looking for automake-1.7

2005-05-02 Thread Robert G. Hays
BOFH? Please? Probably need to knoe this one, too, methinks Thanks, rgh. Scott Taylor wrote: On Mon, 2005-05-02 at 01:15 +1000, Richard Watson wrote: emerge sys-dev/automake-1.7 Calculating dependencies !!! Problem in sys-dev/automake-1.7 dependencies. !!! Specific key requires an operator

Re: [gentoo-user] installation failure (libgpg-error-1.0-r1 failed during emerge --emptytree)

2005-06-16 Thread Allan Gottlieb
dependencies ...done! [ebuild N] dev-libs/glib-1.2.10-r5 -debug -hardened 411 kB [ebuild N] sys-apps/miscfiles-1.4.2 -minimal 1,489 kB [ebuild N] sys-libs/cracklib-2.7-r11 -debug -minimal +pam 20 kB [ebuild N] sys-devel/automake-1.5 514 kB [ebuild N] sys-devel/automake

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Rafa Griman
Jackie !! On Thu, May 2, 2013 at 5:09 PM, Jackie jiangjun12...@gmail.com wrote: [...] My problem was similiar to Rafa's,though I was compiling dev-python/pygtk-2.24.0-r3.But I also got same autom4te aclcal error as Rafa.But I just masked automake-1.13.1 downgraded to automake-1.12.6

Re: [gentoo-user] How many automake?

2007-10-19 Thread Daniel Barkalow
On Fri, 19 Oct 2007, econti wrote: Scrolling my package db I found I have installed many automakes. Here is the list: drwxr-xr-x 2 root root 664 16 ott 10:36 automake-1.10 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.4_p6 drwxr-xr-x 2 root root 936 9 feb 2006 automake-1.5 drwxr

Re: [gentoo-user] Math symbols with emerge -C

2007-06-01 Thread Albert Hopkins
that this version (2.6.20-r5) is not installed, which would make sense if the answer to the above question is yes. e.g: $ epm -q automake automake-1.9.6-r2 automake-1.10 automake-1.7.9-r1 automake-1.8.5-r3 automake-1.5 automake-1.6.3

Re: [gentoo-user] emerge gnome looking for automake-1.7

2005-05-01 Thread Max revolt
did you try to use only emerge automake ?? Em Seg, 2005-05-02 às 01:15 +1000, Richard Watson escreveu: Hi - emerge gnome is now giving me the following error am-wrapper: /usr/bin/automake-1.7 is missing or not executable please try emerging the correct version I checked /usr/bin

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Alan McKinnon
On 02/05/2013 17:09, Jackie wrote: My problem was similiar to Rafa's,though I was compiling dev-python/pygtk-2.24.0-r3.But I also got same autom4te aclcal error as Rafa.But I just masked automake-1.13.1 downgraded to automake-1.12.6 and the compilation went through,then I unmasked automake

Re: [gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-06-12 Thread Enrico Weigelt
on both variants can use this virtual, just to get the || dep out there. What folders are you tallking about ? sys-devel/automake/automake-1.10.ebuild sys-devel/automake/automake-1.4_p6.ebuild sys-devel/automake/automake-1.5.ebuild sys-devel/automake/automake-1.6.3.ebuild sys-devel/automake

[gentoo-user] Re: Multiple versions of automake?

2010-03-10 Thread Nikos Chantziaras
On 03/10/2010 06:17 PM, walt wrote: On 03/10/2010 05:50 AM, Tanstaafl wrote: Hello, I currently have 3 versions of automake installed (1.7.9-r1, 1.9.6-r3, and 1.10.2). emerge -pvuDN world shows an update available for each one, but, my question is, do I need all 3 versions? 'equery depends

Re: [gentoo-user] automake 1.4

2011-03-19 Thread Neil Bothwick
On Sat, 19 Mar 2011 06:42:39 +0100, Kraus Philipp wrote: I would like to emerge a new automake version. At this time emerge shows the 1.11.1 version but I need the version 1.4. I have found a security information that the package is masked because a vulnerabily. I need only the 1.4

Re: [gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-06-09 Thread Kent Fredric
ebuild names would drive me nutty ( folder with 10 different package names for the same thing = wtf? ) What folders are you tallking about ? sys-devel/automake/automake-1.10.ebuild sys-devel/automake/automake-1.4_p6.ebuild sys-devel/automake/automake-1.5.ebuild sys-devel/automake/automake-1.6.3

[gentoo-user] Multiple versions of automake?

2010-03-10 Thread Tanstaafl
Hello, I currently have 3 versions of automake installed (1.7.9-r1, 1.9.6-r3, and 1.10.2). emerge -pvuDN world shows an update available for each one, but, my question is, do I need all 3 versions? 'equery depends automake' shows 44 packages, all depending on 1.10* or higher. So, can I safely

Re: [gentoo-user] Problems with aclocal

2013-05-01 Thread Alan McKinnon
have to unmask it ... which takes me back to step 1 ... Right now I have: # equery list autoconf * Searching for autoconf ... [IP-] [ ] sys-devel/autoconf-2.13:2.1 [IP-] [ ] sys-devel/autoconf-2.69:2.5 # equery list automake * Searching for automake ... [IP-] [ ] sys-devel

Re: [gentoo-user] Need drive space, what to delete?

2005-12-06 Thread Walter Dnes
--pretend --prune blindly tells you to delete all but one version of a package. That can be a *BD* idea. Here is part of its output on my system... x11-libs/gtk+ selected: 1.2.10-r11 protected: 2.6.10-r1 omitted: none sys-devel/automake selected: 1.5 1.6.3 1.7.9-r1 1.4_p6

[gentoo-user] emerge gnome looking for automake-1.7

2005-05-02 Thread Richard Watson
did you try to use only emerge automake Hi - Yes I did. Afterwards # ls /usr/bin/automak* /usr/bin/automake /usr/bin/automake-1.9 If I then rerun # emerge gtk+ I get the same error. It seems I must have automake-1.7 to continue. I'm really stuck at the moment so any help would be really

Re: [gentoo-user] gtk+-2.6.4 automake missing

2005-06-14 Thread Zac Medico
-bmp_reject_corrupt.patch ... [A [-7G [34;01m[ [32;01mok [34;01m ] [0m am-wrapper: /usr/bin/automake-1.7 is missing or not executable. Please try emerging the correct version of automake. Is /usr/bin/automake-1.7 there? emerge =automake-1.7* Zac -- gentoo-user@gentoo.org mailing

Ant: Re: [gentoo-user] gtk+-2.6.4 automake missing

2005-06-15 Thread stefan riha
[32;01m* [0m Applying gtk+-2.6-smoothscroll-r2.patch ... [A [-7G [34;01m[ [32;01mok [34;01m ] [0m [32;01m* [0m Applying gtk+-2.6.4-bmp_reject_corrupt.patch ... [A [-7G [34;01m[ [32;01mok [34;01m ] [0m am-wrapper: /usr/bin/automake-1.7 is missing or not executable

Re: [gentoo-user] Re: problem emerging gnome-base/gnome-vfs-2.16.3-r1

2007-07-04 Thread Stefán István
szerda 04 július 2007 17.18 dátummal Neil Bothwick ezt írta: On Wed, 4 Jul 2007 16:33:35 +0200, Stefán István wrote: * Include in your bugreport the contents of: * * /var/tmp/portage/gnome-base/gnome-vfs-2.16.3-r1/temp/automake-24490.out Like it says. -- Neil Bothwick

[gentoo-user] unable to merge courier-authlib-0.58

2007-01-13 Thread John covici
/courier-authlib-0.58/libltdl' ... * Requested autoconf 2.5 * Using autoconf (GNU Autoconf) 2.61 * Using autoheader (GNU Autoconf) 2.61 * Requested automake latest: 1.10 * Using automake (GNU automake) 1.10 * Using aclocal (GNU automake) 1.10 * Running aclocal ... [ ok ] * Running

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Rafa Griman
Yo Alan !! On Thu, May 2, 2013 at 5:15 PM, Alan McKinnon alan.mckin...@gmail.com wrote: On 02/05/2013 17:09, Jackie wrote: My problem was similiar to Rafa's,though I was compiling dev-python/pygtk-2.24.0-r3.But I also got same autom4te aclcal error as Rafa.But I just masked automake-1.13.1

Re: [gentoo-user] Inconsistency in portage automake package versioning

2014-11-17 Thread Alan McKinnon
On 17/11/2014 23:29, Gevisz wrote: In today's system update I was advised to update sys-devel/automake from version 1.11.6 to version 1.11.6-r1. However, just after the update the system reported that sys-devel/automake has version 1.13.4. Is it only me who think that something is wrong here

Re: [gentoo-user] Inconsistency in portage automake package versioning

2014-11-17 Thread Gevisz
On Mon, 17 Nov 2014 23:49:18 +0200 Alan McKinnon alan.mckin...@gmail.com wrote: On 17/11/2014 23:29, Gevisz wrote: In today's system update I was advised to update sys-devel/automake from version 1.11.6 to version 1.11.6-r1. However, just after the update the system reported that sys

Re: [gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-05-30 Thread Boyd Stephen Smith Jr.
On Wednesday 30 May 2007 21:23:00 Denis wrote: Why are there multiple versions of java-config, autoconf, and automake shown on my system? They are incompatible, slotted, and each slot is individually required (or was at some time). There could be other multi-version packages

[gentoo-user] Why autoconf?

2005-09-12 Thread Frank Schafer
. That's NOT the truth for building a package. Autoconf and automake provide tools to CREATE configure scripts. They are completely unnecessary to BUILD or RUN the packages. I've built a full featured LFS system some time ago without autoconf and automake installed at all. It is a good thing to have all

[gentoo-user] Re: Multiple versions of automake?

2010-03-10 Thread walt
On 03/10/2010 05:50 AM, Tanstaafl wrote: Hello, I currently have 3 versions of automake installed (1.7.9-r1, 1.9.6-r3, and 1.10.2). emerge -pvuDN world shows an update available for each one, but, my question is, do I need all 3 versions? 'equery depends automake' shows 44 packages, all

Re: [gentoo-user] Multiple versions of automake?

2010-03-10 Thread Neil Bothwick
On Wed, 10 Mar 2010 08:50:33 -0500, Tanstaafl wrote: I currently have 3 versions of automake installed (1.7.9-r1, 1.9.6-r3, and 1.10.2). emerge -pvuDN world shows an update available for each one, but, my question is, do I need all 3 versions? 'equery depends automake' shows 44 packages

Re: [gentoo-user] LightDM. Anybody succesfully using it?

2011-06-02 Thread Ignas Anikevicius
On 02/06/11 22:43, Andrés Becerra Sandoval wrote: It looks like a bug in the ebuild not demanding version requirements for automake. Could you try installing other automake versions, I have these in my system: 1.9.6-r3(1.9) 1.10.3(1.10) 1.11.1-r1(1.11) Actually another thing helped. I googled

Re: [gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Michael Orlitzky
reat historical reason to explicitly list the latest stable version of automake in the eclass and then add it to DEPEND, but today DEPEND="sys-devel/automake" would work just fine and wouldn't require a thousand packages to get revisions whenever a new automake is released. If any particula

[gentoo-user] problem emerging gnome-base/gnome-vfs-2.16.3-r1

2007-07-04 Thread Stefán István
Hello! I got the following error: * Failed Running automake ! * * Include in your bugreport the contents of: * * /var/tmp/portage/gnome-base/gnome-vfs-2.16.3-r1/temp/automake-24490.out !!! ERROR: gnome-base/gnome-vfs-2.16.3-r1 failed. Call stack: ebuild.sh, line 1615: Called

Re: [gentoo-user] Why autoconf?

2005-09-12 Thread Daniel Drake
Frank Schafer wrote: Why the hick are there so much versions of autoconf (in system)? Well, somewhere in the [Nasty bug..] thread someone (again) mentioned, that different packaged depend on different versions of autoconf. That's NOT the truth for building a package. Autoconf and automake

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Rafa Griman
with the following error: Failed Running aclocal ! Looking through the Forums I saw I've got to mask autoconf. So I added autoconf to: /etc/portage/package.mask That's what you get with the forums, aclocal isn't even part of autoconf, it is provided by automake-wrapper. I know

[gentoo-user] Re: Multiple versions of automake?

2010-03-10 Thread walt
On 03/10/2010 10:45 AM, Nikos Chantziaras wrote: On 03/10/2010 06:17 PM, walt wrote: A few packages actually specify an exact version of the autotools, but most just want a certain minimum version. Portage doesn't allow ebuilds to specify minimum versions or ranges for automake, only exact

Re: [gentoo-user] Problems with aclocal

2013-05-01 Thread Rafa Griman
there. Tried that too but still get the same error: Failed Running aclocal ! No matter what version I mask in: vim /etc/portage/package.mask/masked I get that same error. I have rebuilt automake and automake-wrapper too just in case. Have also run: revdep-rebuild emerge

Re: [gentoo-user] problem emerging gnome-base/gnome-vfs-2.16.3-r1 - SOLVED

2007-07-05 Thread Stefán István
szerda 04 július 2007 15.26 dátummal Stefán István ezt írta: Hello! I got the following error: * Failed Running automake ! * * Include in your bugreport the contents of: * * /var/tmp/portage/gnome-base/gnome-vfs-2.16.3-r1/temp/automake-24490.out !!! ERROR: gnome-base/gnome

Re: [gentoo-user] openldap-2.4.24 fails to compile

2012-02-20 Thread Joseph
On 02/21/12 07:47, Pandu Poluan wrote: On Feb 21, 2012 1:57 AM, Joseph [1]syscon...@gmail.com wrote: I have automake-1.9.6-r3 installed but emerging openldap fails, it seems to me it has something to do with this bug: [2]https://bugs.gentoo.org/show_bug.cgi?id=403261 I have

Re: [gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-06-07 Thread Bo Ørsted Andresen
On Thursday 07 June 2007 01:44:39 Enrico Weigelt wrote: Now... Why are there multiple versions of java-config, autoconf, and automake shown on my system? These are packages totally incompatible and so different packages under the same name. They're sometimes necessary, since certain

Re: [gentoo-user] Need drive space, what to delete?

2005-12-06 Thread Marc Morrisette
--pretend --emptytree xmms on my system wants (amongstother things)...[ebuildN] sys-devel/autoconf- 2.13[ebuildN] sys-devel/autoconf-2.59-r6[ebuildN] sys-devel/automake-1.5[ebuildN] sys-devel/automake-1.8.5-r3[ebuildN] sys-devel/automake-1.6.3[ebuildN] sys-devel/automake- 1.7.9-r1[ebuildN] sys-devel

[gentoo-user] gtk+-2.6.4 automake missing

2005-06-14 Thread stefan riha
[34;01m[ [32;01mok [34;01m ] [0m am-wrapper: /usr/bin/automake-1.7 is missing or not executable. Please try emerging the correct version of automake. !!! ERROR: x11-libs/gtk+-2.6.4-r1 failed. !!! Function src_unpack, Line 62, Exitcode 1 !!! (no error message) !!! If you need support, post

[gentoo-user] aclocal failing on all emerges

2010-02-27 Thread Harry Putnam
: emerge -v sys-devel/automake-wrapper (the package that has aclocal in it) Ran: lafilefixer --justfixit Reinstalled libtool But still everything fails when aclocal gets called. I tried switching to the newer compiler gcc-4.3.4... then tried to repeat

Re: [gentoo-user] Multiple versions of automake?

2010-03-10 Thread Alan McKinnon
On Wednesday 10 March 2010 15:50:33 Tanstaafl wrote: Hello, I currently have 3 versions of automake installed (1.7.9-r1, 1.9.6-r3, and 1.10.2). emerge -pvuDN world shows an update available for each one, but, my question is, do I need all 3 versions? Assuming you do not have those

Re: [gentoo-user] Problems with aclocal

2013-05-01 Thread Jackie
with the following error: Failed Running aclocal ! Looking through the Forums I saw I've got to mask autoconf. So I added autoconf to: /etc/portage/package.mask That's what you get with the forums, aclocal isn't even part of autoconf, it is provided by automake-wrapper. And now I get a whole

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Rafa Griman
On Thu, May 2, 2013 at 3:06 PM, Neil Bothwick n...@digimed.co.uk wrote: On Thu, 2 May 2013 13:59:07 +0200, Rafa Griman wrote: There have been issues with automake-1.13. I have seen a similar error on one package and worked around it with WANT_AUTOMAKE=1.12 emerge -1 cat/package Tried

[gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Nikos Chantziaras
)stable versions of automake are hard-coded in autotools.eclass, and they wind up in the dependency string of every ebuild that uses the eclass. It's stupid, we don't need to do it, and it breaks all of those packages for other PMS-compliant package managers (--changed-deps is portage-only). Sorry, we

[gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Nikos Chantziaras
On 26/02/18 17:59, Rich Freeman wrote: Can't you whitelist packages like automake so that they don't trigger rebuilds? Or at least provide a configurable whitelist (for make.conf) where we can add packages that don't trigger changed-deps rebuilds? There is no reason to rebuild anything just

Re: [gentoo-user] libusb build error

2005-12-11 Thread Rafael Fernández López
message attached. Anyone a clue where I can start searching for a solution? Wrong automake version? A missing variable? Thx best regards ce emerge libusb Calculating dependencies ...done! emerge (1 of 1) dev-libs/libusb-0.1.10a to / md5 files ;-) libusb-0.1.7-r1.ebuild md5

[gentoo-user] mt-daapd automake error

2012-01-10 Thread Kraus Philipp
=dbus gdbm introspection -autoipd -bookmarks -doc -gtk -gtk3 -howl-compat -ipv6 -mdnsresponder-compat -mono -python -qt4 -test -utils [ebuild N ] media-sound/mt-daapd-0.2.4.2 USE=avahi vorbis The avahi package breaks with: * Failed Running automake ! * * Include in your bugreport

Re: [gentoo-user] emerge openssl fails.

2007-10-29 Thread David Harel
Ralf Stephan wrote: What versions of autoconf and automake do you have? Had: autoconf: 2.13 and 2.61-r1 automake: 1.10, 1.9.6-r2, 1.8.5-r3, 1.7.9-r1, 1.6.3, 1.5 and 1.4_p6 I removed all old versions and re-emerged current stable versions (2.61-r1 and 1.10). No go. Was wrong with last log

Re: [gentoo-user] aclocal failing on all emerges

2010-03-01 Thread Alex Schuster
-4.3.4) since the first sync and update world. gcc-4.4.3 is also installed but I'm using 4.3.4 Today I ran: emerge -v sys-devel/automake-wrapper (the package that has aclocal in it) I'd try to emerge the other autotools stuff, too: emerge -a $( qlist

Re: [gentoo-user] Problems with aclocal

2013-05-01 Thread Alan McKinnon
/masked I get that same error. I have rebuilt automake and automake-wrapper too just in case. Have also run: revdep-rebuild emerge --depclean perl-cleaner --all python-updater I have also unmerged the previous versions of automake and left the latest, but portage

[gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Holger Hoffstätte
I > would guess portage is operating as expected. As the pastebin log says it's automake-1.16 for ~arch, and since automake is used everywhere.. -h

[gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-05-30 Thread Denis
. Now... Why are there multiple versions of java-config, autoconf, and automake shown on my system? There could be other multi-version packages... Is this normal for portage that is configured to autoclean? If so, I find it rather interesting that packages would depend on so many different

Re: [gentoo-user] problem emerging gnome-base/gnome-vfs-2.16.3-r1

2007-07-04 Thread Rumen Yotov
On (04/07/07 15:26) Stefán István wrote: Hello! I got the following error: * Failed Running automake ! * * Include in your bugreport the contents of: * * /var/tmp/portage/gnome-base/gnome-vfs-2.16.3-r1/temp/automake-24490.out !!! ERROR: gnome-base/gnome-vfs-2.16.3-r1

Re: [gentoo-user] problem emerging gnome-base/gnome-vfs-2.16.3-r1

2007-07-05 Thread Stefán István
csütörtök 05 július 2007 03.04 dátummal Rumen Yotov ezt írta: On (04/07/07 15:26) Stefán István wrote: Hello! I got the following error: * Failed Running automake ! * * Include in your bugreport the contents of: * * /var/tmp/portage/gnome-base/gnome-vfs-2.16.3-r1

[gentoo-user] Re: problem emerging gnome-base/gnome-vfs-2.16.3-r1 - SOLVED

2007-07-05 Thread Alexander Skwar
Stefán István [EMAIL PROTECTED] wrote: But I think that maybe it is a bug in the portage. This package (gnome-base/gnome-vfs-2.16.3-r1) should be dependent from automake-1.9.6-r2. If you think so, go to bugzilla and check, if that issue has been filed already. If not, go ahead and create

Re: [gentoo-user] automake fails when emerging

2006-11-03 Thread Bo Ørsted Andresen
On Friday 03 November 2006 23:39, Cosmin Rentea wrote: Could you please give me some advice on how to proceed ? I'd go to bugs.gentoo.org and file a bug... -- Bo Andresen pgpEhpmCFuAAo.pgp Description: PGP signature

Re: [gentoo-user] Problems with aclocal

2013-05-02 Thread Alan McKinnon
, it is provided by automake-wrapper. I know, that's why I posted in another mail the automake and automake-wrapper versions I've got installed. And now I get a whole bunch of errors saying autoconf is masked and I have to unmask it ... which takes me back to step 1 ... There have been issues

Re: [gentoo-user] Can't Emerge jbig2dec-0.11-r1

2014-04-06 Thread Mick
may want to remerge sys-devel/automake-wrapper as a first step? emerge -1aDv sys-devel/automake-wrapper Then try to emerge --update world. Oh my god. Thank you for your help. I have been struggling with this for a long time. I tried to reinstall so many other things that I thought

Re: [gentoo-user] Can't Emerge jbig2dec-0.11-r1

2014-04-06 Thread Willie Matthews
... [ !! ] * Failed Running aclocal ! == So you may want to remerge sys-devel/automake-wrapper as a first step? emerge -1aDv sys-devel/automake-wrapper Then try to emerge --update world. Oh my god. Thank you for your help. I have been struggling

Re: [gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Paul Colquhoun
On Tuesday, 27 February 2018 3:25:40 AM AEDT Rich Freeman wrote: > On Mon, Feb 26, 2018 at 11:16 AM, Nikos Chantziaras <rea...@gmail.com> wrote: > > On 26/02/18 17:59, Rich Freeman wrote: > >>> Can't you whitelist packages like automake so that they don't trigger

Re: [gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Rich Freeman
wanted to >>> remerge >>> 217 packages. Removing --changed-deps reduced that to one: >>> sys-devel/llvm. >>> >> >> You do need to reinstall those. >> >> The latest (un)stable versions of automake are hard-coded in >> autotools.eclass, a

Re: [gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Rich Freeman
On Mon, Feb 26, 2018 at 11:16 AM, Nikos Chantziaras <rea...@gmail.com> wrote: > On 26/02/18 17:59, Rich Freeman wrote: >>> >>> Can't you whitelist packages like automake so that they don't trigger >>> rebuilds? Or at least provide a configurable whitelist (for

Re: [gentoo-user] libusb build error

2005-12-11 Thread Christoph Eckert
... [ ok ] * Running libtoolize --copy --force --automake ... [ ok ] * Running aclocal ... [ ok ] * Running autoconf

[gentoo-user] Re: mt-daapd automake error

2012-01-13 Thread Philipp Kraus
Running automake ! * * Include in your bugreport the contents of: * * /var/tmp/portage/net-dns/avahi-0.6.30-r2/temp/automake.out * ERROR: net-dns/avahi-0.6.30-r2 failed (prepare phase): * Failed Running automake ! * * Call stack: * ebuild.sh, line 85: Called src_prepare

Re: [gentoo-user] lanmap ebuild

2008-11-30 Thread Ricardo Saffi Marques
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Justin wrote: Shouldn't sound that harsh, sorry. Don't worry, no problem! That's the problem with written text. Does not carry how the sentence would sound if spoken! :-) It looks like that it has a automake style installer included, so just

[gentoo-user] Dependency problems with Stage 1 install

2005-05-25 Thread Ezequiel Tolnay
because it requires automake. Automake on turn requires perl. Perl required libperl. Finally I installed libperl, and attempted to install perl now. It needs libgdbm. So I installed it. So far, this is where I've come now, it is currently attempting to install perl again. I'm making this install

[gentoo-user] portage bugs?

2005-10-06 Thread Erwin Lang
the package automake (which contains aclocal) I tried `emerge -ep system' an the two packages (autoconf and automake) are mentioned in the list of packages which portage will install. But it seems that portage installs them to late. 2) after `emerge -e system' I tried to install the following packages

Re: [gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-05-30 Thread Ric de France
a prune with a deep world emerge, ie.: # emerge -DNuva world It'll make sure if you prune something like automake that isn't back / forth - compatible will be restored to your system. HTH, Ric -- Ric de France Ph: +61412945554 (international) or 0412945554 (Australia) == Do you, uh... Gentoo

Re: [gentoo-user] why multiple versions of java-config, automake, and autoconf?

2007-06-08 Thread Kent Fredric
nutty ( folder with 10 different package names for the same thing = wtf? ) Just replying to myself here. ] sys-devel/automake Available versions: (1.4) 1.4_p6 (1.5) 1.5 (1.6) 1.6.3 (1.7) 1.7.9-r1 (1.8) 1.8.5-r3 (1.9) 1.9.6-r2

Re: [gentoo-user] Why autoconf?

2005-09-12 Thread Dave Nebinger
of the emerge process applies many patches to the original package. Sometimes these patches are applied to the configure.in and makefile.in scripts. When changes like this are made, autoconf automake are called to rebuild the configure script before it is executed. And because the original

Re: [gentoo-user] libsamplerate fails to compile

2009-12-13 Thread Alan McKinnon
in the libsamplerate ebuild. My following guess is that the dev has automake:1.7 installed and hasn't seen the dependency. Do this: emerge -1 automake:1.7 emerge libsamplerate If it then succeeds, file a bug -- alan dot mckinnon at gmail dot com

Re: [gentoo-user] Re: amanda run and build failure

2010-08-08 Thread John Blinka
just-created ...' message has something to do with an erroneous attempt to install the same file twice, possibly related to behavior in specific versions of automake. That may explain the fact that I was once able to install this version of amanda, but can't now after subsequent upgrades in automake

Re: [gentoo-user] LightDM. Anybody succesfully using it?

2011-06-02 Thread Andrés Becerra Sandoval
://pastebin.com/KXvTBE5a Thanks a lot for help, Ignas A. It looks like a bug in the ebuild not demanding version requirements for automake. Could you try installing other automake versions, I have these in my system: 1.9.6-r3(1.9) 1.10.3(1.10) 1.11.1-r1(1.11) --   Andrés Becerra Sandoval

Re: [gentoo-user] Problems with aclocal

2013-05-01 Thread Neil Bothwick
the Forums I saw I've got to mask autoconf. So I added autoconf to: /etc/portage/package.mask That's what you get with the forums, aclocal isn't even part of autoconf, it is provided by automake-wrapper. And now I get a whole bunch of errors saying autoconf is masked and I have to unmask

Re: [gentoo-user] Can't Emerge jbig2dec-0.11-r1

2014-04-06 Thread Mick
: == * Running aclocal ... [ !! ] * Failed Running aclocal ! == So you may want to remerge sys-devel/automake-wrapper

[gentoo-user] Re: Symlinked directories and rsync

2017-08-19 Thread Ian Zimmerman
misc/lndir package on gentoo 2. on a GNU system, cp -rsT 3. symlink-tree script in older releases of GNU automake (on my gentoo system, in the sys-devel/automake-1.11.6-r1 package) -- Please don't Cc: me privately on mailing lists and Usenet, if you also post the followup to the list or newsgroup. Do obvious transformation on domain to reply privately _only_ on Usenet.

[gentoo-user] Re: Symlinked directories and rsync

2017-08-25 Thread Ian Zimmerman
c/lndir package on gentoo > > 2. on a GNU system, cp -rsT > > 3. symlink-tree script in older releases of GNU automake (on my gentoo > system, in the sys-devel/automake-1.11.6-r1 package) After I wrote that, I had the nagging thought that none of those in fact worked just as I w

Re: [gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread tuxic
; > >> > > >> This is not OK. What the hell? This is just plain broken. > > > > > > Someone probably changed a dependency in a commonly used eclass. I > > > would guess portage is operating as expected. > > > > As the pastebin log say

Re: [gentoo-user] Re: Is --changed-deps going to be *that* useless?

2018-02-26 Thread Peter Humphrey
> > > Someone probably changed a dependency in a commonly used eclass. I > > would guess portage is operating as expected. > > As the pastebin log says it's automake-1.16 for ~arch, and > since automake is used everywhere.. Well, I'm on amd64, not ~amd64, and this morning

  1   2   3   4   5   6   7   8   9   10   >