Re: [gentoo-user] kvm and intel E5450 processor

2009-09-25 Thread Daniel Troeder
directory `/usr/src/linux-2.6.31-gentoo' LD /dev/shm/portage/app-emulation/kvm-kmod-88-r1/work/kvm-kmod-devel-88/x86/built-in.o CC [M] /dev/shm/portage/app-emulation/kvm-kmod-88-r1/work/kvm-kmod-devel-88/x86/svm.o CC [M] /dev/shm/portage/app-emulation/kvm-kmod-88-r1/work/kvm

Re: [gentoo-user] kvm and intel E5450 processor

2009-09-24 Thread James Erickson
/portage/app-emulation/kvm-kmod-88-r1/work/kvm-kmod-devel-88/x86/built-in.o CC [M] /dev/shm/portage/app-emulation/kvm-kmod-88-r1/work/kvm-kmod-devel-88/x86/svm.o CC [M] /dev/shm/portage/app-emulation/kvm-kmod-88-r1/work/kvm-kmod-devel-88/x86/vmx.o CC [M] /dev/shm/portage/app-emulation/kvm-kmod

Re: [gentoo-user] list of kernel modules

2012-04-06 Thread Todd Goodman
* Mark Knecht markkne...@gmail.com [120406 11:40]: [..] To me it looks safe to emerge -C kmod and then emerge module-init-tools if you want to go that way. I'd do an equery files kmod and carefully study what you're getting with that package, or else push a bug request up to that package

Re: [gentoo-user] portage insists in pulling in sys-apps/kmod

2013-03-24 Thread Walter Dnes
On Sat, Mar 23, 2013 at 03:06:05PM -0400, Mike Gilbert wrote On Sat, Mar 23, 2013 at 1:42 PM, Dan Johansson dan.johans...@dmj.nu wrote: Hello, Some of my servers are running with a kernel without module-support. On these servers something has started to pull in sys-apps/kmod, which when

[gentoo-user] udev-197 USE=kmod

2013-01-26 Thread Florian Philipp
Hi list! Quick question: If I deactivate the kmod use flag in udev and keep sys-apps/module-init-tools, does udev still load modules or is kmod a required flag for that? Thanks in advance! Florian Philipp signature.asc Description: OpenPGP digital signature

Re: [gentoo-user] portage insists in pulling in sys-apps/kmod

2013-03-23 Thread Felix Kuperjans
Mike Gilbert: On Sat, Mar 23, 2013 at 1:42 PM, Dan Johansson dan.johans...@dmj.nu wrote: Hello, Some of my servers are running with a kernel without module-support. On these servers something has started to pull in sys-apps/kmod, which when compiled complains about missing modules-support

Re: [gentoo-user] portage insists in pulling in sys-apps/kmod

2013-03-24 Thread Mike Gilbert
in sys-apps/kmod, which when compiled complains about missing modules-support in the kernel (as it should). Doing an equery d sys-apps/kmod I can see that the following two packages depends on sy-apps/kmod: sys-fs/udev-197-r8 (kmod ? =sys-apps/kmod-12) virtual/modutils-0 (sys-apps/kmod

[gentoo-user] kmod module-init-tools + udev-171-r10

2013-03-27 Thread Tanstaafl
Hi all, Just a question... Can I replace module-init-tools with kmod and stay with udev-171-r10 for the time being? Asked another way - is kmod fully supported by older releases of udev like 171-r10? Thanks

Re: [gentoo-user] list of kernel modules

2012-04-06 Thread Mark Knecht
On Fri, Apr 6, 2012 at 9:03 AM, Todd Goodman t...@bonedaddy.net wrote: * Mark Knecht markkne...@gmail.com [120406 11:40]: [..] To me it looks safe to emerge -C kmod and then emerge module-init-tools if you want to go that way. I'd do an equery files kmod and carefully study what you're

Re: [gentoo-user] I guess it is time to update udev from 171-r10 to 197-r8...

2013-03-17 Thread Neil Bothwick
On Sun, 17 Mar 2013 13:46:39 -0400, Tanstaafl wrote: Also, should I manually fix the blockers: [blocks B ] sys-apps/module-init-tools (sys-apps/module-init-tools is blocking sys-apps/kmod-12-r1) [blocks B ] sys-apps/kmod (sys-apps/kmod is blocking sys-apps/module-init-tools

[gentoo-user] portage insists in pulling in sys-apps/kmod

2013-03-23 Thread Dan Johansson
Hello, Some of my servers are running with a kernel without module-support. On these servers something has started to pull in sys-apps/kmod, which when compiled complains about missing modules-support in the kernel (as it should). Doing an equery d sys-apps/kmod I can see that the following two

Re: [gentoo-user] portage insists in pulling in sys-apps/kmod

2013-03-23 Thread Mike Gilbert
On Sat, Mar 23, 2013 at 1:42 PM, Dan Johansson dan.johans...@dmj.nu wrote: Hello, Some of my servers are running with a kernel without module-support. On these servers something has started to pull in sys-apps/kmod, which when compiled complains about missing modules-support in the kernel

Re: [gentoo-user] udev-197 USE=kmod

2013-01-26 Thread Canek Peláez Valdés
On Sat, Jan 26, 2013 at 6:15 PM, Florian Philipp li...@binarywings.net wrote: Hi list! Quick question: If I deactivate the kmod use flag in udev and keep sys-apps/module-init-tools, does udev still load modules or is kmod a required flag for that? I'm not 100% sure, but I don't think so

Re: [gentoo-user] kmod requires modules in kernel??

2013-04-03 Thread Alan McKinnon
On 03/04/2013 14:54, Tanstaafl wrote: Ok, I am prepping for the udev update this weekend, getting everything updated that doesn't pull in the udev updates. First thing I did was to eliminate the module-init-toolskmod Blocker: emerge -C module-init-tools %% emerge kmod and noted

Re: [gentoo-user] portage insists in pulling in sys-apps/kmod

2013-03-24 Thread Dan Johansson
On Saturday 23 March 2013 15.06:05 Mike Gilbert wrote: On Sat, Mar 23, 2013 at 1:42 PM, Dan Johansson dan.johans...@dmj.nu wrote: Hello, Some of my servers are running with a kernel without module-support. On these servers something has started to pull in sys-apps/kmod, which when

Re: [gentoo-user] kmod requires modules in kernel??

2013-04-03 Thread Dan Johansson
: emerge -C module-init-tools %% emerge kmod and noted the following warnings/errors: Checking for suitable kernel configuration options... ERROR: setup CONFIG_MODULES: is not set when it should be. CONFIG_MODULE_UNLOAD: is not set when it should be. This is a server

Re: [gentoo-user] Do I require static nodes?

2013-11-30 Thread Samuli Suominen
On 27/11/13 12:22, Daniel Pielmeier wrote: 2013/11/27 Chris Stankevitz chrisstankev...@gmail.com mailto:chrisstankev...@gmail.com Hello, Portage recently told me this: * You need to add kmod-static-nodes to the sysinit runlevel for * kernel modules to have required

Re: [gentoo-user] kmod module-init-tools + udev-171-r10

2013-03-27 Thread Canek Peláez Valdés
On Wed, Mar 27, 2013 at 11:17 AM, Tanstaafl tansta...@libertytrek.org wrote: Hi all, Just a question... Can I replace module-init-tools with kmod and stay with udev-171-r10 for the time being? Asked another way - is kmod fully supported by older releases of udev like 171-r10? If you

[gentoo-user] Do I require static nodes?

2013-11-26 Thread Chris Stankevitz
Hello, Portage recently told me this: * You need to add kmod-static-nodes to the sysinit runlevel for * kernel modules to have required static nodes! * Run this command: * rc-update add kmod-static-nodes sysinit Will you please help me parse this statement? Interpretation A: * You need

Re: [gentoo-user] Do I require static nodes?

2013-11-27 Thread Daniel Pielmeier
2013/11/27 Chris Stankevitz chrisstankev...@gmail.com Hello, Portage recently told me this: * You need to add kmod-static-nodes to the sysinit runlevel for * kernel modules to have required static nodes! * Run this command: * rc-update add kmod-static-nodes sysinit Will you please

[gentoo-user] udev-181 and kmod vs module-init-tools

2012-03-19 Thread Paul Hartman
udev-181 merge is blocked because : [blocks B ] sys-apps/module-init-tools (sys-apps/module-init-tools is blocking sys-apps/kmod-7) [blocks B ] sys-apps/kmod (sys-apps/kmod is blocking sys-apps/module-init-tools-3.16-r1) * Error: The above package list contains packages which cannot

Re: [gentoo-user] list of kernel modules

2012-04-06 Thread Todd Goodman
* Mark Knecht markkne...@gmail.com [120406 12:16]: On Fri, Apr 6, 2012 at 9:03 AM, Todd Goodman t...@bonedaddy.net wrote: * Mark Knecht markkne...@gmail.com [120406 11:40]: [..] To me it looks safe to emerge -C kmod and then emerge module-init-tools if you want to go that way. I'd do

Re: [gentoo-user] I guess it is time to update udev from 171-r10 to 197-r8...

2013-03-17 Thread Tanstaafl
On 2013-03-17 2:17 PM, Neil Bothwick n...@digimed.co.uk wrote: On Sun, 17 Mar 2013 13:46:39 -0400, Tanstaafl wrote: Also, should I manually fix the blockers: [blocks B ] sys-apps/module-init-tools (sys-apps/module-init-tools is blocking sys-apps/kmod-12-r1) [blocks B ] sys-apps

[gentoo-user] Failure of zfs-kmod with 3.13.* kernel

2014-02-08 Thread Scott Ellis
When trying to build zfs-kmod against a a 3.13.[0|1|2] kernel, spl works fine, but zfs fails. It looks like the issue is that the configure script isn't doing quite the right check for bdi_setup_and_register, so HAVE_BDI_SETUP_AND_REGISTER doesn't get defined, and then there's a mismatch

Re: [gentoo-user] udev-197 USE=kmod

2013-01-27 Thread Canek Peláez Valdés
On Sun, Jan 27, 2013 at 4:30 AM, Florian Philipp li...@binarywings.net wrote: Am 27.01.2013 03:24, schrieb Canek Peláez Valdés: On Sat, Jan 26, 2013 at 6:15 PM, Florian Philipp li...@binarywings.net wrote: Hi list! Quick question: If I deactivate the kmod use flag in udev and keep sys-apps

Re: [gentoo-user] udev-197 USE=kmod

2013-01-27 Thread Florian Philipp
deactivate the kmod use flag in udev and keep sys-apps/module-init-tools, does udev still load modules or is kmod a required flag for that? I'm not 100% sure, but I don't think so. The git repository has not a single instance of the strings modprobe or insmod, apparently the only way to load

Re: [gentoo-user] Re: udev-197-r3 update problem...

2013-01-20 Thread Canek Peláez Valdés
=-static-libs 1,405 kB [ebuild N ] dev-libs/libxslt-1.1.28 USE=crypt -debug -python -static-libs 3,356 kB [ebuild N ] sys-apps/kmod-12-r1 USE=tools zlib -debug -doc -lzma -static-libs 1,246 kB [ebuild U ] sys-fs/udev-197-r3 [171-r9] USE=acl%* kmod%* openrc%* -doc% -gudev

[gentoo-user] Re: udev-197-r3 update problem...

2013-01-20 Thread »Q«
USE=crypt -debug -python -static-libs 3,356 kB [ebuild N ] sys-apps/kmod-12-r1 USE=tools zlib -debug -doc -lzma -static-libs 1,246 kB [ebuild U ] sys-fs/udev-197-r3 [171-r9] USE=acl%* kmod%* openrc%* -doc% -gudev -hwdb -introspection -keymap (-selinux) -static-libs

Re: [gentoo-user] udev-197 USE=kmod

2013-01-27 Thread Florian Philipp
Am 27.01.2013 03:24, schrieb Canek Peláez Valdés: On Sat, Jan 26, 2013 at 6:15 PM, Florian Philipp li...@binarywings.net wrote: Hi list! Quick question: If I deactivate the kmod use flag in udev and keep sys-apps/module-init-tools, does udev still load modules or is kmod a required flag

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Jarry
On 24-Mar-13 18:39, Canek Peláez Valdés wrote: BTW why should kmod depend on kernel-sources? Or even better, why should be kmod installed, if I have static (non-modular) kernel? Because your use case is not standard. The normal situation for users with kmod installed (and you have already

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Mike Gilbert
On Sun, Mar 24, 2013 at 2:57 PM, Jarry mr.ja...@gmail.com wrote: On 24-Mar-13 18:39, Canek Peláez Valdés wrote: BTW why should kmod depend on kernel-sources? Or even better, why should be kmod installed, if I have static (non-modular) kernel? Because your use case is not standard

Re: [gentoo-user] Re: Beta test Gentoo with mdev instead of udev; version 4

2012-02-28 Thread Walter Dnes
. There is talk on the gentoo-dev list that mod-utils will be replaced by virtual/mod-utils which will default to kmod (required to build udev-181). Note that mod-utils and kmod are mutually exclusive. That should be taken care of in the ebuilds, but I'll monitor the situation. I may have to modify the setup

Re: [gentoo-user] Is 'MAKEOPTS=--jobs --load-average=5' silly?

2013-03-25 Thread Neil Bothwick
, then zfs-kmod. But that's because zfs-kmod requires a complete built spl. Interesting, I have --jobs and portage doesn't try t build spl and zfs-kmod in parallel, it always completes spl first. -- Neil Bothwick If the cops arrest a mime, do they tell her she has the right to remain silent

Re: [gentoo-user] digikam + systemd

2013-09-06 Thread Philip Webb
-apps/systemd-206-r3::gentoo (Change USE: +kmod) virtual/udev-206-r2::gentoo (Change USE: -kmod) Adding -kmod to the USE list gets 54 pkgs, incl systemd , which I've masked in package.mask with sys-fs/systemd. -- ,, SUPPORT

Re: [gentoo-user] cannot compile kvm

2009-12-24 Thread Alan McKinnon
to emerge kvm-kmod, it is said to have been masked, so i unmasked it. but while compiling, kvm-kmod failed with an error message like: cannot file arch/x86/kvm/trace.h file Masked packages are usually masked for a reason. I would check on google and then the gentoo bugzilla and see

Re: [gentoo-user] Re: Kernel 3.5 and nvidia

2012-07-25 Thread Stefan G. Weichinger
Am 25.07.2012 23:59, schrieb Nikos Chantziaras: Make sure sys-apps/kmod is installed. It is and was. Thanks, Stefan

[gentoo-user] module-init-tools - can not download it

2012-12-28 Thread Joseph
Where is module-init-tools-3.16-r2? My system wants to upgrade it and it is mark stable but I can not download it at all. I know kmod is going to replace it eventually but it is not mark stable yet. -- Joseph

[gentoo-user] Re: udev-197-r3 update problem...

2013-01-20 Thread »Q«
On Sun, 20 Jan 2013 20:01:33 -0600 Canek Peláez Valdés can...@gmail.com wrote: [snip explanation of kmod module-init-tools] Hope it helps. Yes, very much -- thank you.

Re: [gentoo-user] Re: module-init-tools : masked opponent : SOLVED

2013-03-11 Thread Philip Webb
130309 Philip Webb wrote: 130309 »Q« wrote: 130309 Philip Webb purs...@ca.inter.net wrote: Doing my usual Saturday system update, I saw a prominent msg telling me that 'module-init-tools' has been masked to use 'kmod' or 'modutils' -- the msgs vary -- to replace it. When I did so (both

[gentoo-user] I guess it is time to update udev from 171-r10 to 197-r8...

2013-03-17 Thread Tanstaafl
managed /usr partition, is it now safe to comment out my udev masks and update udev, with a reasonable expectation that doing so won't break my boot ability? Also, should I manually fix the blockers: [blocks B ] sys-apps/module-init-tools (sys-apps/module-init-tools is blocking sys-apps/kmod

Re: [gentoo-user] Moving from old udev to eudev

2013-08-10 Thread Tanstaafl
Hmmm... Do I need (I don't think so) the kmod USE flag set for eudev and virtual/udev? I have kernel modules disabled on this system.

Re: [gentoo-user] udev-197-r3 update problem...

2013-01-19 Thread Canek Peláez Valdés
[ebuild N ] dev-libs/libgpg-error-1.10 USE=nls -common-lisp -static-libs 429 kB [ebuild N ] dev-libs/libgcrypt-1.5.0-r2 USE=-static-libs 1,405 kB [ebuild N ] dev-libs/libxslt-1.1.28 USE=crypt -debug -python -static-libs 3,356 kB [ebuild N ] sys-apps/kmod-12-r1 USE=tools

[gentoo-user] cannot compile kvm

2009-12-23 Thread Xi Shen
hi, i cannot access my computer now, so i can only tell you what i remember. i am using gentoo amd64, and the portage is updated. the kernel have kvm modules compiled. when i was trying to emerge kvm-kmod, it is said to have been masked, so i unmasked it. but while compiling, kvm-kmod failed

Re: [gentoo-user] udev-181 and kmod vs module-init-tools

2012-03-19 Thread Hinnerk van Bruinehsen
regards, Hinnerk On 19.03.2012 16:47, Paul Hartman wrote: udev-181 merge is blocked because : [blocks B ] sys-apps/module-init-tools (sys-apps/module-init-tools is blocking sys-apps/kmod-7) [blocks B ] sys-apps/kmod (sys-apps/kmod is blocking sys-apps/module-init-tools-3.16-r1

Re: [gentoo-user] [SOLVED] make modules_install error; modules not recognized as ELF files

2013-03-15 Thread Neil Bothwick
On Fri, 15 Mar 2013 03:37:05 -0400, Walter Dnes wrote: For anybody who's reading this thread... you *MUST* use the tools flag with kmod in order to get basic stuff like a man page, lsmod, etc. The tools flag is enabled by default in the kmod ebuild, so only those who choose to deliberately

Re: [gentoo-user] Re: module-init-tools : masked opponent

2013-03-09 Thread Philip Webb
130309 »Q« wrote: 130309 Philip Webb purs...@ca.inter.net wrote: Doing my usual Saturday system update, I saw a prominent msg telling me that 'module-init-tools' has been masked to use 'kmod' or 'modutils' -- the msgs vary -- to replace it. When I did so (both), Nvidia wouldn't start, even

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Canek Peláez Valdés
-0 0 kB [ebuild R] sys-apps/kmod-12-r1 USE=tools zlib -debug -doc -lzma -static-libs KERNEL=(linux%*) 0 kB Why in the heavens name should be gentoo-sources pulled in as dependency of whatever? As a dependency of virtual-sources, which is probably pulled in by kmod. Adding --tree

[gentoo-user] Re: I guess it is time to update udev from 171-r10 to 197-r8...

2013-03-18 Thread nunojsilva
On 2013-03-17, Tanstaafl wrote: On 2013-03-17 2:17 PM, Neil Bothwick n...@digimed.co.uk wrote: On Sun, 17 Mar 2013 13:46:39 -0400, Tanstaafl wrote: Also, should I manually fix the blockers: [blocks B ] sys-apps/module-init-tools (sys-apps/module-init-tools is blocking sys-apps/kmod-12

[gentoo-user] ZFS wiki confusion

2013-03-31 Thread Douglas J Hunley
/var/tmp/portage/sys-kernel/spl-/work/spl- ./copy-builtin /usr/src/linux) root # (cd /var/tmp/portage/sys-fs/zfs-kmod-/work/zfs-kmod-/ ./copy-builtin /usr/src/linux) After this, you just need to edit the kernel config to enable CONFIG_SPL and CONFIG_ZFS and emerge the zfs binaries

[gentoo-user] udev upgrade 208 212-r1, openrc USE flag changed to disabled?

2014-06-14 Thread Tanstaafl
Is this right? # eix udev ... [U] sys-fs/udev Available versions: 208-r1^t 212-r1^t ~213^t **^t {acl doc +firmware-loader gudev introspection +kmod selinux static-libs ABI_MIPS=n32 n64 o32 ABI_X86=32 64 x32} Installed versions: 208^t{tbz2}(03:30:13 PM 12/08/2013)(acl

[gentoo-user] Re: module-init-tools : masked opponent

2013-03-09 Thread »Q«
On Sat, 9 Mar 2013 08:07:45 -0500 Philip Webb purs...@ca.inter.net wrote: Doing my usual Saturday system update, I saw a prominent msg telling me that 'module-init-tools' has been masked to use 'kmod' or 'modutils' -- the msgs vary -- to replace it. When I did so (both), Nvidia wouldn't

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Felix Kuperjans
a cron daemon or a system logger for that reason, so they won't include kernel sources. AFAICT stage3 archives include everything of @system. virtual/dev-manager usually pulls in udev, which might pull in kmod (depending on USE flags) and virtual/modutils is part of system, which by default uses

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Neil Bothwick
everything of @system. They don't. That's why you have to satisfy some virtuals manually at install time. virtual/dev-manager usually pulls in udev, which might pull in kmod (depending on USE flags) and virtual/modutils is part of system, which by default uses kmod. So kmod is part of system

Re: [gentoo-user] Is 'MAKEOPTS=--jobs --load-average=5' silly?

2013-03-26 Thread Neil Bothwick
On Tue, 26 Mar 2013 21:58:29 +0100, Michael Hampicke wrote: I havent't had any failed builds that were related to the --jobs option. The only exception is when rebuilding my kernel modules. I have to build spl first, then zfs-kmod. But that's because zfs-kmod requires a complete built

Re: [gentoo-user] Is 'MAKEOPTS=--jobs --load-average=5' silly?

2013-03-27 Thread Michael Hampicke
Am 26.03.2013 22:40, schrieb Neil Bothwick: On Tue, 26 Mar 2013 21:58:29 +0100, Michael Hampicke wrote: I havent't had any failed builds that were related to the --jobs option. The only exception is when rebuilding my kernel modules. I have to build spl first, then zfs-kmod. But that's

Re: [gentoo-user] digikam + systemd

2013-09-06 Thread Canek Peláez Valdés
- pykde4-4.11.0 - USE=script. (4) udisks - USE=gudev. (5) then I see : sys-apps/systemd-206-r3::gentoo (Change USE: +kmod) virtual/udev-206-r2::gentoo (Change USE: -kmod) Adding -kmod to the USE list gets 54 pkgs, incl systemd , which I've masked in package.mask with sys-fs/systemd

Re: [gentoo-user] digikam + systemd

2013-09-06 Thread Alan McKinnon
) udisks - USE=gudev. (5) then I see : sys-apps/systemd-206-r3::gentoo (Change USE: +kmod) virtual/udev-206-r2::gentoo (Change USE: -kmod) Adding -kmod to the USE list gets 54 pkgs, incl systemd , which I've masked in package.mask with sys-fs/systemd. It gets more complex

Re: [gentoo-user] modules.devname not found...

2014-07-29 Thread Jarry
What does it mean and how can I get rid of it? By creating the missing file :) Right, and if he is using monolitic kernel with CONFIG_MODULES=n in kernel /usr/src/linux/.config, with no modules at all, then he should remove 'kmod-static-nodes' init script from the runlevels to silence

Re: [gentoo-user] cannot compile kvm

2009-12-24 Thread Marcus Wanner
On 12/23/2009 8:14 PM, Xi Shen wrote: hi, i cannot access my computer now, so i can only tell you what i remember. i am using gentoo amd64, and the portage is updated. the kernel have kvm modules compiled. when i was trying to emerge kvm-kmod, it is said to have been masked, so i unmasked

[gentoo-user] udev-197-r3 update problem...

2013-01-19 Thread Jarry
429 kB [ebuild N ] dev-libs/libgcrypt-1.5.0-r2 USE=-static-libs 1,405 kB [ebuild N ] dev-libs/libxslt-1.1.28 USE=crypt -debug -python -static-libs 3,356 kB [ebuild N ] sys-apps/kmod-12-r1 USE=tools zlib -debug -doc -lzma -static-libs 1,246 kB [ebuild U ] sys-fs/udev-197-r3

[gentoo-user] kmod requires modules in kernel??

2013-04-03 Thread Tanstaafl
Ok, I am prepping for the udev update this weekend, getting everything updated that doesn't pull in the udev updates. First thing I did was to eliminate the module-init-toolskmod Blocker: emerge -C module-init-tools %% emerge kmod and noted the following warnings/errors: Checking

Re: [gentoo-user] kmod requires modules in kernel??

2013-04-03 Thread Mike Gilbert
%% emerge kmod and noted the following warnings/errors: Checking for suitable kernel configuration options... ERROR: setup CONFIG_MODULES:is not set when it should be. CONFIG_MODULE_UNLOAD: is not set when it should be. This is a server, and I do not WANT loadable modules

Re: [gentoo-user] Failure of zfs-kmod with 3.13.* kernel

2014-02-08 Thread Neil Bothwick
On Sat, 8 Feb 2014 10:07:31 -0800, Scott Ellis wrote: When trying to build zfs-kmod against a a 3.13.[0|1|2] kernel, spl works fine, but zfs fails. It looks like the issue is that the configure script isn't doing quite the right check for bdi_setup_and_register, so

Re: [gentoo-user] Failure of zfs-kmod with 3.13.* kernel

2014-02-09 Thread Scott Ellis
Ah, I missed that bug report. Thanks for the pointer (and the workaround). On Sat, Feb 8, 2014 at 11:50 AM, Neil Bothwick n...@digimed.co.uk wrote: On Sat, 8 Feb 2014 10:07:31 -0800, Scott Ellis wrote: When trying to build zfs-kmod against a a 3.13.[0|1|2] kernel, spl works fine, but zfs

Re: [gentoo-user] cannot compile kvm

2009-12-24 Thread Xi Shen
, and the portage is updated. the kernel have kvm modules compiled. when i was trying to emerge kvm-kmod, it is said to have been masked, so i unmasked it. but while compiling, kvm-kmod failed with an error message like: cannot file arch/x86/kvm/trace.h file Masked packages are usually masked

Re: [gentoo-user] list of kernel modules

2012-04-06 Thread Mark Knecht
On Fri, Apr 6, 2012 at 9:21 AM, Todd Goodman t...@bonedaddy.net wrote: SNIP So it looks like just udev-182-r2 depends upon it. Sorry for the misinformation. Todd Not a problem. So this problem is really just for folks running ~amd64 as all this new udev stuff as well as kmod aren't marked

Re: [gentoo-user] Re: Kernel 3.5 and nvidia (SOLVED)

2012-07-25 Thread Stefan G. Weichinger
Am 26.07.2012 00:15, schrieb Stefan G. Weichinger: Am 25.07.2012 23:59, schrieb Nikos Chantziaras: Make sure sys-apps/kmod is installed. It is and was. my fault ... I compiled modules for 3.5.0-gentoo, forgot about updating GRUB2-config, and booted 3.5.0 (from git-sources), which lacked

Re: [gentoo-user] udev-197 USE=kmod

2013-01-27 Thread Matthias Hanft
Florian Philipp wrote: Is it really a drop-in? I was under the impression that for example `modprobe -l` is not implemented (mentioned in a comment on the eudev fork on LWN). I guess that's outdated as well. I'm using kmod's modprobe, and there is *no* -l option. -Matt

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Jarry
On 24-Mar-13 17:46, Neil Bothwick wrote: On Sun, 24 Mar 2013 17:26:03 +0100, Jarry wrote: [ebuild N ] sys-kernel/gentoo-sources-3.7.10:3.7.10 USE=-build -deblob -symlink 68,335 kB [ebuild N ] virtual/linux-sources-0 0 kB [ebuild R] sys-apps/kmod-12-r1 USE=tools zlib -debug

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Felix Kuperjans
package.provided again, and again... BTW why should kmod depend on kernel-sources? Or even better, why should be kmod installed, if I have static (non-modular) kernel? Because your use case is not standard. The normal situation for users with kmod installed (and you have already kmod installed, since

[gentoo-user] Why is udev now having USE (-openrc%*)

2014-05-09 Thread Mick
What is the meaning of this change? [ebuild U ] sys-fs/udev-212-r1 [208] USE=acl firmware-loader gudev introspection kmod -doc (-selinux) -static-libs (-openrc%*) 2,660 kB -- Regards, Mick signature.asc Description: This is a digitally signed message part.

[gentoo-user] Re: Kernel 3.14.14 build failure at DEPMOD stage

2014-08-16 Thread walt
On 08/16/2014 11:56 AM, Walter Dnes wrote: * unmerge modutils * emerge kmod, with the tools USE flag. Before I screw anything up, does this sound reasonable? Yes, that's what I did and all's well. But *don't* do it until you return from your trip, lest the spirit of desktop environments

Re: [gentoo-user] Is 'MAKEOPTS=--jobs --load-average=5' silly?

2013-03-26 Thread Michael Hampicke
modules. I have to build spl first, then zfs-kmod. But that's because zfs-kmod requires a complete built spl. Interesting, I have --jobs and portage doesn't try t build spl and zfs-kmod in parallel, it always completes spl first. Interesting. Maybe a problem with module-rebuild? I

Re: [gentoo-user] udev-197 vs udev-200??

2013-03-30 Thread Mark David Dumlao
, with strange Blockers referencing udev-186??? [ebuild U #] sys-fs/udev-200 [171-r10] USE="acl%* firmware-loader%* kmod%* openrc%* -doc% -gudev -hwdb -introspection -keymap (-selinux) -static-libs% (-action_modeswitch%) (-build%) (-debug%) (-edd%) (-e

Re: [gentoo-user] udev upgrade 208 212-r1, openrc USE flag changed to disabled?

2014-06-14 Thread Alan McKinnon
On 14/06/2014 15:30, Tanstaafl wrote: Is this right? # eix udev ... [U] sys-fs/udev Available versions: 208-r1^t 212-r1^t ~213^t **^t {acl doc +firmware-loader gudev introspection +kmod selinux static-libs ABI_MIPS=n32 n64 o32 ABI_X86=32 64 x32} Installed versions: 208^t

Re: [gentoo-user] list of kernel modules

2012-04-06 Thread András Csányi
-3.16-r1 USE=-static 233 kB [blocks B ] sys-apps/module-init-tools (sys-apps/module-init-tools is blocking sys-apps/kmod-7) [blocks B ] sys-apps/kmod (sys-apps/kmod is blocking sys-apps/module-init-tools-3.16-r1) Total: 1 package (1 new), Size of downloads: 233 kB Conflict: 2 blocks (2

Re: [gentoo-user] cannot compile kvm

2009-12-23 Thread Xi Shen
On Thu, Dec 24, 2009 at 9:14 AM, Xi Shen davidshe...@googlemail.com wrote: hi, i cannot access my computer now, so i can only tell you what i remember. i am using gentoo amd64, and the portage is updated. the kernel have kvm modules compiled. when i was trying to emerge kvm-kmod, it is said

Re: [gentoo-user] Which 'tools' package for VMware DomU?

2011-03-31 Thread Mike Edenfield
On 3/31/2011 4:31 AM, Pandu Poluan wrote: The specific modules you mentioned are included in your kernel already, assuming you are using at least a 2.6.34 kernel. You'll still want to install open-vm-tools, which installs the other modules via open-vm-tools-kmod, like vsock and vmci, plus

[gentoo-user] Re: module-init-tools : masked opponent

2013-03-09 Thread »Q«
On Sat, 9 Mar 2013 21:02:02 -0600 »Q« boxc...@gmx.net wrote: On Sat, 9 Mar 2013 21:22:23 -0500 Philip Webb purs...@ca.inter.net wrote: It looks as if the change needs a 'news' msg. If it turns out to be solved by the tools flag for kmod, I gotta disagree. I also use -* , but I don't

Re: [gentoo-user] [SOLVED] make modules_install error; modules not recognized as ELF files

2013-03-15 Thread Walter Dnes
On Fri, Mar 15, 2013 at 03:07:01AM -0400, Walter Dnes wrote It was actually modutils that was masked out and replaced with modutils. This had not kicked in yet on the install image I was using on the netbook. I had to unmerge virtual/modutils and modutils, then I was able to emerge kmod

Re: [gentoo-user] [SOLVED] make modules_install error; modules not recognized as ELF files

2013-03-15 Thread Walter Dnes
On Fri, Mar 15, 2013 at 09:33:16AM +, Neil Bothwick wrote On Fri, 15 Mar 2013 03:37:05 -0400, Walter Dnes wrote: For anybody who's reading this thread... you *MUST* use the tools flag with kmod in order to get basic stuff like a man page, lsmod, etc. The tools flag is enabled

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Neil Bothwick
On Sun, 24 Mar 2013 17:26:03 +0100, Jarry wrote: [ebuild N ] sys-kernel/gentoo-sources-3.7.10:3.7.10 USE=-build -deblob -symlink 68,335 kB [ebuild N ] virtual/linux-sources-0 0 kB [ebuild R] sys-apps/kmod-12-r1 USE=tools zlib -debug -doc -lzma -static-libs KERNEL=(linux

Re: [gentoo-user] Is 'MAKEOPTS=--jobs --load-average=5' silly?

2013-03-25 Thread Michael Hampicke
to the --jobs option. The only exception is when rebuilding my kernel modules. I have to build spl first, then zfs-kmod. But that's because zfs-kmod requires a complete built spl.

[gentoo-user] Re: ZFS wiki confusion

2013-04-01 Thread Remy Blank
Douglas J Hunley wrote: Do you really need to copy the files into the kernel tree? No, you don't need to do that. which seems to pull in the daemon and the kmod so wouldn't the zfs-kmod ebuild build against the current kernel and drop in the modules directory all by itself much like any

Re: [gentoo-user] why zfs and friends want to update to 9999?

2017-10-11 Thread J. Roeleveld
how did you unmask zfs? Here are mine: $ grep -r zfs /etc/portage /etc/portage/sets/zfs:sys-fs/zfs /etc/portage/sets/zfs:sys-fs/zfs-kmod /etc/portage/package.keywords/zfs:=sys-fs/zfs-kmod-0.7.1 ~amd64 /etc/portage/package.keywords/zfs:=sys-fs/zfs-0.7.1 ~amd64 $ grep -r spl /etc/portage /etc/portag

[gentoo-user] Which 'tools' package for VMware DomU?

2011-03-30 Thread Pandu Poluan
Hello, list! I want to deploy some Gentoo-based VMs on VMware. From portage-search, I see some 'tools' related to VMware, namely: * vmware-tools * open-vm-tools * open-vm-tools-kmod What are the differences? And which one should I use if I want to use VMware's PVSCSI and VMXNET? Thank you

Re: [gentoo-user] udev-197 USE=kmod

2013-01-27 Thread Florian Philipp
Am 27.01.2013 12:33, schrieb Matthias Hanft: Florian Philipp wrote: Is it really a drop-in? I was under the impression that for example `modprobe -l` is not implemented (mentioned in a comment on the eudev fork on LWN). I guess that's outdated as well. I'm using kmod's modprobe, and there

[gentoo-user] module-init-tools : masked opponent

2013-03-09 Thread Philip Webb
Doing my usual Saturday system update, I saw a prominent msg telling me that 'module-init-tools' has been masked to use 'kmod' or 'modutils' -- the msgs vary -- to replace it. When I did so (both), Nvidia wouldn't start, even after remerging it. Back with 'module-init-tools' -- now

[gentoo-user] Re: module-init-tools : masked opponent

2013-03-09 Thread »Q«
On Sat, 9 Mar 2013 21:22:23 -0500 Philip Webb purs...@ca.inter.net wrote: It looks as if the change needs a 'news' msg. If it turns out to be solved by the tools flag for kmod, I gotta disagree. I also use -* , but I don't think we should get news items whenever that's going to break something

Re: [gentoo-user] How can I prevent gentoo-sources being installed?

2013-03-24 Thread Canek Peláez Valdés
: no wildcards are allowed, so whenever new sorces come I'll have to edit package.provided again, and again... BTW why should kmod depend on kernel-sources? Or even better, why should be kmod installed, if I have static (non-modular) kernel? Because your use case is not standard. The normal

Re: [gentoo-user] Re: beegfs goes opensource!

2016-02-27 Thread Tanstaafl
s, to have their own >> ZFS-in-kernel system available, and that it would also be possible to >> accomplish this via an overlay... > sys-fs/zfs-kmod I would be using this on a server, so, for security reasons, no module support.

Re: [gentoo-user] kvm and intel E5450 processor

2009-09-25 Thread James Erickson
if you have 2.6.31 and want to use kvm-88-r1, kvm-kmod-88-r1 is not required and you can use the in kernel modules. if they release kvm-devel-89 for example, it may have newer kvm-kmod code than what is bundled in the kernel. Daniel, thanks for your help in this matter. i have linux-2.6.31

Re: [gentoo-user] Which 'tools' package for VMware DomU?

2011-03-31 Thread Pandu Poluan
: * vmware-tools * open-vm-tools * open-vm-tools-kmod What are the differences? And which one should I use if I want to use VMware's PVSCSI and VMXNET? As I understand things, open-vm-tools is just an open-source version of vmware-tools, but uses the same code base and is managed by VMWare

Re: [gentoo-user] Moving from old udev to eudev

2013-08-01 Thread Walter Dnes
googled until my fingers are blue, but cannot for the life of me find any explicit instructions for *how* to switch from udev to eudev. Step 1) keyword sys-fs/eudev-1_beta2-r2 Step 2) ensure that kmod and openrc and -modutils USE flags are set (at least for sys-fs/eudev). tools flag needs

Re: [gentoo-user] list of kernel modules

2012-04-06 Thread Mark Knecht
c2stable ~ # See my previous letter and you can see what the situation is at my machine. It looks like my modprobe command belongs to sys-apps/kmod package. I installed this system 2 months ago. -- --  Csanyi Andras (Sayusi Ando)  -- http://sayusi.hu -- http://facebook.com/andras.csanyi

[gentoo-user] trouble downgrading systemd and virtual/udev

2013-09-25 Thread gottlieb
package.mask/systemd = livecd package.mask # emerge -1 =virtual/udev-200 =sys-apps/systemd-204 These are the packages that would be merged, in reverse order: Calculating dependencies... done! [ebuild UD ] sys-apps/systemd-204 [207-r2] USE=acl firmware-loader gudev introspection keymap%* kmod

[gentoo-user] udev-197 vs udev-200??

2013-03-30 Thread Tanstaafl
-pvuDN world shows updates to BOTH virtual/udev-197-r2 *and* udev-200, with strange Blockers referencing udev-186??? [ebuild U #] sys-fs/udev-200 [171-r10] USE=acl%* firmware-loader%* kmod%* openrc%* -doc% -gudev -hwdb -introspection -keymap (-selinux) -static-libs% (-action_modeswitch

[gentoo-user] blocking -systemd

2014-02-06 Thread Joseph
after recent experience. So I was planning on avoiding it but I don't know if I can. emerge -1avq gnome-base/gnome-settings-daemon * Last emerge --sync was 45d 2h 15m 32s ago. [ebuild N] sys-apps/systemd-208-r2 USE=filecaps firmware-loader gudev introspection kmod pam policykit tcpd -acl

Re: [gentoo-user] can't unload modules

2005-08-03 Thread Holly Bostick
the problem with your cable TV reception really *is* that the power is unplugged, after all. That said, do you also have KMOD (Automatic kernel module loading) set? I can't think of anything else that might have any affect on this, unless the problem is with the specific modules that you're trying

Re: [gentoo-user] Which 'tools' package for VMware DomU?

2011-03-30 Thread Mike Edenfield
On 3/30/2011 12:55 PM, Pandu Poluan wrote: Hello, list! I want to deploy some Gentoo-based VMs on VMware. From portage-search, I see some 'tools' related to VMware, namely: * vmware-tools * open-vm-tools * open-vm-tools-kmod What are the differences? And which one should I use

  1   2   3   4   >