Re: [gentoo-user] Masked packages

2007-04-13 Thread W. Barnhoorn
Johannes Skov Frandsen wrote: echo dev-php5/phpunit-3.0.5 ~x86 /etc/portage/package.keywords emerge -av dev-php5/phpunit .. Invalid atom in /etc/portage/package.keywords: dev-php5/phpunit-3.0.5 You used the version number of the package, and that why portage complains. The right line

Re: [gentoo-user] Masked packages

2007-04-13 Thread Etaoin Shrdlu
On Friday 13 April 2007 11:47, Johannes Skov Frandsen wrote: My problem is that emerge still ain't to happy... it prints out: Invalid atom in /etc/portage/package.keywords: dev-php5/phpunit-3.0.5 Just put the name of the package without the version number: echo dev-php5/phpunit ~x86 /etc

[gentoo-user] Masked packages

2007-04-13 Thread Johannes Skov Frandsen
posts I figured that the way to go would be to add a line to the 'package.keywords' file in /etc/portage. So i did the following: echo dev-php5/phpunit-3.0.5 ~x86 /etc/portage/package.keywords emerge -av dev-php5/phpunit My problem is that emerge still ain't to happy... it prints out: Invalid

Re: [gentoo-user] Masked packages

2007-04-13 Thread Will Briggs
figured that the way to go would be to add a line to the 'package.keywords' file in /etc/portage. So i did the following: echo dev-php5/phpunit-3.0.5 ~x86 /etc/portage/package.keywords Try echo =dev-php5/phpunit-3.0.5 ~x86 /dtc/portage/package.keywords Alternatively emerge flagedit

Re: [gentoo-user] Masked packages

2007-04-13 Thread Tony Stohne
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Etaoin Shrdlu said the following on 2007-04-13 12:28: Just put the name of the package without the version number: echo dev-php5/phpunit ~x86 /etc/portage/package.keywords ...or put = before the specific version, as in echo =dev-php5/phpunit

Re: [gentoo-user] Masked packages

2007-04-13 Thread Boris Fersing
there is no way around it. After reading trough the different posts I figured that the way to go would be to add a line to the 'package.keywords' file in /etc/portage. So i did the following: echo dev-php5/phpunit-3.0.5 ~x86 /etc/portage/package.keywords emerge -av dev-php5/phpunit My problem