[gentoo-user] qt3support conflict

2009-06-27 Thread Andrew Gaydenko
Trying to upgrade to qt 4.5.2: kde4 wants qt3support for qt-core: x11-libs/qt-core-4.5.2 (Change USE: +qt3support) (dependency required by x11-libs/qt-qt3support-4.5.2 [ebuild]) (dependency required by kde-base/kteatime-4.2.4 [installed]) (dependency required by kde-base/kdetoys-meta-4.2.4

[gentoo-user] Re: qt3support conflict

2009-06-27 Thread Nikos Chantziaras
On 06/28/2009 12:51 AM, Andrew Gaydenko wrote: Trying to upgrade to qt 4.5.2: kde4 wants qt3support for qt-core: x11-libs/qt-core-4.5.2 (Change USE: +qt3support) (dependency required by x11-libs/qt-qt3support-4.5.2 [ebuild]) (dependency required by kde-base/kteatime-4.2.4 [installed

Re: [gentoo-user] Uncle: qt-*:4 dependencies/blocks preventing world update

2009-10-25 Thread Amit Dor-Shifer
amit0 ~ # eselect profile show Current make.profile symlink: default/linux/amd64/10.0 amit0 ~ # euse -i qt3support global use flags (searching: qt3support) no matching entries found local use flags (searching: qt3support

Re: [gentoo-user] Re: qt3support conflict

2009-06-27 Thread Andrew Gaydenko
On Sunday 28 June 2009 02:41:53 Nikos Chantziaras wrote: On 06/28/2009 01:32 AM, Andrew Gaydenko wrote: On Sunday 28 June 2009 02:23:38 Nikos Chantziaras wrote: On 06/28/2009 12:51 AM, Andrew Gaydenko wrote: Trying to upgrade to qt 4.5.2: kde4 wants qt3support for qt-core: x11-libs

[gentoo-user] Re: qt3support conflict

2009-06-27 Thread Nikos Chantziaras
On 06/28/2009 01:32 AM, Andrew Gaydenko wrote: On Sunday 28 June 2009 02:23:38 Nikos Chantziaras wrote: On 06/28/2009 12:51 AM, Andrew Gaydenko wrote: Trying to upgrade to qt 4.5.2: kde4 wants qt3support for qt-core: x11-libs/qt-core-4.5.2 (Change USE: +qt3support) (dependency required

Re: [gentoo-user] Qt3 and Qt3support

2008-01-30 Thread Pavel Sanda
What actually does the qt3support USE flag do on the qt4 ebuild? Does for example qtconfig wont be compiled installed without it. pavel -- gentoo-user@lists.gentoo.org mailing list

[gentoo-user] Howto get rid of USE qt3support

2010-06-09 Thread Rudmer van Dijk
Hi, there is a new qt and kde available, but it still has the annoying USE flag qt3support... is there a way to get rid of it? a lot of kde packages are complaining about qt3support and I don't want it. qt3 left my system a couple of years ago! so this is starting to get really annoying 8

[gentoo-user] qt3support USE flag. Is it needed now?

2010-10-07 Thread Dale
Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3. I'm just curious if I can get rid of this USE flag now. I only have KDE4 installed. No more

[gentoo-user] Re: Howto get rid of USE qt3support

2010-06-09 Thread Nikos Chantziaras
On 06/09/2010 11:27 PM, Rudmer van Dijk wrote: Hi, there is a new qt and kde available, but it still has the annoying USE flag qt3support... is there a way to get rid of it? a lot of kde packages are complaining about qt3support and I don't want it. qt3 left my system a couple of years ago! so

[gentoo-user] update problems after profile update

2009-11-10 Thread Arnau Bria
: first: emerge: there are no ebuilds built with USE flags to satisfy =x11-libs/qt-qt3support-4.5.1:4[accessibility,kde]. !!! One of the following packages is required to complete your request: - x11-libs/qt-qt3support-4.5.3 (Change USE: +kde) x11-libs/qt-qt3support kde then x11-libs/qt-core

Re: [gentoo-user] qt3support: only in /etc/make.conf, never in /etc/portage/package.use

2010-05-03 Thread David W Noon
On Mon, 03 May 2010 03:30:02 +0200, Grant Edwards wrote about [gentoo-user] qt3support: only in /etc/make.conf, never in /etc/portage/package.use: qt3support on a per-package basis. If you want qt3support put it in /etc/make.conf. Despite the fact that portage will tell you to enable qt3support

[gentoo-user] Re: Howto get rid of USE qt3support

2010-06-09 Thread Nikos Chantziaras
On 06/10/2010 01:17 AM, Rudmer van Dijk wrote: On Wednesday 09 June 2010, Nikos Chantziaras wrote: On 06/09/2010 11:27 PM, Rudmer van Dijk wrote: Hi, there is a new qt and kde available, but it still has the annoying USE flag qt3support... is there a way to get rid of it? a lot of kde

Re: [gentoo-user] qt3support USE flag. Is it needed now?

2010-10-07 Thread Peter Humphrey
On Thursday 07 October 2010 20:40:32 Dale wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3. I'm just curious if I can get rid

Re: [gentoo-user] Slot war on my system

2012-06-03 Thread kwkhui
On Sun, 03 Jun 2012 00:27:09 -0500 Michael Sullivan msulli1...@gmail.com wrote: x11-libs/qt-qt3support:4 (x11-libs/qt-qt3support-4.8.1::gentoo, installed) pulled in by ~x11-libs/qt-qt3support-4.8.1[accessibility=,aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-declarative-4.8.1

Re: [gentoo-user] Uncle: qt-*:4 dependencies/blocks preventing world update

2009-10-25 Thread Mick
On Sunday 25 October 2009 11:43:59 Amit Dor-Shifer wrote: With regards to this: I believe I'm in the same situation: SNIP emerge: there are no ebuilds built with USE flags to satisfy ~x11-libs/qt-core-4.5.2[qt3support,-debug]. !!! One of the following packages is required to complete your

Re: [gentoo-user] Qt3 and Qt3support

2008-01-26 Thread Vaclav Vanc
2008/1/26, Willie Wong [EMAIL PROTECTED]: What actually does the qt3support USE flag do on the qt4 ebuild? Does it enable some sort of compatibility library for qt3? For example, I want djvu with the djview viewer built, which requires the qt3 flag set for the djvu ebuild. Currently I have

Re: [gentoo-user] Howto get rid of USE qt3support

2010-06-09 Thread Paul Hartman
On Wed, Jun 9, 2010 at 3:27 PM, Rudmer van Dijk rudmer.van.d...@casema.nl wrote: Hi, there is a new qt and kde available, but it still has the annoying USE flag qt3support... is there a way to get rid of it? a lot of kde packages are complaining about qt3support and I don't want it. qt3

[gentoo-user] qt3support issue solved

2009-06-30 Thread Doug Hunley
Just another bullet point of information for the 'can't upgrade to 4.5.2 cause of qt3support' thread. I solved it here by removing 'qt3' from USE in make.conf. For whatever reason, I had both 'qt3' and 'qt4' in the USE flag. Removing 'qt3' allowed 'emerge world' to do its thing. -- Douglas J

Re: [gentoo-user] qt3support issue solved

2009-06-30 Thread Anthony Mutiso
Is there a difference between qt and qt4? Doug Hunley wrote: Just another bullet point of information for the 'can't upgrade to 4.5.2 cause of qt3support' thread. I solved it here by removing 'qt3' from USE in make.conf. For whatever reason, I had both 'qt3' and 'qt4' in the USE flag. Removing

[gentoo-user] qt3support: only in /etc/make.conf, never in /etc/portage/package.use

2010-05-02 Thread Grant Edwards
I probably shouldn't admit this in public, but I've been fighting with Portage over qt3 support for a long time (at least a year). I was constantly being told by Portage to either enable or disable the qt3support use flag for some package or other. I usually just gave up and uninstalled all

Re: [gentoo-user] Re: Howto get rid of USE qt3support

2010-06-09 Thread Rudmer van Dijk
On Wednesday 09 June 2010, Nikos Chantziaras wrote: On 06/09/2010 11:27 PM, Rudmer van Dijk wrote: Hi, there is a new qt and kde available, but it still has the annoying USE flag qt3support... is there a way to get rid of it? a lot of kde packages are complaining about qt3support and I

Re: [gentoo-user] qt3support USE flag. Is it needed now?

2010-10-07 Thread Alan McKinnon
Apparently, though unproven, at 21:40 on Thursday 07 October 2010, Dale did opine thusly: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3

Re: [gentoo-user] qt3support USE flag. Is it needed now?

2010-10-07 Thread Paul Hartman
On Thu, Oct 7, 2010 at 2:40 PM, Dale rdalek1...@gmail.com wrote: Hi, I have a question.  I'm using KDE4, about to switch to 4.5.2.  Do I need qt3support anymore?  I'm talking about the USE flag qt3support.  I run into blocks sometimes and I know KDE3 needed qt3.  I'm just curious if I can get

Re: [gentoo-user] This nite's switch to full multilib

2015-03-30 Thread Peter Humphrey
of a clean upgrade Just to get you started, here's my list from a system that upgraded smoothly: $ grep qt /etc/portage/package.use app-text/popplercairo qt4 dev-qt/qtcore qt3support dev-qt/qtdeclarativeqt3support webkit dev-qt/qtgui

Re: [gentoo-user] update problems after profile update

2009-11-10 Thread Alan McKinnon
change profile at all then I did my emerge -uDvpt world and found that I had to add some use flags to some packages: first: emerge: there are no ebuilds built with USE flags to satisfy =x11-libs/qt-qt3support-4.5.1:4[accessibility,kde]. !!! One of the following packages is required

[gentoo-user] Re: qt3support: only in /etc/make.conf, never in /etc/portage/package.use

2010-05-03 Thread Grant Edwards
On 2010-05-03, David W Noon dwn...@ntlworld.com wrote: On Mon, 03 May 2010 03:30:02 +0200, Grant Edwards wrote about [gentoo-user] qt3support: only in /etc/make.conf, never in /etc/portage/package.use: qt3support on a per-package basis. If you want qt3support put it in /etc/make.conf

[gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Nikos Chantziaras
On 10/08/2010 01:14 AM, Dale wrote: Paul Hartman wrote: On Thu, Oct 7, 2010 at 2:40 PM, Dalerdalek1...@gmail.com wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I

Re: [gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Dale
Nikos Chantziaras wrote: On 10/08/2010 01:14 AM, Dale wrote: Paul Hartman wrote: On Thu, Oct 7, 2010 at 2:40 PM, Dalerdalek1...@gmail.com wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run

[gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Nikos Chantziaras
On 10/08/2010 02:17 AM, Dale wrote: Nikos Chantziaras wrote: On 10/08/2010 01:14 AM, Dale wrote: Paul Hartman wrote: On Thu, Oct 7, 2010 at 2:40 PM, Dalerdalek1...@gmail.com wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking

[gentoo-user] Qt3 and Qt3support

2008-01-26 Thread Willie Wong
What actually does the qt3support USE flag do on the qt4 ebuild? Does it enable some sort of compatibility library for qt3? For example, I want djvu with the djview viewer built, which requires the qt3 flag set for the djvu ebuild. Currently I have both qt3 and qt4 installed on my system. Does

[gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Nikos Chantziaras
On 10/07/2010 10:40 PM, Dale wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3. I'm just curious if I can get rid of this USE flag now. I only

Re: [gentoo-user] Re: qt3support conflict

2009-06-27 Thread Andrew Gaydenko
all packages that are to be upgraded and install them afterwards. Or wait for someone who actually knows a Paludis workaround for this. No, I don't use Paludis. What do you mean saying has automatically resolved all blocks? Do you mean you have added those qt3support flags and started

[gentoo-user] Re: qt3support conflict

2009-06-27 Thread walt
On 06/27/2009 03:32 PM, Andrew Gaydenko wrote: make.conf hasn't qt3support at all. Adding qt3support to qt-opengl shows... well... something horrible (see below) :-) //== emerge -pvDuN world These are the packages that would

Re: [gentoo-user] Re: qt3support conflict

2009-06-27 Thread Andrew Gaydenko
On Sunday 28 June 2009 02:54:59 walt wrote: On 06/27/2009 03:32 PM, Andrew Gaydenko wrote: make.conf hasn't qt3support at all. Adding qt3support to qt-opengl shows... well... something horrible (see below

[gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Nikos Chantziaras
On 10/07/2010 10:51 PM, Alan McKinnon wrote: Apparently, though unproven, at 21:40 on Thursday 07 October 2010, Dale did opine thusly: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run

Re: [gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Alan McKinnon
, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3. I'm just curious if I can get rid of this USE flag now. I only have KDE4 installed. No more KDE3 left that I know

Re: [gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Alan McKinnon
Apparently, though unproven, at 01:31 on Friday 08 October 2010, Dale did opine thusly: But I would still have to recompile again with the qt3support flag if it messed up badly. On this machine, that takes time. During that time, I may not have KDE at all. I did that when I made

Re: [gentoo-user] QT4's qtconfig - SOLVED

2007-01-07 Thread Andrew Gaydenko
To be built, 'qtconfig' needs 'qt3support' USE flag be turned on. === On Sunday 07 January 2007 16:20, Martins wrote: === ... from eix -s qt: 4.2.2(4)(09:07:11 2006.12.09.)(-accessibility cups dbus -debug -doc -examples -firebird gif -glib -input_devices_wacom

Re: [gentoo-user] Re: qt3support conflict

2009-06-27 Thread Andrew Gaydenko
On Sunday 28 June 2009 04:55:57 Nikos Chantziaras wrote: ... Thanks, Portage has resolved conflicts, I'm on 4.5.2 now. It seems like qt3support flags deletion doesn't work for me. Now, after upgrading, I have tried to comment out those flags in package.use and got conflicts. What profile

Re: [gentoo-user] Uncle: qt-*:4 dependencies/blocks preventing world update

2009-10-25 Thread Arttu V.
On 10/25/09, Amit Dor-Shifer ami...@oversi.com wrote: !!! One of the following packages is required to complete your request: - x11-libs/qt-core-4.5.2 (Change USE: +qt3support) Have you tried doing what it says here, i.e., enabling USE=qt3support in, e.g., make.conf? (Sorry if you've already

Re: [gentoo-user] virtualbox-ose build failed [SOLVED]

2008-08-31 Thread pat
acpi alsa -arts audiofile browserplugin dbus divx4linux -directfb -doc dts dvb dvd dvdr dvdread -eds -emacs -emboss flac gnome -kde kerberos mad mime mmx mozilla nptl nptlonly nsplugin opengl posix -qt -qt3 -qt3support -qt4 -qt-static -samba slang sse -svga unicode usb v4l v4l2 videos

Re: [gentoo-user] qt3support USE flag. Is it needed now?

2010-10-07 Thread Dale
Paul Hartman wrote: On Thu, Oct 7, 2010 at 2:40 PM, Dalerdalek1...@gmail.com wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3. I'm

Re: [gentoo-user] qt3support USE flag. Is it needed now?

2010-10-07 Thread Dale
Peter Humphrey wrote: On Thursday 07 October 2010 20:40:32 Dale wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3. I'm just curious

[gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Nikos Chantziaras
On 10/08/2010 01:24 AM, Dale wrote: Peter Humphrey wrote: On Thursday 07 October 2010 20:40:32 Dale wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3

Re: [gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Dale
Nikos Chantziaras wrote: On 10/08/2010 01:24 AM, Dale wrote: Peter Humphrey wrote: On Thursday 07 October 2010 20:40:32 Dale wrote: Hi, I have a question. I'm using KDE4, about to switch to 4.5.2. Do I need qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks

Re: [gentoo-user] Slot war on my system

2012-06-03 Thread Alan McKinnon
On Sun, 3 Jun 2012 23:38:53 +0800 kwk...@hkbn.net wrote: On Sun, 03 Jun 2012 00:27:09 -0500 Michael Sullivan msulli1...@gmail.com wrote: x11-libs/qt-qt3support:4 (x11-libs/qt-qt3support-4.8.1::gentoo, installed) pulled in by ~x11-libs/qt-qt3support-4.8.1[accessibility=,aqua=,c

[gentoo-user] qt USE flags conflict

2015-05-16 Thread Mick
packages is required to complete your request: - dev-qt/qtcore-4.8.6-r2::gentoo (Change USE: +qt3support) - dev-qt/qtgui-4.8.6-r4::gentoo (Change USE: -qt3support) (dependency required by dev-qt/qtgui-4.8.6-r4::gentoo [ebuild]) (dependency required by app-text/poppler-0.32.0::gentoo[qt4] [installed

Re: [gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-07 Thread Dale
qt3support anymore? I'm talking about the USE flag qt3support. I run into blocks sometimes and I know KDE3 needed qt3. I'm just curious if I can get rid of this USE flag now. I only have KDE4 installed. No more KDE3 left that I know of. Going along with what Alan said. qt3support does not use Qt 3 at all

Re: [gentoo-user] virtualbox-ose build failed

2008-08-31 Thread Dale
-eds -emacs -emboss flac gnome -kde kerberos mad mime mmx mozilla nptl nptlonly nsplugin opengl posix -qt -qt3 -qt3support -qt4 -qt-static -samba slang sse -svga unicode usb v4l v4l2 videos win32codecs X xinerama -xmms xsl xvid package.use ~~~ app-emulation/virtualbox-ose additions alsa

Re: [gentoo-user] virtualbox-ose build failed

2008-08-31 Thread pat
divx4linux -directfb -doc dts dvb dvd dvdr dvdread -eds -emacs -emboss flac gnome -kde kerberos mad mime mmx mozilla nptl nptlonly nsplugin opengl posix -qt -qt3 -qt3support -qt4 -qt-static -samba slang sse -svga unicode usb v4l v4l2 videos win32codecs X xinerama -xmms xsl xvid package.use

Re: [gentoo-user] qt3support: only in /etc/make.conf, never in /etc/portage/package.use

2010-05-02 Thread Dale
Grant Edwards wrote: I probably shouldn't admit this in public, but I've been fighting with Portage over qt3 support for a long time (at least a year). I was constantly being told by Portage to either enable or disable the qt3support use flag for some package or other. I usually just gave up

[gentoo-user] Slot war on my system

2012-06-02 Thread Michael Sullivan
-qt3support-4.8.1::gentoo Here's a shortened version of what I get when I run python-updater: !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: x11-libs/qt-script:4 (x11-libs/qt-script-4.8.1::gentoo, installed

Re: [gentoo-user] Slot war on my system

2012-06-03 Thread Alan McKinnon
-daemon-2.32.1-r1 x11-libs/qt-script-4.8.1::gentoo x11-libs/qt-core-4.8.1-r3::gentoo x11-libs/qt-sql-4.8.1::gentoo x11-libs/qt-dbus-4.8.1::gentoo x11-libs/qt-gui-4.8.1-r1::gentoo x11-libs/qt-qt3support-4.8.1::gentoo Here's a shortened version of what I get when I run python-updater

[gentoo-user] Re: qt3support conflict

2009-06-27 Thread Nikos Chantziaras
afterwards. Or wait for someone who actually knows a Paludis workaround for this. No, I don't use Paludis. What do you mean saying has automatically resolved all blocks? Do you mean you have added those qt3support flags and started emerging and got successfull upgrading to 4.5.2 without any problems

[gentoo-user] Re: qt3support conflict

2009-06-27 Thread Nikos Chantziaras
On 06/28/2009 04:12 AM, Andrew Gaydenko wrote: On Sunday 28 June 2009 04:55:57 Nikos Chantziaras wrote: ... Thanks, Portage has resolved conflicts, I'm on 4.5.2 now. It seems like qt3support flags deletion doesn't work for me. Now, after upgrading, I have tried to comment out those flags

[gentoo-user] Re: Where to get qmake for qt3?

2010-07-01 Thread Nikos Chantziaras
On 07/01/2010 10:21 PM, Grant Edwards wrote: On 2010-07-01, Nils Larssonn...@nerdshack.com wrote: Where do I find qmake 3? I assume qt3 and whatever deps. it needs are available through the kde-sunset overlay. Two questions: 1) What do the qt3support use flag and the qt-qt3support

Re: [gentoo-user] qt3support USE flag. Is it needed now?

2010-10-08 Thread Dale
will. That's what I was going to do. Copy the binaries from packages that I am currently using to a safe place then recompile. If it failed, I was going to delete the ones with the qt3support removed and but back the ones I saved that were compiled with qt3support. Dale :-) :-)

Re: [gentoo-user] [OT] Still trying to compile hydrogen

2012-02-18 Thread Alan McKinnon
that you need qt = 4.something. But it says you need qt = 3.2.0, so qt-meta 3.3.8b-r2 (which I have installed) would do fine. Oh, I just see that this is no longer in portage, my qt-meta:3 comes from the kde-sunset overlay. Maybe having Qt4 installed with the qt3support USE flag would work

Re: [gentoo-user] Understand Portage not

2012-09-29 Thread Florian Philipp
the following packages with USE=qt3support: x11-libs/qt-core:4 x11-libs/qt-gui:4 x11-libs/qt-sql:4 x11-libs/qt-opengl:4 The reason for the odd error message is that all QT packages require that the qt3support flag is either set for all or not set for any. When some other package requires qt3support

Re: [gentoo-user] Confusion

2009-10-18 Thread econti
! [ebuild N] app-office/akonadi-server-1.2.1 USE=mysql -sqlite [nomerge ] x11-libs/qt-dbus-4.5.2 [ebuild UD] x11-libs/qt-qt3support-4.5.1 [4.5.2] [ebuild UD]x11-libs/qt-sql-4.5.1 [4.5.2] [ebuild UD]x11-libs/qt-gui-4.5.1 [4.5.2-r2] USE=dbus* gtkstyle%* [ebuild UD

Re: [gentoo-user] qt USE flags conflict

2015-05-16 Thread Alan McKinnon
(-)?,abi_s390_64(-)?]. !!! One of the following packages is required to complete your request: - dev-qt/qtcore-4.8.6-r2::gentoo (Change USE: +qt3support) - dev-qt/qtgui-4.8.6-r4::gentoo (Change USE: -qt3support) (dependency required by dev-qt/qtgui-4.8.6-r4::gentoo [ebuild]) (dependency required by app

Re: [gentoo-user] virtualbox-ose build failed

2008-08-31 Thread Daniel Pielmeier
-qt3support -qt4 -qt-static -samba slang sse -svga unicode usb v4l v4l2 videos win32codecs X xinerama -xmms xsl xvid package.use ~~~ app-emulation/virtualbox-ose additions alsa pulseaudio qt qt3 qt3support qt4 emerge --pretend qt ~~~ [ebuild R ] x11-libs/qt-4.3.3 What I have

Re: [gentoo-user] qt3support issue solved

2009-06-30 Thread Alan McKinnon
? Doug Hunley wrote: Just another bullet point of information for the 'can't upgrade to 4.5.2 cause of qt3support' thread. I solved it here by removing 'qt3' from USE in make.conf. For whatever reason, I had both 'qt3' and 'qt4' in the USE flag. Removing 'qt3' allowed 'emerge world' to do

[gentoo-user] Where to get qmake for qt3?

2010-07-01 Thread Grant Edwards
, no qmake. I've got qt3support in my global useflags, and x11-libs/qt-qt3support is installed. Where do I find qmake 3? -- Grant Edwards grant.b.edwardsYow! I'm imagining a surfer at van filled with soy sauce

Re: [gentoo-user] Understand Portage not

2012-09-29 Thread Silvio Siefke
Hello, 2012/9/29 Florian Philipp li...@binarywings.net: Yes, the message is a bit counter-intuitive. What I think portage wants to tell you is that you need to re-emerge the following packages with USE=qt3support: x11-libs/qt-core:4 x11-libs/qt-gui:4 x11-libs/qt-sql:4 x11-libs/qt-opengl:4

[gentoo-user] Qt blocking @world update

2013-11-02 Thread Alex Schuster
-4.8.5:4[accessibility,dbus(+)] required by (kde-base/libkworkspace-4.11.2::gentoo, installed) ~dev-qt/qtgui-4.8.5[aqua=,debug=,egl=,qt3support=] required by (dev-qt/qtopengl-4.8.5::gentoo, installed) (and 283 more with the same problems) (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled

[gentoo-user] Re: This nite's switch to full multilib

2015-03-30 Thread James
Peter Humphrey peter at prh.myzen.co.uk writes: On Sunday 29 March 2015 20:12:45 Alan McKinnon wrote: grep -ir qt /etc/portage grep qt /etc/portage/package.use | wc -l =11 dev-qt/qt-creator android autotools cmake python dev-qt/qtguiqt3support =dev-qt/qtsql-4.8.5

Re: [gentoo-user] qt-dbus blocker

2009-10-13 Thread Yoav Luft
a source to broken system, to remove the older Qt libraries manually. [blocks B ] x11-libs/qt-qt3support-4.5.2 (x11-libs/qt-qt3support-4.5.2 is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt

Re: [gentoo-user] qt-dbus blocker

2009-10-13 Thread Yoav Luft
-qt3support-4.5.2 (x11-libs/qt-qt3support-4.5.2 is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2) [blocks B     ] x11-libs/qt-core

Re: [gentoo-user] custom-cxxflags not supported but on anyway

2009-02-16 Thread Daniel Pielmeier
[ebuild R ] x11-libs/qt-core-4.4.2 USE=qt3support ssl -custom-cxxflags% -debug -doc -glib -pch 0 kB -custom-cxxflags To me it looks like it is disabled! This flag has been added recently to the qt packages and although it is disabled the affected packages need a rebuild when newuse

Re: [gentoo-user] virtualbox-ose build failed

2008-08-31 Thread Daniel Pielmeier
gnome -kde kerberos mad mime mmx mozilla nptl nptlonly nsplugin opengl posix -qt -qt3 -qt3support -qt4 -qt-static -samba slang sse -svga unicode usb v4l v4l2 videos win32codecs X xinerama -xmms xsl xvid package.use ~~~ app-emulation/virtualbox-ose additions alsa pulseaudio qt qt3 qt3support

Re: [gentoo-user] QT4's qtconfig

2007-01-07 Thread Andrew Gaydenko
opengl -pch png postgres qt3support sqlite -sqlite3 -xinerama zlib) -- gentoo-user@gentoo.org mailing list

[gentoo-user] Re: qt3support conflict

2009-06-27 Thread Nikos Chantziaras
those qt3support flags and started emerging and got successfull upgrading to 4.5.2 without any problems and in spite of those blocks? I did not add qt3support anywhere. It seems to be enabled by default here. Anyway, you went past that problem anyway. Your current is something else: the blockers

[gentoo-user] Re: qt3support conflict

2009-06-28 Thread walt
On 06/27/2009 07:24 PM, Andrew Gaydenko wrote: On Sunday 28 June 2009 02:54:59 walt wrote: On 06/27/2009 03:32 PM, Andrew Gaydenko wrote: make.conf hasn't qt3support at all. Adding qt3support to qt-opengl shows... well... something horrible (see below

Re: [gentoo-user] qt3support issue solved

2009-06-30 Thread Anthony Mutiso
So for those that *had* qt in make.conf, (like me), the right thing to do is to change it to qt4? Alan McKinnon wrote: Yes. The difference is huge. KDE-3 uses Qt KDE-4 uses Qt4 They are so different that a name change from Qt to something else would be entirely acceptable.

Re: [gentoo-user] qt3support issue solved

2009-06-30 Thread Paul Hartman
On Tue, Jun 30, 2009 at 3:24 PM, Anthony Mutisoanm.mlis...@limuru.com wrote: So for those that *had* qt in make.conf, (like me), the right thing to do is to change it to qt4? I think the qt USE flag is deprecated in favor of qt3 and qt4 USE flags and ebuilds should have been updated to use the

[gentoo-user] Re: qt-dbus blocker

2009-10-13 Thread Peter Weilbacher
-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1) (the entire output from emerge world is below EMERGE_DEFAULT_OPTS=--ask --deep --tree --verbose --with-bdeps=y) I read the news article and was directed to http://www.linuxized.com/p192, which said to add dbus and qt3support

Re: [gentoo-user] Re: qt3support: only in /etc/make.conf, never in /etc/portage/package.use

2010-05-03 Thread David W Noon
On Mon, 03 May 2010 17:30:02 +0200, Grant Edwards wrote about [gentoo-user] Re: qt3support: only in /etc/make.conf, never in /etc/portage/package.use: On 2010-05-03, David W Noon dwn...@ntlworld.com wrote: [snip] Specifically, it applies to: x11-libs/qt-core x11-libs/qt-gui x11-libs

[gentoo-user] Re: Where to get qmake for qt3?

2010-07-01 Thread Grant Edwards
On 2010-07-01, Grant Edwards grant.b.edwa...@gmail.com wrote: On 2010-07-01, Nils Larsson n...@nerdshack.com wrote: Where do I find qmake 3? I assume qt3 and whatever deps. it needs are available through the kde-sunset overlay. Two questions: 1) What do the qt3support use flag and the qt

Re: [gentoo-user] Slot war on my system

2012-06-03 Thread Volker Armin Hemmann
Am Sonntag, 3. Juni 2012, 00:27:09 schrieb Michael Sullivan: =x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (net-wireless/bluedevil-1.1-r2::gentoo, installed) I think that is your culprit. -- #163933

Re: [gentoo-user] qt USE flags conflict

2015-05-16 Thread Mick
, in order: Calculating dependencies... done! 390_32(-)?,abi_s390_64(-)?]. !!! One of the following packages is required to complete your request: - dev-qt/qtcore-4.8.6-r2::gentoo (Change USE: +qt3support) - dev-qt/qtgui-4.8.6-r4::gentoo (Change USE: -qt3support) (dependency required

Re: [gentoo-user] Re: qt3support conflict

2009-06-28 Thread Alan McKinnon
On Sunday 28 June 2009 16:12:26 walt wrote: On 06/27/2009 07:24 PM, Andrew Gaydenko wrote: On Sunday 28 June 2009 02:54:59 walt wrote: On 06/27/2009 03:32 PM, Andrew Gaydenko wrote: make.conf hasn't qt3support at all. Adding qt3support to qt-opengl shows... well... something horrible (see

Re: [gentoo-user] Qt blocking @world update

2013-11-03 Thread Alan McKinnon
(+)] required by (kde-base/libkworkspace-4.11.2::gentoo, installed) ~dev-qt/qtgui-4.8.5[aqua=,debug=,egl=,qt3support=] required by (dev-qt/qtopengl-4.8.5::gentoo, installed) (and 283 more with the same problems) (dev-qt/qtgui-4.8.4-r1::gentoo, ebuild scheduled for merge) pulled

Re: [gentoo-user] Re: Using KDE apps in a non KDE environment

2015-10-02 Thread Walter Dnes
was deprecated, I eventually settled on mupdf, which is nice and lightweight. I skipped okular, because it brought in a big chunk of KDE. Just for s and giggles, I had a look today at what would be required to build okular on my system. Repeat emerge commands showed that my package.use would requi

[gentoo-user] qt-dbus blocker

2009-10-13 Thread Allan Gottlieb
I just started getting this blocker yesterday (was away for the weekend) [blocks B ] x11-libs/qt-dbus-4.5.1-r (x11-libs/qt-dbus-4.5.1-r is blocking x11-libs/qt-script-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11

[gentoo-user] complex depencies - how to cut the Gordian knot?

2009-07-10 Thread Helmut Jarausch
, x11-libs/qt-gui-4.5.2-r1, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2) [blocks B ] x11-libs/qt-test-4.5.1-r (x11-libs/qt-test-4.5.1-r is blocking x11-libs/qt-xmlpatterns-4.5.1) [blocks B ] x11-libs/qt-script-4.5.1-r (x11

[gentoo-user] The Great Macbook Update 3: Qt-4.5.1 to Qt-4.5.3 blocks hell

2009-12-26 Thread bn
, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1) [blocks b ] x11-libs/qt-gui-4.5.1-r (x11-libs/qt-gui-4.5.1-r is blocking x11-libs/qt-assistant-4.5.1, x11

Re: [gentoo-user] qt-xxx-4.5.0_rc1 conflicts

2009-02-12 Thread Momesso Andrea
to resolve the issue? x11-libs/qt-core:4 ('ebuild', '/', 'x11-libs/qt-core-4.5.0_rc1', 'merge') pulled in by ~x11-libs/qt-core-4.5.0_rc1[qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt- sql-4.5.0_rc1', 'merge') ~x11-libs/qt-core-4.5.0_rc1[-debug] required by ('ebuild

Re: [gentoo-user] crazy KDE4 panel

2009-05-01 Thread Paul Hartman
on turning qt3support flag on). Hmmm, I already used qt3support flag in make.conf so I did not notice that.

Re: [gentoo-user] virtualbox-ose build failed

2008-08-31 Thread pat
mime mmx mozilla nptl nptlonly nsplugin opengl posix -qt -qt3 -qt3support -qt4 -qt-static -samba slang sse -svga unicode usb v4l v4l2 videos win32codecs X xinerama -xmms xsl xvid package.use ~~~ app-emulation/virtualbox-ose additions alsa pulseaudio qt qt3 qt3support qt4

Re: [gentoo-user] QT4's qtconfig

2007-01-07 Thread Andrew Gaydenko
As I have wrote, 'qtconfig' demands 'qt3support' flag. === On Sunday 07 January 2007 18:57, Graham Murray wrote: === Andrew Gaydenko [EMAIL PROTECTED] writes: Probably somebody has (unstable) 4.2.2 installed... The thing is, v.4.2.2 is the first Qt4 installation on this machine

Re: [gentoo-user] Re: qt3support conflict

2009-06-27 Thread Andrew Gaydenko
On Sunday 28 June 2009 02:23:38 Nikos Chantziaras wrote: On 06/28/2009 12:51 AM, Andrew Gaydenko wrote: Trying to upgrade to qt 4.5.2: kde4 wants qt3support for qt-core: x11-libs/qt-core-4.5.2 (Change USE: +qt3support) (dependency required by x11-libs/qt-qt3support-4.5.2 [ebuild

[gentoo-user] Re: Confusion

2009-10-18 Thread Jonathan Callen
, qt-*-4.5.2 and xulrunner. Is it right? Is there any other solution? Thanks emilio Add USE=accessibility qt3support to /etc/make.conf, which should fix the downgrade issue (note: qt3support != qt3). - -- Jonathan -BEGIN PGP SIGNATURE- Version: GnuPG v2.0.11 (GNU/Linux) Comment: Using

Re: [gentoo-user] Qt3 deprecated, but Qt4 still not x86 (only ~x86)???

2010-02-10 Thread Stroller
mng nas nis pch qt3support raster (+)stable-branch tiff xinerama} Installed versions: 4.6.1(4)(23:21:45 09/02/10)(accessibility cups dbus glib gtk mng pch qt3support tiff xinerama -aqua -debug -nas -nis - raster) Homepage:http://qt.nokia.com/ Description

[gentoo-user] Re: Where to get qmake for qt3?

2010-07-01 Thread Grant Edwards
On 2010-07-01, Nils Larsson n...@nerdshack.com wrote: Where do I find qmake 3? I assume qt3 and whatever deps. it needs are available through the kde-sunset overlay. Two questions: 1) What do the qt3support use flag and the qt-qt3support package do? I had assumed that they enabled qt3

Re: [gentoo-user] Re: Where to get qmake for qt3?

2010-07-01 Thread Dale
Grant Edwards wrote: On 2010-07-01, Nils Larssonn...@nerdshack.com wrote: Where do I find qmake 3? I assume qt3 and whatever deps. it needs are available through the kde-sunset overlay. Two questions: 1) What do the qt3support use flag and the qt-qt3support package do

Re: [gentoo-user] custom-cxxflags not supported but on anyway

2009-02-16 Thread Dale
Daniel Pielmeier wrote: [ebuild R ] x11-libs/qt-core-4.4.2 USE=qt3support ssl -custom-cxxflags% -debug -doc -glib -pch 0 kB -custom-cxxflags To me it looks like it is disabled! This flag has been added recently to the qt packages and although it is disabled the affected

Re: [gentoo-user] virtualbox-ose build failed

2008-08-31 Thread Daniel Pielmeier
pat schrieb am 31.08.2008 14:49: Well, I've enabled qt3support in make.conf and the my Qt (4.3.3) library contains the uic3 source, so I'll see if the Qt rebuild helps :-) I'll inform if it helped or not. Normally it should be enough if it is enabled in package.use for x11-libs/qt. You

Re: [gentoo-user] Uncle: qt-*:4 dependencies/blocks preventing world update

2009-10-25 Thread Mick
for qt3support would be enabled by default. However, I am running x86 over here so others may be able to confirm. -- Regards, Mick signature.asc Description: This is a digitally signed message part.

Re: [gentoo-user] Re: qt3support USE flag. Is it needed now?

2010-10-08 Thread Arttu V.
On 10/8/10, Nikos Chantziaras rea...@arcor.de wrote: One thing I don't get is why this seems to worry you. I don't see you complaining about packages needing the libsamplerate or opengl USE flags... :-P Don't give them any ideas! Soon Gentoo devs will be revealing following new USE flags,

  1   2   3   4   5   6   >