Re: [gentoo-user] dev-qt/qtwebkit-5.4.0

2015-02-03 Thread Alec Ten Harmsel
I've never had qtwebkit fail to build (at least not recently), what's the exact error? Can you post the output of `emerge --info dev-qt/qtwebkit` as well? Alec On 02/03/2015 05:58 AM, Stefan G. Weichinger wrote: dev-qt/qtwebkit does not compile for me ... not with gcc 4.8.4 or 4.9.2

[gentoo-user] dev-qt/qtwebkit-5.4.0

2015-02-03 Thread Stefan G. Weichinger
dev-qt/qtwebkit does not compile for me ... not with gcc 4.8.4 or 4.9.2 ... before I file a bug @ b.g.o ... anyone else?

[gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-25 Thread Dale
Howdy, Doing some updates and ran into this. Anyone else having this problem? I can post more info if needed but thought this would get it off to a start. /var/tmp/portage/dev-qt/qtwebkit-5.6.0/work/qtwebkit-opensource-src-5.6.0/Source/JavaScriptCore//.obj/API/JSValueRef.o: In function

Re: [gentoo-user] dev-qt/qtwebkit-5.4.0

2015-02-03 Thread Stefan G. Weichinger
Am 03.02.2015 um 12:27 schrieb Alec Ten Harmsel: I've never had qtwebkit fail to build (at least not recently), what's the exact error? Can you post the output of `emerge --info dev-qt/qtwebkit` as well? hmmm, yes, I would like to ... but now it worked! I had it fail 3 times already ... maybe

Re: [gentoo-user] Calibre Update Problems

2013-05-09 Thread Neil Bothwick
On Thu, 9 May 2013 21:28:40 +0100, Peter Humphrey wrote: $ eix -c qtwebkit [I] dev-qt/qtwebkit (4.8.4(4){tbz2}@08/05/13): The WebKit module for the Qt toolkit $ qfile /usr/lib64/qt4/libQtWebKit.so.4.9.3 dev-qt/qtwebkit (/usr/lib64/qt4/libQtWebKit.so.4.9.3) Why the mismatched version

Re: [gentoo-user] Calibre Update Problems

2013-05-09 Thread Silvio Siefke
. $ eix -c qtwebkit [I] dev-qt/qtwebkit (4.8.4(4){tbz2}@08/05/13): The WebKit module for the Qt toolkit Eix i not use, can not follow the command. Maybe equery: siefke@gentoo-mobile : ~ $ equery l qtwebkit * Searching for qtwebkit ... [IP-] [ ] dev-qt/qtwebkit-4.8.4:4 $ equery f qtwebkit

[gentoo-user] PyQt5 depends on qtwebkit[printsupport]?

2015-06-22 Thread v_2e
Hello! I noticed that dev-python/PyQt5-5.4.1.ebuild requires the dev-qt/qtwebkit package to be built with the printsupport USE-flag even when the PyQt5 itself has this USE-flag turned OFF. Is this really necessary? Vladimir - v...@ukr.net

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Dale
Andrés Becerra Sandoval wrote: > > > > > ​Dale, > > Do you have debugging activated (ggdb in make.conf) ? > > If yes, turn it off for qtwebkit! > ​ > > -- > Andrés Becerra Sandoval > I didn't recognise that flag but looked to be sure, it's not t

Re: [gentoo-user] Update to dev-libs/icu-51.1 results in borked Dolphin

2013-04-28 Thread Mick
On Sunday 28 Apr 2013 14:50:58 Mick wrote: On Sunday 28 Apr 2013 13:21:35 Marc Joliet wrote: I have to admit, I'm a bit confused. I was going to suggest rebuilding QtWebKit, because of the undefined references and other warnings above, but I didn't rebuild it myself after upgrading icu

[gentoo-user] Re: dev-qt/qtwebkit-5.4.0

2015-02-03 Thread Jörg Schaible
Hi Stefan, Stefan G. Weichinger wrote: Am 03.02.2015 um 12:27 schrieb Alec Ten Harmsel: I've never had qtwebkit fail to build (at least not recently), what's the exact error? Can you post the output of `emerge --info dev-qt/qtwebkit` as well? hmmm, yes, I would like to ... but now

Re: [gentoo-user] Re: Well, I went about updating my system again. (day 6)

2016-12-07 Thread Alan McKinnon
e-mail a good deal > more than I feel comfortable posting. It's still the problem as before, you have a blocker due to incompatible USE: > tortoise ~ # emerge -avuND world<<< copied verbatim, seems > equivalent to what my script has anyway [snip] > [blocks B

Re: [gentoo-user] Package conflict while trying to emerge chromium

2015-02-13 Thread Alec Ten Harmsel
On 02/13/2015 01:02 PM, Gevisz wrote: These your suggestions actually forced me to delay the answer, as I needed time to check which of my application packages depend on qtwebkit and if I really need gstreamer. My bad. That's why I prefaced my response with (emphasis on think) - I don't have

Re: [gentoo-user] Calibre Update Problems

2013-05-09 Thread Paul Hartman
On Thu, May 9, 2013 at 3:28 PM, Peter Humphrey pe...@humphrey.ukfsn.org wrote: I'm puzzled by the following, which I checked to compare with the import error you quoted: $ eix -c qtwebkit [I] dev-qt/qtwebkit (4.8.4(4){tbz2}@08/05/13): The WebKit module for the Qt toolkit $ equery f

Re: [gentoo-user] Package conflict while trying to emerge chromium

2015-02-13 Thread Gevisz
-qt/qtwebkit-4.8.5:4/4::gentoo, installed) ^ It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected

Re: [gentoo-user] Calibre Update Problems

2013-05-09 Thread Peter Humphrey
problem, but have you run python- updater? I did that just now and it's rebuilding 16 packages, including PyQt4. Not the same as QtWebKit I know, but I'm clutching at straws now. Any time I suspect an inconsistency in my system I run python-updater, then perl-cleaner, then revdep-rebuild

[gentoo-user] Re: Re: dev-qt/qtwebkit-5.4.0

2015-02-06 Thread Jörg Schaible
cleaning the fans work wonders. Good suggestion, will check tmrw and clean the fans as well. It gave internal compiler error afai remember. How much free memory do you have, and are you building with debug symbols? qtwebkit:5 is exceptionally hungry, and I've seen it hit by the kernel OOM killer

Re: [gentoo-user] Re: dev-qt/qtwebkit-5.4.0

2015-02-06 Thread Stefan G. Weichinger
. Good suggestion, will check tmrw and clean the fans as well. It gave internal compiler error afai remember. How much free memory do you have, and are you building with debug symbols? qtwebkit:5 is exceptionally hungry, and I've seen it hit by the kernel OOM killer a lot. I removed one

Re: [gentoo-user] Package conflict while trying to emerge chromium

2015-02-13 Thread Peter Humphrey
On Thursday 12 February 2015 09:02:33 Alec Ten Harmsel wrote: I think (emphasis on the think) that qtwebkit needs libxml2 with -icu, and chromium needs libxml2 with +icu. As far as I can tell from reading a couple bug reports, it looks like you can rebuild qtwebkit with -gstreamer (since

Re: [gentoo-user] Package conflict while trying to emerge chromium

2015-02-13 Thread Hinnerk van Bruinehsen
) ^^^ (dev-libs/libxml2-2.9.2:2/2::gentoo, installed) pulled in by dev-libs/libxml2:2[!icu?] required by (dev-qt/qtwebkit-4.8.5:4/4::gentoo, installed

[gentoo-user] Re: dev-qt/qtwebkit-5.4.0

2015-02-05 Thread Michael Palimaka
the fans as well. It gave internal compiler error afai remember. How much free memory do you have, and are you building with debug symbols? qtwebkit:5 is exceptionally hungry, and I've seen it hit by the kernel OOM killer a lot.

Re: [gentoo-user] Update to dev-libs/icu-51.1 results in borked Dolphin

2013-04-28 Thread Mick
On Sunday 28 Apr 2013 13:21:35 Marc Joliet wrote: I have to admit, I'm a bit confused. I was going to suggest rebuilding QtWebKit, because of the undefined references and other warnings above, but I didn't rebuild it myself after upgrading icu, and various KDE software I have (that depends

Re: [gentoo-user] Package conflict while trying to emerge chromium

2015-02-12 Thread Alec Ten Harmsel
, installed) pulled in by dev-libs/libxml2:2[!icu?] required by (dev-qt/qtwebkit-4.8.5:4/4::gentoo, installed) ^ It may be possible to solve this problem by using

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-29 Thread Dale
Dale wrote: > Howdy, > > Doing some updates and ran into this. Anyone else having this problem? > I can post more info if needed but thought this would get it off to a > start. > > SNIP > > Thanks. > > Dale > > :-) :-) > > Seems I'm not alone and it is a bug.

Re: [gentoo-user] Package conflict while trying to emerge chromium

2015-02-13 Thread Gevisz
) ^^^ (dev-libs/libxml2-2.9.2:2/2::gentoo, installed) pulled in by dev-libs/libxml2:2[!icu?] required by (dev-qt/qtwebkit-4.8.5:4/4::gentoo, installed

Re: [gentoo-user] Package conflict while trying to emerge chromium

2015-02-13 Thread Gevisz
in the ._cfg0002_package.use file as the recommendation to insert it to the package.use. But it is odd, as the qtwebkit package was by default built with -ice USE flag and that created the blocker. This situation would not appear if instead of the following, actual insertion into the ._cfg0002_package.use file

Re: [gentoo-user] Help installing skype

2016-02-25 Thread David Haller
4(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] > required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for > merge) > ^ [..] > (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed) pulled in by >dev-libs/l

Re: [gentoo-user] Help installing skype

2016-02-25 Thread allan gottlieb
pulled >> in by >> >> dev-libs/libxml2:2[!icu?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] >> required by (dev-qt/qtwebki

Re: [gentoo-user] KDE 4.2: Emerge of ksysguard and ksmserver failed

2009-01-29 Thread Tomas Linhart
Everything is going fine now. The problem was that /usr/lib64/qt4/libQtWebKit.so.4 was symlinked to QtWebkit 4.5 library and that was the reason why some symbols could not be found. After correcting the symlink the problem disappeared. However, it seems strange to me, because I have tried

Re: [gentoo-user] Re: dev-qt/qtwebkit-5.4.0

2015-02-03 Thread Stefan G. Weichinger
Am 03.02.2015 um 20:30 schrieb Jörg Schaible: Consider a memcheck. Arbitrary failures while the CPU is high is often because some component starts dying. Sometimes cleaning the fans work wonders. Good suggestion, will check tmrw and clean the fans as well. It gave internal compiler error

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-29 Thread Peter Humphrey
On Thursday 28 Apr 2016 16:53:43 waltd...@waltdnes.org wrote: > On Thu, Apr 28, 2016 at 10:44:34AM +0100, Peter Humphrey wrote > > > proc/proc procdefaults0 0 > > shm /dev/shmtmpfs nodev,nosuid0 0 > > > > Not sure about

Re: [gentoo-user] Update to dev-libs/icu-51.1 results in borked Dolphin

2013-04-28 Thread Alan McKinnon
On 28/04/2013 17:46, Mick wrote: On Sunday 28 Apr 2013 14:50:58 Mick wrote: On Sunday 28 Apr 2013 13:21:35 Marc Joliet wrote: I have to admit, I'm a bit confused. I was going to suggest rebuilding QtWebKit, because of the undefined references and other warnings above, but I didn't rebuild

Re: [gentoo-user] Re: has anyone tried KDE5?

2014-10-05 Thread Volker Armin Hemmann
]: https://dot.kde.org/2013/09/04/kde-release-structure-evolves ok, at the moment you can't even install this mess: merge: there are no ebuilds built with USE flags to satisfy =dev-qt/qtwebkit-5.3.2:5[debug=,widgets]. !!! One of the following packages is required to complete your request: - dev-qt

[gentoo-user] retext, PyQt, QtPrintSupport, and QObject

2017-02-08 Thread Grant Edwards
run: $ retext Traceback (most recent call last): File "/usr/lib64/python3.4/site-packages/ReText/__init__.py", line 16, in from PyQt5 import QtCore, QtPrintSupport, QtGui, QtWidgets, QtWebKit, QtWebKitWidgets ImportError: cannot import name 'QtPrintSupport'

[gentoo-user] Well, I went about updating my system again. (day 6)

2016-12-07 Thread Alan Grimes
/2::gentoo, installed) dev-libs/icu:0/58.1=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.7:4

Re: [gentoo-user] necessary use flgas

2015-06-23 Thread David Haller
others print about 5 pages for me in ~10 years. Why would I want cups? And BTW: qtwebkit:5 compiles just fine without leveldb (with a little -D help)... --- /usr/portage/dev-qt/qtwebkit/qtwebkit-5.4.2.ebuild 2015-06-17 17:24:04.0 +0200 +++ /usr/local/portage/dev-qt/qtwebkit/qtwebkit

[gentoo-user] Re: has anyone tried KDE5?

2014-10-06 Thread Michael Palimaka
the 5.3.0 release. Best regards, Michael [1]: https://dot.kde.org/2013/09/04/kde-release-structure-evolves ok, at the moment you can't even install this mess: merge: there are no ebuilds built with USE flags to satisfy =dev-qt/qtwebkit-5.3.2:5[debug=,widgets]. !!! One of the following

Re: [gentoo-user] Re: has anyone tried KDE5?

2014-10-06 Thread Volker Armin Hemmann
is expected in the main tree in about a week, after the 5.3.0 release. Best regards, Michael [1]: https://dot.kde.org/2013/09/04/kde-release-structure-evolves ok, at the moment you can't even install this mess: merge: there are no ebuilds built with USE flags to satisfy =dev-qt/qtwebkit

Re: [gentoo-user] Re: has anyone tried KDE5?

2014-10-07 Thread Volker Armin Hemmann
is expected in the main tree in about a week, after the 5.3.0 release. Best regards, Michael [1]: https://dot.kde.org/2013/09/04/kde-release-structure-evolves ok, at the moment you can't even install this mess: merge: there are no ebuilds built with USE flags to satisfy =dev-qt/qtwebkit

Re: [gentoo-user] libreoffice cannot use oxygen theme

2013-08-19 Thread Wang Xuerui
output usually forces me into emerging it every 2 weeks or so. And just consider how much CPU cycles are lost in frequent qtwebkit, webkit-gtk and chromium rebuilds...

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-26 Thread Dale
Dale wrote: > Howdy, > > Doing some updates and ran into this. Anyone else having this problem? > I can post more info if needed but thought this would get it off to a > start. > > > > <<< SNIP >>> > > Anyone else running into this? Anything obvious sticking out? > > Thanks. > > Dale > > :-)

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Dale
Michael Mol wrote: > I have my system automatically update nightly, and check the build results in > the morning. If there's a persistent build error for a couple days, I file a > bug report. That's my threshold, anyway. > This started on Sunday. So it has met that part anyway. Since I run a

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Peter Humphrey
On Tuesday 26 Apr 2016 18:50:41 Dale wrote: --->8 > I synced again and was hoping I either caught the tree in the middle of > some change over with the last sync or whatever it is would have a fix > by now. Well, still the same error as before. > > Anyone have any ideas on the cause of this?

[gentoo-user] Re: Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-28 Thread walt
On Tue, 26 Apr 2016 18:50:41 -0500 Dale wrote: > Dale wrote: > > Howdy, > > > > Doing some updates and ran into this. Anyone else having this > > problem? I can post more info if needed but thought this would get > > it off to a start. > > > > > > > > <<< SNIP >>> > > > >

Re: [gentoo-user] Re: Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-28 Thread Dale
walt wrote: > On Tue, 26 Apr 2016 18:50:41 -0500 > Dale wrote: > >> Dale wrote: >>> Howdy, >>> >>> Doing some updates and ran into this. Anyone else having this >>> problem? I can post more info if needed but thought this would get >>> it off to a start. >>> >>> >>> >>>

Re: [gentoo-user] GCC 5.4.0

2017-04-24 Thread Peter Humphrey
On Monday 24 Apr 2017 14:47:32 Mick wrote: > On Monday 24 Apr 2017 14:36:01 Peter Humphrey wrote: > > Speaking of long emerge times, so far this box has spent nearly six > > hours on two systems simultaneously (one being a chroot for a slower > > machine) and still hasn't f

Re: [gentoo-user] GCC 5.4.0

2017-04-24 Thread Mick
On Monday 24 Apr 2017 14:36:01 Peter Humphrey wrote: > Speaking of long emerge times, so far this box has spent nearly six hours on > two systems simultaneously (one being a chroot for a slower machine) and > still hasn't finished. And qtwebkit has just failed; I'd better look into >

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Andrés Becerra Sandoval
er ways but still found nothing helpful, as in > > a solution. > > > > I'll give it another day or two and if after another sync the problem > > remains, I'll file a roach report. > > I have my system automatically update nightly, and check the build results > in > the morning. If there's a persistent build error for a couple days, I file > a > bug report. That's my threshold, anyway. > > -- > :wq ​Dale, Do you have debugging activated (ggdb in make.conf) ? If yes, turn it off for qtwebkit! ​ -- Andrés Becerra Sandoval

Re: [gentoo-user] Well, I went about updating my system again. (day 6)

2016-12-07 Thread Alan Grimes
>> [ebuild U ] kde-apps/kde-meta-16.08.3:5::gentoo [16.08.1:5::gentoo] >> 0 KiB >> [blocks B ] > ("> media-libs/phonon-gstreamer-4.9.0) >> quickpkg qtwebkit and phonon-gstreamer )so you can easily put them back >> if needed), unmerge both then do a p

Re: [gentoo-user] Well, I went about updating my system again. (day 6)

2016-12-07 Thread Alan McKinnon
wouldn't waste enough of the user's time... >>> >>> >>> [ebuild U ] kde-apps/kde-meta-16.08.3:5::gentoo [16.08.1:5::gentoo] >>> 0 KiB >>> [blocks B ] >> (">> media-libs/phonon-gstreamer-4.9.0) >>> quickpkg qtwebkit and p

Re: [gentoo-user] Re: dev-qt/qtwebkit-5.4.0

2015-02-04 Thread Stefan G. Weichinger
Am 03.02.2015 um 22:07 schrieb Stefan G. Weichinger: Am 03.02.2015 um 20:30 schrieb Jörg Schaible: Consider a memcheck. Arbitrary failures while the CPU is high is often because some component starts dying. Sometimes cleaning the fans work wonders. Good suggestion, will check tmrw and

Re: [gentoo-user] This nite's switch to full multilib

2015-03-30 Thread Peter Humphrey
qt3support dev-qt/qtopengl qt3support dev-qt/qtsqlmysql qt3support dev-qt/qtwebkit icu (Package.use is the only place where qt occurs.) -- Rgds Peter.

Re: [gentoo-user] This nite's switch to full multilib

2015-03-29 Thread Alan McKinnon
On 29/03/2015 19:53, Stefan G. Weichinger wrote: On 29.03.2015 19:30, Mick wrote: I went through that exercise about a month ago, and I needed this: /etc/portage/package.use/abi_x86_32: =dev-qt/qtwebkit-4.8.6-r1:4 abi_x86_32 =dev-qt/qtgui-4.8.6-r1:4 abi_x86_32 =dev-qt/qtdbus-4.8.6-r1:4

Re: [gentoo-user] This nite's switch to full multilib

2015-03-29 Thread Stefan G. Weichinger
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On 29.03.2015 19:30, Mick wrote: I went through that exercise about a month ago, and I needed this: /etc/portage/package.use/abi_x86_32: =dev-qt/qtwebkit-4.8.6-r1:4 abi_x86_32 =dev-qt/qtgui-4.8.6-r1:4 abi_x86_32 =dev-qt/qtdbus-4.8.6-r1:4

Re: [gentoo-user] Re: Using KDE apps in a non KDE environment

2015-10-02 Thread Neil Bothwick
/htdig, > qtcore-4.8.6-r4, 2 versions of qtgui, qt3support, qtwebkit, libdbusmenu, etc. That's because Okular is not a PDF reader, it's a "Universal document viewer", so it needs to support a lot of formats and protocols. That does mean that if you need a simple PDF reader and don

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Dale
Peter Humphrey wrote: > On Tuesday 26 Apr 2016 18:50:41 Dale wrote: > > --->8 > >> I synced again and was hoping I either caught the tree in the middle of >> some change over with the last sync or whatever it is would have a fix >> by now. Well, still the same error as before. >> >> Anyone have

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-05-01 Thread Dale
If anyone runs into this, here is a patch that works. Should be attached. It worked here at least. Careful if you do copy and paste tho. It seems copy and paste gave me some trouble. I had to open it with nano -w to get it to work right. It seems to lose a indention in there. I think it was

Re: [gentoo-user] GCC 5.4.0

2017-04-24 Thread Peter Humphrey
being a chroot for a slower > > > machine) and still hasn't finished. And qtwebkit has just failed; I'd > > > better look into that. > > > > I've had the odd rebuild failure here & there, don't bother re-emerging > > it until revdep-rebuild has finished. Any depe

Re: [gentoo-user] Qt-4.8.7 bug

2017-05-19 Thread Peter Humphrey
tly, a revdep-rebuild fixes it: revdep-rebuild -- library='libQtCore.so.4' 71 packages! See you in the morning - I don't intend to sit and wait while the likes of qtwebkit and libreoffice compiling. -- Regards Peter

Re: [gentoo-user] Calibre Update Problems

2013-05-09 Thread Silvio Siefke
Hello, i have run revdep-build now clean, say me something from sigel, but its not installed. I have run emerge -e system, run clean without errors. I have clean /usr/local/* complete. But the mistake is ever the same, i think its QtWebkit but im not sure. When i run calibre i become: siefke

[gentoo-user] Package conflict while trying to emerge chromium

2015-02-12 Thread Gevisz
[!icu?] required by (dev-qt/qtwebkit-4.8.5:4/4::gentoo, installed) ^ It may be possible to solve this problem by using package.mask to prevent one of those packages from

Re: [gentoo-user] This nite's switch to full multilib

2015-03-29 Thread Mick
do not seem capable to overcome yet. KDE wants qt 4.8.5 installed which is blocking qt 4.8.6. How did you go about overcoming this? I went through that exercise about a month ago, and I needed this: /etc/portage/package.use/abi_x86_32: =dev-qt/qtwebkit-4.8.6-r1:4 abi_x86_32 =dev-qt

Re: [gentoo-user] Update to dev-libs/icu-51.1 results in borked Dolphin

2013-04-28 Thread Mick
On Sunday 28 Apr 2013 17:44:25 Alan McKinnon wrote: On 28/04/2013 17:46, Mick wrote: On Sunday 28 Apr 2013 14:50:58 Mick wrote: On Sunday 28 Apr 2013 13:21:35 Marc Joliet wrote: I have to admit, I'm a bit confused. I was going to suggest rebuilding QtWebKit, because of the undefined

Re: [gentoo-user] Update to dev-libs/icu-51.1 results in borked Dolphin

2013-04-28 Thread staticsafe
On 4/28/2013 16:23, Mick wrote: On Sunday 28 Apr 2013 17:44:25 Alan McKinnon wrote: On 28/04/2013 17:46, Mick wrote: On Sunday 28 Apr 2013 14:50:58 Mick wrote: On Sunday 28 Apr 2013 13:21:35 Marc Joliet wrote: I have to admit, I'm a bit confused. I was going to suggest rebuilding QtWebKit

Re: [gentoo-user] Update to dev-libs/icu-51.1 results in borked Dolphin

2013-04-28 Thread Alan McKinnon
On 28/04/2013 22:23, Mick wrote: On Sunday 28 Apr 2013 17:44:25 Alan McKinnon wrote: On 28/04/2013 17:46, Mick wrote: On Sunday 28 Apr 2013 14:50:58 Mick wrote: On Sunday 28 Apr 2013 13:21:35 Marc Joliet wrote: I have to admit, I'm a bit confused. I was going to suggest rebuilding QtWebKit

Re: [gentoo-user] This nite's switch to full multilib

2015-03-29 Thread Alan McKinnon
, that I do not seem capable to overcome yet. KDE wants qt 4.8.5 installed which is blocking qt 4.8.6. How did you go about overcoming this? I went through that exercise about a month ago, and I needed this: /etc/portage/package.use/abi_x86_32: =dev-qt/qtwebkit-4.8.6-r1:4 abi_x86_32 =dev

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Dale
ibs/glibc-2.23-r2:2.2 [-P-] [ -] sys-libs/glibc-:2.2 root@fireball / # Yea, I'm using a old kernel. I haven't rebooted in a while now. I just wonder what that glibc 2.23-r2 would be like?? Anyone here took a drive around the block with that version? I just synced again. Going to see if anything changes or not but I doubt it will. I didn't see any changes to the qtwebkit ebuild. Dale :-) :-)

Re: [gentoo-user] Update to dev-libs/icu-51.1 results in borked Dolphin

2013-04-28 Thread Marc Joliet
- I/usr/include/KDE -I/usr/include/qt4/QtXmlPatterns -I/usr/include/qt4/QtXml - I/usr/include/qt4/QtWebKit -I/usr/include/qt4/QtUiTools - I/usr/include/qt4/QtTest -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtSql - I/usr/include/qt4/QtScriptTools -I/usr/include/qt4/QtScript - I/usr/include/qt4

Re: [gentoo-user] libreoffice cannot use oxygen theme

2013-08-19 Thread Alan McKinnon
them, but the length of @preserved-rebuild output usually forces me into emerging it every 2 weeks or so. And just consider how much CPU cycles are lost in frequent qtwebkit, webkit-gtk and chromium rebuilds... webkit* updates have slowed down recently so I'm not too bothered about

Re: [gentoo-user] This nite's switch to full multilib

2015-03-29 Thread Alan McKinnon
is blocking qt 4.8.6. How did you go about overcoming this? I went through that exercise about a month ago, and I needed this: /etc/portage/package.use/abi_x86_32: =dev-qt/qtwebkit-4.8.6-r1:4 abi_x86_32 =dev-qt/qtgui-4.8.6-r1:4 abi_x86_32 =dev-qt/qtdbus-4.8.6-r1:4 abi_x86_32 =dev-qt

Re: [gentoo-user] Ruby is infesting my machine

2015-07-07 Thread Andrew Lowe
this infestation from happening? Regards, Andrew To close off my original question, the problem was related to qt-creator. I had 3.2.2 installed and it wanted to update to 3.4.1. 3.4.1 has a dependency on qtwebkit, which has a dependency on ruby, hence

Re: [gentoo-user] Help installing skype

2016-02-24 Thread allan gottlieb
x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuil

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-28 Thread Peter Humphrey
On Wednesday 27 Apr 2016 17:52:07 Dale wrote: > I seem to recall glibc being one of those packages that you can't > downgrade. Sort of chicken to upgrade, just in case the problem gets > even worse. You could back your system partitions up first, to have a system to revert to if necessary. I've

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Michael Mol
On Wednesday, April 27, 2016 12:33:43 PM Dale wrote: > Michael Mol wrote: > > I have my system automatically update nightly, and check the build results > > in the morning. If there's a persistent build error for a couple days, I > > file a bug report. That's my threshold, anyway. > > This

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Bill Kenworthy
On 28/04/16 01:33, Dale wrote: > Michael Mol wrote: >> I have my system automatically update nightly, and check the build results >> in >> the morning. If there's a persistent build error for a couple days, I file a >> bug report. That's my threshold, anyway. >> > > > This started on Sunday.

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-28 Thread waltdnes
On Thu, Apr 28, 2016 at 10:44:34AM +0100, Peter Humphrey wrote > proc/proc procdefaults0 0 > shm /dev/shmtmpfs nodev,nosuid0 0 > > Not sure about those last two - are they still needed nowadays? I'm running OK without

Re: [gentoo-user] Failed to emerge dev-qt/qtwebkit-5.6.0

2016-04-27 Thread Michael Mol
On Wednesday, April 27, 2016 08:11:05 AM Dale wrote: > Peter Humphrey wrote: > > On Tuesday 26 Apr 2016 18:50:41 Dale wrote: > > > > --->8 > > > >> I synced again and was hoping I either caught the tree in the middle of > >> some change over with the last sync or whatever it is would have a fix

Re: [gentoo-user] Well, I went about updating my system again. (day 6)

2016-12-07 Thread Alan McKinnon
B ] (" media-libs/phonon-gstreamer-4.9.0) quickpkg qtwebkit and phonon-gstreamer )so you can easily put them back if needed), unmerge both then do a proper world update: emerge -avuND world and let portage figure out the best way to do it. And don;t use that bloody jackhammer script

Re: [gentoo-user] GCC 5.4.0

2017-04-24 Thread J. Roeleveld
gt;> > hours on two systems simultaneously (one being a chroot for a >slower >> > machine) and still hasn't finished. And qtwebkit has just failed; >I'd >> > better look into that. >> >> I've had the odd rebuild failure here & there, don't bother >re-emerging it

Re: [gentoo-user] GCC 5.4.0

2017-04-24 Thread Peter Humphrey
On Monday 24 Apr 2017 14:47:32 Mick wrote: > On Monday 24 Apr 2017 14:36:01 Peter Humphrey wrote: > > Speaking of long emerge times, so far this box has spent nearly six > > hours on two systems simultaneously (one being a chroot for a slower > > machine) and still hasn't f

Re: [gentoo-user] GCC 5.4.0

2017-04-24 Thread Peter Humphrey
to make exceptions for them. It was easier just to put the options into an alias: $ alias emerj='sudo emerge --jobs=24 --load-average=48 --keep-going --nospinner' Speaking of long emerge times, so far this box has spent nearly six hours on two systems simultaneously (one being a chroot for

Re: [gentoo-user] Re: Qt-4.8.7 bug

2017-05-19 Thread Peter Humphrey
6-r2, until the bug is resolved. > > > > Apparently, a revdep-rebuild fixes it: revdep-rebuild -- > > library='libQtCore.so.4' > > > > 71 packages! See you in the morning - I don't intend to sit and wait > > while the likes of qtwebkit and libreoffice compiling.

Re: [gentoo-user] Re: Qt-4.8.7 bug

2017-05-20 Thread Mick
a fix for this? > > > > > > > > I haven't run an update yet, but thank you for bringing this to our > > > > attention. I'll stay put on 4.8.6-r2, until the bug is resolved. > > > > > > Apparently, a revdep-rebuild fixes it: revdep-rebuild -- > > >

Re: [gentoo-user] Re: Qt-4.8.7 bug

2017-05-20 Thread Mick
t; > > > https://bugs.gentoo.org/show_bug.cgi?id=618922 > > > > > > > > > > > > Has anyone found a fix for this? > > > > > > > > > > I haven't run an update yet, but thank you for bringing this to our > > > >

[gentoo-user] Re: Qt-4.8.7 bug

2017-05-19 Thread Kai Krakow
this? > > > > I haven't run an update yet, but thank you for bringing this to our > > attention. I'll stay put on 4.8.6-r2, until the bug is resolved. > > Apparently, a revdep-rebuild fixes it: revdep-rebuild -- > library='libQtCore.so.4' > > 71 packag

Re: [gentoo-user] Ruby - 3 versions - seriously????

2017-09-02 Thread Peter Humphrey
ge for something, obviously Python wasn't good > enough > > Thoughts on the magically multiplying Rubies would be greatly > appreciated, > > Andrew Won't portage let you remove any of them? On my system only qtwebkit and webkit-gtk need ruby, and they seem

Re: [gentoo-user] cannot emerge @preserved-rebuild due to removed package...

2015-03-14 Thread Meino . Cramer
in by: * dev-qt/qtwebkit-4.8.5 * * =app-text/texlive-core-2014 pulled in by: * dev-texlive/texlive-basic-2014 * * =app-text/texlive-core-2014 pulled in by: * dev-texlive/texlive-latex-2014 * * dev-qt/qtgui:4 pulled in by: * media-video/smplayer-14.9.0-r1 * * dev-qt/qtgui:4

Re: [gentoo-user] Re: USE flags handling

2014-07-30 Thread Walter Dnes
pdf reader, I need... phonon vlc (or gstreamer) libmpeg libmad net-dns/libidn dev-qt/qtwebkit ...***FOR A STINKING PDF READER***. Here's the emerge -pv okular output with USE flag listings edited out... [d531][waltdnes][~] emerge -pv okular | sed s/USE.*$// These are the packages that would

Re: [gentoo-user] Re: USE flags handling

2014-07-30 Thread Volker Armin Hemmann
unicode Seems that if I want to emerge and use KDE's pdf reader, I need... phonon vlc (or gstreamer) libmpeg libmad net-dns/libidn dev-qt/qtwebkit ...***FOR A STINKING PDF READER***. Here's the emerge -pv okular okular is not a 'stinking pdf reader'. Nice try. But just like konqueror

Re: [gentoo-user] libreoffice cannot use oxygen theme

2013-08-18 Thread Wang Xuerui
) dev-db/sqlite-3.7.17 (icu ? dev-libs/icu) dev-lang/php-5.4.18 (intl ? dev-libs/icu) dev-lang/php-5.5.1-r1 (intl ? dev-libs/icu) dev-libs/boost-1.53.0 (icu ? =dev-libs/icu-3.6) dev-libs/libxml2-2.9.1-r1 (icu ? dev-libs/icu) dev-qt/qtcore-4.8.5 (icu ? =dev-libs/icu-49) dev-qt/qtwebkit-4.8.5 (icu

Re: [gentoo-user] libreoffice cannot use oxygen theme

2013-08-19 Thread Alan McKinnon
-4.8.5 (icu ? =dev-libs/icu-49) dev-qt/qtwebkit-4.8.5 (icu ? dev-libs/icu) dev-tex/bibtexu-3.71_p20130530 (=dev-libs/icu-4.4) media-libs/harfbuzz-0.9.18-r1 (icu ? dev-libs/icu) media-libs/libcdr-0.0.14 (dev-libs/icu) media-libs/libvisio-0.0.30 (dev-libs/icu) media-libs/raptor-2.0.9 (unicode ? dev

Re: [gentoo-user] Re: USE flags handling

2014-07-31 Thread J. Roeleveld
(or gstreamer) libmpeg libmad net-dns/libidn dev-qt/qtwebkit ...***FOR A STINKING PDF READER***. Here's the emerge -pv okular output with USE flag listings edited out... [d531][waltdnes][~] emerge -pv okular | sed s/USE.*$// These are the packages that would be merged

Re: [gentoo-user] Ruby is infesting my machine

2015-07-07 Thread Alan McKinnon
. Does anyone know how I can prevent this infestation from happening? Regards, Andrew To close off my original question, the problem was related to qt-creator. I had 3.2.2 installed and it wanted to update to 3.4.1. 3.4.1 has a dependency on qtwebkit, which has

[gentoo-user] libxml2 conflicts

2016-01-13 Thread James
xml2:2 (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, ebuild scheduled for merge) conflicts with dev-libs/libxml2:2[-icu,abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed) egrep libxml package.use =dev-libs/libxml2-2.9.1-r1 python >=dev-libs/libxml2-2.9.1-

Re: [gentoo-user] Help installing skype

2016-02-25 Thread Alan McKinnon
6_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) ^ >=dev-libs/libxml2-2.9.1-r4:2[abi_x86_32(-)?,abi

Re: [gentoo-user] Help installing skype

2016-02-26 Thread Mick
e/sys:>=dev-libs/libxml2-2.9.2 icu abi_x86_32 /etc/portage/package.use/clients:www-client/firefox system-cairo system-icu system-jpeg system-libvpx system-sqlite /etc/portage/package.use/xorg:>=dev-libs/icu-54.1-r1 abi_x86_32 /etc/portage/package.use/media:>=media-libs/harfbuzz-0.9.41 abi

[gentoo-user] The war continues.

2016-03-19 Thread Alan Grimes
ng Gentoo Every day now for ten years. This is an entirely New level of bullshit. =( Modest list of complete and utter FAIL: tortoise portage # tree -L 2 . ├── app-office │ └── texmacs-1.99.2-r1 ├── dev-libs │ ├── libcdio-0.93 │ └── libcdio-paranoia-0.93_p1 ├── dev-qt │ └── qtwebkit-5.5.

Re: [gentoo-user] conflict with same package, same USE

2017-06-02 Thread Hogren
;python2_7 python3_4 (-pypy) > (-pypy3) (-python3_5) (-python3_6)" > [ebuild N ] dev-qt/qtnetwork-5.6.2 USE="bindist ssl -connman > -debug -libproxy -networkmanager {-test}" > [ebuild U ] sys-libs/ldb-1.1.29-r1 [1.1.26] USE="ldap%* python%*" > [ebuild R

[gentoo-user] conflict with same package, same USE

2017-06-02 Thread Hogren
* python%*" [ebuild R] dev-qt/qtxmlpatterns-5.6.2 [ebuild R] dev-qt/qtwebkit-5.6.2 [ebuild R ~] net-misc/teamviewer-9.0.32150 [ebuild U ] net-fs/samba-4.5.10 [4.2.14] USE="-gpg% (-system-heimdal) -zeroconf%" [ebuild R] media-gfx/blender-2.72b-r4 [ebuild R

Re: Re: [gentoo-user] gst-plugins-bad-1.11.90 is blocking gst-plugins-base-1.12.3

2017-10-17 Thread Hubert Hauser
/5.7::gentoo, installed) pulled in by     ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)     ^ ^        ~dev-qt/qtgui-5.7

[gentoo-user] Help installing skype

2016-02-24 Thread allan gottlieb
-pax_kernel -plasma (-selinux)" [ebuild N ] dev-qt/qtwebkit-4.8.6-r1 USE="gstreamer jit (-aqua) -debug -exceptions -icu -pch" ABI_X86="32 (64) (-x32)" [nomerge ] gnome-base/gnome-3.16.0 [nomerge ] gnome-base/gnome-extra-apps-3.16.0 [nomerge ]

  1   2   >