[gentoo-user] Ruby's rdoc

2005-08-07 Thread David Corbin
Is Ruby's rdoc documentation installed with the ruby ebuild? ri18 doesn't seem to be able to find it. David -- gentoo-user@gentoo.org mailing list

[gentoo-user] Re: Understanding new ruby dependencies

2012-05-22 Thread Hans de Graaff
On Mon, 21 May 2012 20:52:01 -0700, Chris Stankevitz wrote: Question: Is is true that the RUBY dependencies listed in the above paste link are entirely due to adding documentation support (specifically rdoc)? If so, can I tell portage to not install the rdoc stuff? I have USE=-doc already

[gentoo-user] Re: dev-ruby/json-1.8.0

2014-06-06 Thread walt
On 06/06/2014 09:48 AM, Stephen Reynolds wrote: rdoc -o doc -t 'JSON Implementation for Ruby' -m README.rdoc snip ext/json/ext/generator/generator.c sh: rdoc: command not found You apparently have ruby19 and ruby20 installed, is this right? Do you have a version of ruby eselected? eselect

Re: [gentoo-user] Ruby's rdoc

2005-08-07 Thread David Corbin
On Sunday 07 August 2005 02:11 pm, David Corbin wrote: Is Ruby's rdoc documentation installed with the ruby ebuild? ri18 doesn't seem to be able to find it. I noticed that USE flags were -doc. I assume correcting this will make things better... -- gentoo-user@gentoo.org mailing list

[gentoo-user] USE ruby_targets_ruby20

2013-11-14 Thread Chris Stankevitz
a bunch of ruby_targets_ruby20 use flags in /etc/portage/package.use Thank you, Chris === The following USE changes are necessary to proceed: (see package.use in the portage(5) man page for more details) # required by dev-lang/ruby-2.0.0_p247-r1[rdoc] # required by dev-ruby/racc-1.4.9

Re: [gentoo-user] Ruby's rdoc

2005-08-07 Thread Michael Crute
Only with the doc use flag. Make sure you had that in there when you emerged ruby or re-emerge ruby with it. -MikeOn 8/7/05, David Corbin [EMAIL PROTECTED] wrote: Is Ruby's rdoc documentation installed with the ruby ebuild?ri18 doesn'tseem to be able to find it.David--gentoo-user@gentoo.org

Re: [gentoo-user] Ruby's rdoc

2005-08-07 Thread Michael Crute
Indeed it should.On 8/7/05, David Corbin [EMAIL PROTECTED] wrote: On Sunday 07 August 2005 02:11 pm, David Corbin wrote: Is Ruby's rdoc documentation installed with the ruby ebuild?ri18 doesn't seem to be able to find it.I noticed that USE flags were -doc.I assume correcting this will make things

Re: [gentoo-user] USE ruby_targets_ruby20

2013-11-14 Thread Mark David Dumlao
=ruby20 in make.conf. Thank you, Chris === The following USE changes are necessary to proceed: (see package.use in the portage(5) man page for more details) # required by dev-lang/ruby-2.0.0_p247-r1[rdoc] # required by dev-ruby/racc-1.4.9[ruby_targets_ruby20] =dev-ruby/rdoc-4.0.1-r1

[gentoo-user] Understanding new ruby dependencies

2012-05-21 Thread Chris Stankevitz
request caught my eye. Question: Is is true that the RUBY dependencies listed in the above paste link are entirely due to adding documentation support (specifically rdoc)? If so, can I tell portage to not install the rdoc stuff? I have USE=-doc already. Thank you, Chris

Re: [gentoo-user] ruby 22

2017-08-20 Thread allan gottlieb
On Sun, Aug 20 2017, Alec Ten Harmsel wrote: > On 08/20/2017 08:19 AM, allan gottlieb wrote: >> I am currently running ruby21 (ruby-2.1.9). >> All such versions of ruby are masked so this is clearly a mistake >> on my part. I was alerted to this error by dev-ruby/rdoc-4.2.

Re: [gentoo-user] Re: Understanding new ruby dependencies

2012-05-22 Thread Chris Stankevitz
On Mon, May 21, 2012 at 11:07 PM, Hans de Graaff gra...@gentoo.org wrote: Yes, this is true. We do this because normally ruby contains a copy of rdoc. We unbundle that and thus the external rdoc implementation is installed. Hans, Thank you, I understand. Apparently I have to add some

[gentoo-user] ruby 22

2017-08-20 Thread allan gottlieb
I am currently running ruby21 (ruby-2.1.9). All such versions of ruby are masked so this is clearly a mistake on my part. I was alerted to this error by dev-ruby/rdoc-4.2.0 failing to build on today's emerge --update @world After I do eselect ruby set ruby22 can I simply emerge --update

[gentoo-user] Circular dependencies...

2014-01-05 Thread meino . cramer
-2.0.0_p353:2.0 [1.8.7_p374:1.8, 1.9.3_p484:1.9] USE=berkdb doc gdbm ipv6 ncurses rdoc readline ssl -debug -examples -rubytests -socks5 -tk (-xemacs) [nomerge ] dev-ruby/json-1.8.0 [1.7.7] USE=doc {-test} RUBY_TARGETS=ruby18 ruby19 ruby20%* (-jruby) (-ree18%) [nomerge ]dev-ruby/rake

Re: [gentoo-user] Circular dependencies...

2014-01-05 Thread Khumba
, 4:ruby19] RUBY_TARGETS=(ruby20) [nomerge ] dev-lang/ruby-2.0.0_p353:2.0 [1.8.7_p374:1.8, 1.9.3_p484:1.9] USE=berkdb doc gdbm ipv6 ncurses rdoc readline ssl -debug -examples -rubytests -socks5 -tk (-xemacs) [nomerge ] dev-ruby/json-1.8.0 [1.7.7] USE=doc {-test

Re: [gentoo-user] Circular dependencies...

2014-01-06 Thread meino . cramer
! [nomerge ] virtual/rubygems-6:ruby20 [1:ruby18, 4:ruby19] RUBY_TARGETS=(ruby20) [nomerge ] dev-lang/ruby-2.0.0_p353:2.0 [1.8.7_p374:1.8, 1.9.3_p484:1.9] USE=berkdb doc gdbm ipv6 ncurses rdoc readline ssl -debug -examples -rubytests -socks5 -tk (-xemacs) [nomerge

Re: [gentoo-user] Re: RUBY_TARGETS and eselect ruby

2013-12-31 Thread Pavel Volkov
. Ok, I see. The only ruby-related packages I have installed are ruby, rubygems, rake, json, racc and rdoc, those are build-time-deps, so eselecting ruby21 will be ok for me.

Re: [gentoo-user] USE ruby_targets_ruby20

2013-11-15 Thread Chris Stankevitz
sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync =dev-ruby/rdoc-4.0.1-r1 ruby_targets_ruby20 # required by dev-ruby/rdoc-4.0.1-r1[ruby_targets_ruby20] # required by dev-lang/ruby-1.9.3_p448[rdoc] # required by dev-ruby/rubygems

Re: [gentoo-user] Re: dev-ruby/json-1.8.0

2014-06-08 Thread Stephen Reynolds
This is what I have. stephen #grep RUBY /etc/portage/make.conf RUBY_TARGETS=ruby20 stephen # ls -l /usr/bin/rdoc lrwxrwxrwx 1 root root 6 Jun 6 20:13 /usr/bin/rdoc - rdoc20 stephen # eselect ruby list Available Ruby profiles: [1] ruby19 (with Rubygems) [2] ruby20 (with Rubygems

[gentoo-user] Re: Understanding new ruby dependencies

2012-05-23 Thread Hans de Graaff
only. It might work, we just don't support it. :-) f) [your idea here] f) It should just have worked. I tried to be conservative and not add ruby19 in RUBY_TARGETS right away, but as you have noticed this causes problems for rdoc and friends. I'll add ruby19 to the default setting in the profile

Re: [gentoo-user] Re: Ruby is borked on my system

2014-06-27 Thread Ajai Khattri
not immediately clear which package that is from the output, but I suspect dev-ruby/rubygems? Re-emerging the packages still installed for ruby18 should fix this. I rebuiltd rubygems and the virtual but still no go. Then I rebuilt rdoc (which pulled in a bunch of other stuff) but now emerge world

Re: [gentoo-user] ruby 22

2017-08-20 Thread Stroller
> On 20 Aug 2017, at 15:19, allan gottlieb <gottl...@nyu.edu> wrote: > > I am currently running ruby21 (ruby-2.1.9). > All such versions of ruby are masked so this is clearly a mistake > on my part. I was alerted to this error by dev-ruby/rdoc-4.2.0 > failing to build on

[gentoo-user] useflag hell.

2016-02-28 Thread Alan Grimes
not compatible! dev-libs/klibc -custom-cflags #stupid missfeature; buggy as fuck too. media-video/mplayer -joystick #BOINC compatibility. net-misc/curl -gnutls # requires dead libraries: dev-libs/libusb -doc media-libs/fontconfig -doc media-sound/esound -doc dev-java/oracle-jdk-bin doc # kinda

Re: [gentoo-user] Re: Understanding new ruby dependencies

2012-05-23 Thread kwkhui
in this thread provides a pastebin link to back up this claim. Basically the newslot upgrade ruby 1.8.x - 1.9.x. For example, you can see that in ${PORTDIR}/dev-ruby/json/json-1.5.4-r1.ebuild there is the line PDEPEND= rdoc? ( =dev-ruby/rdoc-3.9.4[ruby_targets_ruby19] ) xemacs

[gentoo-user] advice on transitioning from package.use file to package.use directory

2015-08-31 Thread Alexander Kapshuk
e: cat package.use =dev-lang/python-2.7.9-r1 sqlite >=dev-ruby/json-1.8.2-r1 ruby_targets_ruby21 >=dev-ruby/racc-1.4.11 ruby_targets_ruby21 >=dev-ruby/rake-0.9.6-r1 ruby_targets_ruby21 >=dev-ruby/rdoc-4.0.1-r2 ruby_targets_ruby21 >=dev-ruby/rubygems-2.2.5-r1 ruby_targets_ruby21 >=med

[gentoo-user] distfiles contains extra files?

2014-08-13 Thread James
-user.pdf scrollkeeper-omf.dtd seamonkey-2.26.1-en-GB.xpi rdoc-4.0.1.gem readline62-004 rfc2307bis.schema-20140524 nmap-logo-64.png gobject-introspection-1.40.0.tar.xz._checksum_failure_.146ofr I guess I need enlightenment ? Also, in the past I have manually aged/pruned or size/prunded the disfiles dir

Re: [gentoo-user] ruby 22

2017-08-20 Thread Alec Ten Harmsel
On 08/20/2017 08:19 AM, allan gottlieb wrote: I am currently running ruby21 (ruby-2.1.9). All such versions of ruby are masked so this is clearly a mistake on my part. I was alerted to this error by dev-ruby/rdoc-4.2.0 failing to build on today's emerge --update @world After I do eselect

Re: [gentoo-user] Re: dev-ruby/json-1.8.0

2014-06-08 Thread Stephen Reynolds
Okay I am now using ruby19, This have solved my problem. Thanks stephen # eselect ruby list Available Ruby profiles: [1] ruby19 (with Rubygems) * [2] ruby20 (with Rubygems) stephen # ls -l /usr/bin/rdoclrwxrwxrwx 1 root root 6 Jun 8 11:45 /usr/bin/rdoc - rdoc19 stephen # grep RUBY

[gentoo-user] Ruby is borked on my system

2014-06-26 Thread Ajai Khattri
::gentoo (masked by: ~x86 keyword) - virtual/rubygems-5::gentoo (masked by: missing keyword) (dependency required by dev-ruby/rdoc-4.0.1-r1[-test] [installed]) (dependency required by dev-lang/ruby-2.0.0_p353[rdoc] [installed]) (dependency required by virtual/rubygems-6 [ebuild]) (dependency required

Re: [gentoo-user] advice on transitioning from package.use file to package.use directory

2015-08-31 Thread Todd Goodman
to > run. If the output is acceptable, it should be piped through to the > shell. > > Here is the contents of the original 'package.use' file: > > cat package.use > =dev-lang/python-2.7.9-r1 sqlite > >=dev-ruby/json-1.8.2-r1 ruby_targets_ruby21 > >=

Re: [gentoo-user] advice on transitioning from package.use file to package.use directory

2015-08-31 Thread Alexander Kapshuk
l 'package.use' file: >> >> cat package.use >> =dev-lang/python-2.7.9-r1 sqlite >> >=dev-ruby/json-1.8.2-r1 ruby_targets_ruby21 >> >=dev-ruby/racc-1.4.11 ruby_targets_ruby21 >> >=dev-ruby/rake-0.9.6-r1 ruby_targets_ruby21 >> >=dev-ruby/rdoc-4.0.1-r

[gentoo-user] Google or Firefox problem?

2005-08-07 Thread Ryan
Corbin wrote: Is Ruby's rdoc documentation installed with the ruby ebuild? ri18 doesn't seem to be able to find it. I noticed that USE flags were -doc. I assume correcting this will make things better... -- gentoo-user@gentoo.org mailing list

[gentoo-user] Re: Understanding new ruby dependencies

2012-05-23 Thread Hans de Graaff
. It is implicit. dev-lang/ruby:1.9 requires a new enough version of rdoc with this particular USE flag enabled. 2. If the answer to (1) is the gentoo system itself, then why doesn't the gentoo system itself update the USE_EXPAND by adding a reference to ruby19? It appears the gentoo system itself

Re: [gentoo-user] Routine update wants to install 3 version of Ruby + 50 others

2013-12-09 Thread Peter Humphrey
have the energy to sort out the mess. Just now I ran: $ sudo emerge -c dev-lang/ruby:1.8 dev-lang/ruby:1.9 dev-lang/ruby:2.0 json racc rake rdoc rubygems thin-provisioning-tools =virtual/rubygems-1 =virtual/rubygems-4 =virtual/rubygems-6 I'll reboot now and see if lvm2 can still mount my LVM

Re: [gentoo-user] Re: Routine update wants to install 3 version of Ruby + 50 others

2013-12-14 Thread Michael Orlitzky
to the default RUBY_TARGETS. If anything needs ruby, you get whatever version of ruby it wants (say, 1.9). But then the next time you emerge -puDN world, you pull in dev-lang/ruby-2.0 in a different slot. But ruby-2.0 needs rdoc, rake, and json with USE=ruby_targets_ruby20. Down the rabbit hole we go

[gentoo-user] Re: dev-ruby/json-1.8.0

2014-06-07 Thread walt
bothers you or where you would need help? Hi Hans. The annoying problems occur when updating ruby-related packages. For example, I (want to) use only ruby19: #grep RUBY /etc/portage/make.conf RUBY_TARGETS=ruby19 In spite of that, portage often insists on installing other versions of ruby, rdoc

[gentoo-user] Re: dev-ruby/json-1.8.0

2014-06-08 Thread Hans de Graaff
overall coverage for packages. Once ruby20 has caught up I think we'll move to a default of RUBY_TARGETS=ruby20 In spite of that, portage often insists on installing other versions of ruby, rdoc, rubygems, and you already know the others. Partially this was because we tried to solve another issue

Re: [gentoo-user] distfiles contains extra files?

2014-08-13 Thread Nilesh Govindrajan
(here's a sample from /usr/portage/distfiles): scons-2.3.0-user.html scons-2.3.0-user.pdf scrollkeeper-omf.dtd seamonkey-2.26.1-en-GB.xpi rdoc-4.0.1.gem readline62-004 rfc2307bis.schema-20140524 nmap-logo-64.png gobject-introspection-1.40.0.tar.xz._checksum_failure_.146ofr I guess I need

Re: [gentoo-user] distfiles contains extra files?

2014-08-13 Thread Peter Humphrey
from /usr/portage/distfiles): scons-2.3.0-user.html scons-2.3.0-user.pdf scrollkeeper-omf.dtd seamonkey-2.26.1-en-GB.xpi rdoc-4.0.1.gem readline62-004 rfc2307bis.schema-20140524 nmap-logo-64.png gobject-introspection-1.40.0.tar.xz._checksum_failure_.146ofr I guess I need enlightenment

Re: [gentoo-user] ruby 22

2017-08-21 Thread Alec Ten Harmsel
s [ebuild R]dev-ruby/test-unit-3.1.9 RUBY_TARGETS="(-ruby21%*)" [ebuild R]dev-ruby/rdoc-4.2.0 RUBY_TARGETS="(-ruby21%*)" [ebuild R]dev-ruby/minitest-5.8.4 RUBY_TARGETS="(-ruby21%*)" RUBY_TARGETS is set in the profiles

Re: [gentoo-user] Re: ruby 22

2017-08-22 Thread Raffaele Belardi
0.1.1-r1 requires dev-lang/ruby:2.1 >dev-ruby/power_assert-1.0.2 requires dev-lang/ruby:2.1 > dev-ruby/racc-1.4.14 requires dev-lang/ruby:2.1 > dev-ruby/rake-12.0.0 requires dev-lang/ruby:2.1 > dev-ruby/rdoc-5.1.0 re

Re: [gentoo-user] Re: ruby 22

2017-08-21 Thread John Covici
dev-ruby/minitest-5.10.3 requires dev-lang/ruby:2.1 dev-ruby/net-telnet-0.1.1-r1 requires dev-lang/ruby:2.1 dev-ruby/power_assert-1.0.2 requires dev-lang/ruby:2.1 dev-ruby/racc-1.4.14 requires dev-lang/ruby:2.1

Re: [gentoo-user] Re: ruby 22

2017-08-22 Thread John Covici
dev-ruby/racc-1.4.14 requires dev-lang/ruby:2.1 > > dev-ruby/rake-12.0.0 requires dev-lang/ruby:2.1 > >dev-ruby/rdoc-5.1.0 requires dev- > > lang/ruby:2.1 > > dev-ruby/rubygems-2.6.12 requires > > dev-lang

Re: [gentoo-user] Re: ruby 22

2017-08-22 Thread Alec Ten Harmsel
ssert-1.0.2 requires dev-lang/ruby:2.1 > > dev-ruby/racc-1.4.14 requires dev-lang/ruby:2.1 > > dev-ruby/rake-12.0.0 requires dev-lang/ruby:2.1 > > dev-ruby/rdoc-5.1.0 requires dev-lang/ruby:2.1 > > dev-ruby/rubygems-2.6.12 requires > > dev-lang/r

[gentoo-user] dev-ruby/json-1.8.0

2014-06-06 Thread Stephen Reynolds
-2009 by Adrian Thurston Ragel State Machine Compiler version 6.7 May 2011 Copyright (c) 2001-2009 by Adrian Thurston Writing version information for 1.8.0 rdoc -o doc -t 'JSON Implementation for Ruby' -m README.rdoc README.rdoc lib/json.rb lib/json/add/bigdecimal.rb lib/json/add/complex.rb lib/json

Re: [gentoo-user] resolv.conf is different after every reboot

2014-07-27 Thread Grand Duet
for more details) # required by dev-lang/ruby-1.9.3_p484[tk] # required by dev-ruby/rake-0.9.6[ruby_targets_ruby19] # required by dev-lang/ruby-2.0.0_p353 # required by dev-ruby/racc-1.4.9[ruby_targets_ruby20] # required by dev-ruby/rdoc-4.0.1-r1[ruby_targets_ruby19] =dev-lang/tk-8.5.15 threads

Re: [gentoo-user] Re: ruby 22

2017-08-22 Thread Neil Bothwick
requires dev-lang/ruby:2.1 > dev-ruby/maruku-0.7.3 requires dev-lang/ruby:2.1 > dev-ruby/minitest-5.10.3 requires > dev-lang/ruby:2.1 > dev-ruby/net-telnet-0.1.1-r1 requires dev-lang/ruby:2.1 >dev-ruby

Re: [gentoo-user] Re: ruby 22

2017-08-22 Thread John Covici
uku-0.7.3 requires dev-lang/ruby:2.1 > dev-ruby/minitest-5.10.3 requires > dev-lang/ruby:2.1 > dev-ruby/net-telnet-0.1.1-r1 requires dev-lang/ruby:2.1 > dev-ruby/power_assert-1.0.2 requires dev-lang/ruby:2.1 > dev-ruby/racc-1.4.14 requires dev-lang/ruby:2.

Re: [gentoo-user] resolv.conf is different after every reboot (Got an idea!)

2014-07-27 Thread Grand Duet
package.use in the portage(5) man page for more details) # required by dev-lang/ruby-1.9.3_p484[tk] # required by dev-ruby/rake-0.9.6[ruby_targets_ruby19] # required by dev-lang/ruby-2.0.0_p353 # required by dev-ruby/racc-1.4.9[ruby_targets_ruby20] # required by dev-ruby/rdoc-4.0.1-r1[ruby_targets_ruby19

Re: [gentoo-user] Re: ruby 22

2017-08-22 Thread Dale
dev-ruby/json-1.8.3 requires dev-lang/ruby:2.1 >> dev-ruby/json-2.1.0 requires dev-lang/ruby:2.1 >> dev-ruby/kpeg-1.1.0 requires dev-lang/ruby:2.1 >> dev-ruby/maruku-0.7.3 requires dev-lang/ruby:2.1 >> dev-ruby/minitest-5.10.3 requires &g

[gentoo-user] Missing digest for *** Tree looks messed up.

2015-08-09 Thread Dale
' / * Missing digest for '/var/cache/portage/tree/kde-base/kstartupconfig/kstartupconfig-4.11.19.ebuild' * Missing digest for '/var/cache/portage/tree/dev-ruby/rdoc/rdoc-4.1.2-r1.ebuild' / * Missing digest for '/var/cache/portage/tree/kde-apps/kalgebra/kalgebra-4.14.3.ebuild' * Missing digest

Re: [gentoo-user] gentoo-minimal-install software list

2014-01-14 Thread Alan McKinnon
dev-ruby/json-1.8.0 dev-ruby/racc-1.4.9 dev-ruby/rake-0.9.6 dev-ruby/rdoc-4.0.1-r1 dev-ruby/rubygems-2.0.3 dev-util/boost-build-1.52.0-r1 dev-util/dialog-1.2.20130928 dev-util/gperf-3.0.4 dev-util/gtk-doc-am-1.19 dev-util/intltool-0.50.2-r1 dev-util/ragel-6.7-r1 media-gfx/fbgrab-1.0-r2 media-libs/alsa

Re: [gentoo-user] Installing outside of Portage cruft removal

2009-01-26 Thread Daniel Pielmeier
-gnu-size /usr/bin/i686-pc-linux-gnu-strings /usr/bin/i686-pc-linux-gnu-strip /usr/bin/idle /usr/bin/irb /usr/bin/ld /usr/bin/nm /usr/bin/objcopy /usr/bin/objdump /usr/bin/pydoc /usr/bin/python /usr/bin/python-config /usr/bin/python2 /usr/bin/ranlib /usr/bin/rdoc /usr/bin/readelf /usr/bin/ri /usr/bin

Re: [gentoo-user] Re: Well, I went about updating my system again. (day 6)

2016-12-07 Thread Alan Grimes
check-1.75::gentoo USE="pcre qt4 -htmlreport" PYTHON_TARGETS="python2_7 python3_4 python3_5 (-python3_3%)" 0 KiB [ebuild U ] media-gfx/imagemagick-6.9.6.6:0/6.9.6.6::gentoo [6.9.5.10:0/6.9.5.10::gentoo] USE="X bzip2 cxx fftw fontconfig graphviz jpeg jpeg2k lcms open

[gentoo-user] Something went wrong with DNS, plz help!

2014-07-26 Thread Grand Duet
by dev-ruby/rake-0.9.6[ruby_targets_ruby19] # required by dev-lang/ruby-2.0.0_p353 # required by dev-ruby/racc-1.4.9[ruby_targets_ruby20] # required by dev-ruby/rdoc-4.0.1-r1[ruby_targets_ruby19] =dev-lang/tk-8.5.15 threads Use --autounmask-write to write changes to config files (honoring

[gentoo-user] newish vbox gentoo guest crashes from startx

2016-12-07 Thread Harry Putnam
Setup: gentoo 32bit vbox guest on win 10 64bit host Installed xorg-server, lxde Meta pkgs and deps (along with many other pkgs ... to many to list here but included at the end) uname -a: Linux g0 4.8.8-gentoo #2 Fri Nov 18 20:16:14 EST 2016 i686 Intel(R) Xeon(R) CPU X5450 @

Re: [gentoo-user] newish vbox gentoo guest crashes from startx

2016-12-07 Thread Alan McKinnon
On 07/12/2016 17:34, Harry Putnam wrote: > Setup: > >gentoo 32bit vbox guest on win 10 64bit host >Installed xorg-server, lxde Meta pkgs and deps >(along with many other pkgs ... to many to list >here but included at the end) > > uname -a: > Linux g0 4.8.8-gentoo #2 Fri Nov 18