I'm having a similar problem (see archived post below) using RSA2
public key auth on an FC4 machine.

I've set UseDNS to off and it still doesn't work:

UseDNS no

Here is the -vvv output:

debug1: Offering agent key: /home/kitamura/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,gssapi-with-mic,password

If reverse lookups are off, and everything thing else is in place and
has correct permissions, why else would public key auth fail?

Linux 2.6.17-1.2142_FC4 #1 Tue Jul 11 22:41:14 EDT 2006 i686 i686 i386 GNU/Linux
OpenSSH_4.2p1, OpenSSL 0.9.7f 22 Mar 2005


List:       secure-shell
Subject:    Re: problem with publickey authentication
From:       Duane Winner <dwinner () utrs ! com>
Date:       2006-10-20 15:46:25
Message-ID: 4538EF51.6040307 () utrs ! com
[Download message RAW]

This problem has been solved.

The problem was that the Windows SSH Server had reverse DNS lookup
checks turned on, and I had no reverse lookup DNS entry for the test
server (FreeBSD), but did have one for the working server (Linux).

It had nothing to do w/ the OS or OpenSSH version.


Reply via email to