On Tue, 15 Feb 2022 15:16:58 GMT, Weijun Wang <wei...@openjdk.org> wrote:
>> The enhancement adds two extra items in the `getSubjectAlternativeNames()` >> output for an OtherName. >> >> It also fix several errors: >> 1. In `OtherName.java`, `nameValue` should be the value inside `CONTEXT [0]` >> without the tag and length bytes. >> 2. The argument in constructor `extClass.getConstructor(Object.class)` is >> suspicious. Maybe it meant `byte[]`. > > Weijun Wang has updated the pull request incrementally with one additional > commit since the last revision: > > string at 4th place src/java.base/share/classes/sun/security/x509/OtherName.java line 93: > 91: oid = in.getOID(); > 92: DerValue derValue1 = in.getDerValue(); > 93: if (!derValue1.isContextSpecific((byte)0) || > !derValue1.isConstructed()) { It might be purely a matter of taste, but isn't `!(isCSTag0 && isConst)` easier to read? ------------- PR: https://git.openjdk.java.net/jdk/pull/7167