On Fri, 14 Feb 2025 18:44:38 GMT, Anthony Scarpino <ascarp...@openjdk.org> 
wrote:

> Hi,
> 
> I need a review for the following change. Naming conventions for EdDSA and 
> XDH have inconsistencies between DisabledAlgorithms and KeyPairGenerator. 
> These internal changes help make it more consistent when parsing the actual 
> curve being used vs the broader algorithm name.
> 
> thanks
> 
> Tony

src/java.base/share/classes/sun/security/util/AbstractAlgorithmConstraints.java 
line 79:

> 77:     private static List<String> aliasXDH = null;
> 78:     private static List<String> aliasX25519 = null;
> 79: 

Wouldn't it be more concise to create a static algorithm-to-aliases map and 
then make getAliases() to do the map lookup?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r1962387539

Reply via email to