On Tue, 18 Mar 2025 14:11:26 GMT, Mikhail Yankelevich <myankelev...@openjdk.org> wrote:
>> 8351566: Consolidate third party artifacts used in tests > > Mikhail Yankelevich has updated the pull request incrementally with one > additional commit since the last revision: > > minor: imports fix test/lib/jdk/test/lib/security/artifacts/ThirdPartyArtifacts.java line 30: > 28: import jdk.test.lib.artifacts.ArtifactResolverException; > 29: > 30: import java.io.IOException; nit: unused imports can be removed test/lib/jdk/test/lib/security/artifacts/ThirdPartyArtifacts.java line 35: > 33: public class ThirdPartyArtifacts { > 34: > 35: public static final String ACVP_BUNDLE_LOC = "jpg.tests.jdk"; The location: "jpg.tests.jdk" may be common for all artifacts. Suggestion: public static final String ARTIFACT_BASE = "jpg.tests.jdk"; test/lib/jdk/test/lib/security/artifacts/ThirdPartyArtifacts.java line 42: > 40: // the NSS version > 41: public static final String NSS_BUNDLE_VERSION = "3.107"; > 42: public static final String NSSLIB = "jpg.tests.jdk.nsslib"; It can reuse the common location. also do the bundle vars need to be public ? Suggestion: private static final String NSSLIB = ARTIFACT_BASE + ".nsslib"; test/lib/jdk/test/lib/security/artifacts/ThirdPartyArtifacts.java line 49: > 47: revision = NSS_BUNDLE_VERSION, > 48: extension = "zip") > 49: public static class WINDOWS_X64 { Please rename the NSS static classes to `NSS_<platform>` as ThirdPartyArtifacts will also contain other artifacts for these platforms Suggestion: public static class NSS_WINDOWS_X64 { ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/23988#discussion_r2016597905 PR Review Comment: https://git.openjdk.org/jdk/pull/23988#discussion_r2016590177 PR Review Comment: https://git.openjdk.org/jdk/pull/23988#discussion_r2016594920 PR Review Comment: https://git.openjdk.org/jdk/pull/23988#discussion_r2016578229