+1
Although I favour spoolMail(...) as a name, why not just say it like it is.
d.
---
"Please read the following carefully. xxxx Corporation will not be
responsible for any problems caused by customerâs improper operation when
customers did not follow the following instructions:
1. Make sure to follow the instructions in this procedure correctly."
|---------+---------------------------->
| | Serge Knystautas |
| | <[EMAIL PROTECTED]|
| | com> |
| | |
| | 21/03/2004 05:06 |
| | AM |
| | Please respond to|
| | "James Developers|
| | List" |
| | |
|---------+---------------------------->
>---------------------------------------------------------------------------------------------------------------|
|
|
| To: James Developers List <[EMAIL PROTECTED]>
|
| cc:
|
| Subject: Re: Missing Mailet APIs related to attributes?
|
>---------------------------------------------------------------------------------------------------------------|
Noel J. Bergman wrote:
> Seems to me that we either need to add:
>
> sendMail(Sender, Recipients, Message, State, Attributes);
> sendMail(Sender, Recipients, Message, Attributes);
>
> or make it easier for developers to create a new Mail instance, which
pretty
> much means the same sort of parameters, since Sender and Recipients are
> read-only properties.
>
> Meanwhile, we can create a MailImpl when we need them.
I don't like the idea of exposing MailImpl, and it seems we're already
cheating in this regard. I would prefer deprecating all existing
sendMail() methods and instead do:
public interface MailetContext {
Mail newMail();
void queue(Mail mail);
..
..
}
I'm not wedded to the two names. I like queue(Mail) over send(Mail)
because send() implies a) it's going some place else and b) does not
address how message could be placed in other states (like spam, error,
whatever).
--
Serge Knystautas
President
Lokitech >> software . strategy . design >> http://www.lokitech.com
p. 301.656.5501
e. [EMAIL PROTECTED]
---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
***************************************************************************
The information in this e-mail is confidential and for use by the addressee(s) only.
If you are not the intended recipient (or responsible for delivery of the message to
the intended recipient) please notify us immediately on 0141 306 2050 and delete the
message from your computer. You may not copy or forward it or use or disclose its
contents to any other person. As Internet communications are capable of data
corruption Student Loans Company Limited does not accept any responsibility for
changes made to this message after it was sent. For this reason it may be
inappropriate to rely on advice or opinions contained in an e-mail without obtaining
written confirmation of it. Neither Student Loans Company Limited or the sender
accepts any liability or responsibility for viruses as it is your responsibility to
scan attachments (if any). Opinions and views expressed in this e-mail are those of
the sender and may not reflect the opinions and views of The Student Loans Company
Limited.
This footnote also confirms that this email message has been swept for the presence of
computer viruses.
**************************************************************************