Hi Rangan,

you'll see I'm copying the server-devel list -- other people are
following similar steps, so let's have technical conversations via
this list, otherwise, my inbox explodes hopelessly :-)

On Fri, Mar 6, 2009 at 12:13 PM, Rangan Srikhanta <ran...@laptop.org.au> wrote:
> Thank you for your previous email outlining the new patch. We are still on
> 0.5.1 (maybe we need to be on 0.5.2) but did the following commands in the
> school server but to no avail.

With 0.5.1 you'll see some problems with ejabberd. I'd recommend 0.5.2-dev02...

> git-clone git://dev.laptop.org/users/martin/moodle.git work
>
> cp unalias
>
> cp –rf ./work/* /moodle/

I'll give you these alternative instructions - all the steps below as
the root user...

1 - to be sure, perform the full install of the XS (in your notes it's
not clear whether you had configured domains, ejabberd, etc)

2 - start postgres - `chkconfig --add pgsql-xs ; /etc/init.d/pgsql-xs start `

3 - install git `yum install git`

4 - To develop and play with moodle,

    cd /var/www/moodle
    mv web web-from-rpm
    git clone git-clone git://dev.laptop.org/users/martin/moodle.git web
    cp web-from-rpm/config.php web/config.php

now you should have a good moodle install. Also recommeded:

 - add these lines to config.php

$CFG->debug=6143;
$CFG->debugdisplay=0;

  - keep a console where you tail the error logs - I setup an xterm
below my editor and browser windows, where I use the following
command:

   tail -f /var/log/httpd/error_log  | perl -pe 's/\\n/\n/g'

> In the XO I upgraded the Browse version to the latest and it worked!

Right... you've tried to install the Browse.xo from git, which is a
bit of trouble because it's not fully compatible.

> Sudo yum install git
> git-clone git://dev.laptop.org/web-activity clone
> cp –rf ./clone/* /Activities/Browse.activity/

If you want to do it this way, I'd say, as user olpc, do

1 - sudo yum install git
2 - cd /home/olpc/Activities
3 - mv Browse.activity Browse.activity-original
4 - git-clone git://dev.laptop.org/web-activity Browse.activity
5 - cd Browse.activity
6 - git checkout -b sucrose-0.82 origin/sucrose-0.82
7 - from the home view, start Browse.

- steps 5 and 6 are because the 'master' development branch of Browse
doesn'twork on the 8.2.x OS. I know - awkward.

Anyway, my recommendatino is thatr you _don't_ do this either :-). On
the laptop side, just install the nicely packaged Browse-100.xo  from

http://shell.sugarlabs.org/~erikos/bundles/Browse-100.xo

> I am trying to get the seamless login working as I think that will be
> pivotal to our deployments in the next two weeks. Thank you for your
> patience.

Note that this is a development version! If it breaks... and it
probably will... you get to keep both parts.

cheers,


m
-- 
 martin.langh...@gmail.com
 mar...@laptop.org -- School Server Architect
 - ask interesting questions
 - don't get distracted with shiny stuff  - working code first
 - http://wiki.laptop.org/go/User:Martinlanghoff
_______________________________________________
Server-devel mailing list
Server-devel@lists.laptop.org
http://lists.laptop.org/listinfo/server-devel

Reply via email to