Author: cas
Date: Tue Jul 27 18:53:14 2010
New Revision: 5964
URL: http://svn.gna.org/viewcvs/service-tech?rev=5964&view=rev
Log:
* canonicalNames() now distinguishes between places and transitions
* ports can be renamed
* ports can be merged
* finished[tm] work on compose()
* added test cases
Added:
trunk/pnapi/tests/testfiles/test_compose_ports_1.owfn
trunk/pnapi/tests/testfiles/test_compose_ports_2.owfn
Modified:
trunk/pnapi/src/Makefile.am
trunk/pnapi/src/interface.cc
trunk/pnapi/src/interface.h
trunk/pnapi/src/petrinet.cc
trunk/pnapi/src/port.cc
trunk/pnapi/src/port.h
trunk/pnapi/tests/Makefile.am
trunk/pnapi/tests/testsuite.at
trunk/pnapi/utils/petri.cc
--
You received this e-mail, because you subscribed the mailing list
"service-tech-commits" which will forward you any e-mail addressed to
[email protected]. If you want to unsubscribe or make any changes to
your subscription, please go to
https://mail.gna.org/listinfo/service-tech-commits.