The fix looks good, but I have a problem with the ROUNDUP_PAGE macro. First, I don't like having macros defined in the middle of a method. Second, the definition of the macro includes the value of a local variable which is a bit hairy. Can't you just ROUNDUP directly in the four places it's needed? I think it would make for more readable code.
nit on line 743: filed -> field Thanks, /Staffan On 12 okt 2013, at 13:25, Dmitry Samersoff <[email protected]> wrote: > Hi Everybody, > > Please review the fix > > http://cr.openjdk.java.net/~dsamersoff/JDK-8025812/webrev.01/ > > The value of p_memsz filed of elf header of LOAD section inside coredump > is rounded up to page size. So round up corresponding value read from > the header of library it self. > > -- > Dmitry Samersoff > Oracle Java development team, Saint Petersburg, Russia > * I would love to change the world, but they won't give me the sources.
