Hi,

On Mon, 2018-05-14 at 13:02 -0700, JC Beyler wrote:
> Hi Robbin and all,
> 
> Thank you for your continuous help!
> 
> Done then! Here is the new webrev:
> http://cr.openjdk.java.net/~jcbeyler/8171119/heap_event.20/
> 
> and the incremental is:
> http://cr.openjdk.java.net/~jcbeyler/8171119/heap_event.19_20/
> 
> Thanks again all!
> Jc
> 

  looks good to me.

Two minor issues that you might want to fix before pushing:

- collectedHeap.hpp: The declaration of
CollectedHeap::allocate_memory() should be private.

- collectedHeap.inline.hpp: in CollectedHeap::allocate_memory() there
is this completely duplicated code which you might factor out into
another (private) method:

if (init_memory) {
  obj = ...
} else {
  obj = ...
}
post_setup(klass, ...);

Thanks,
  Thomas

Reply via email to