On Thu, 22 Oct 2020 08:03:15 GMT, Serguei Spitsyn <sspit...@openjdk.org> wrote:

>> due to the same reasons in the case w/ `fields001`, these lines have 3 unit 
>> indentation, 1st for `hc001` class, 2nd for `testInvalidCommands` method, 
>> 3rd for `invClassNames` array initialization, so they have 3x4 = 12 spaces.
>
> File test/hotspot/jtreg/vmTestbase/nsk/jdb/kill/kill001/kill001.java has this 
> change:
> 
>          for (int i = 0; i < threads.length; i++) {
>              reply = jdb.receiveReplyForWithMessageWait(JdbCommand.kill + 
> threads[i] + " " +
> -                                                       DEBUGGEE_EXCEPTIONS + 
> "[" + i + "]",
> -                                                       "killed");
> +                            DEBUGGEE_EXCEPTIONS + "[" + i + "]",
> +                    "killed");
>          }
> I think, the second line "killed");  has to be aligned with the previous one.
> Also, I feels like this change makes the code to be less readable:
>          reply = jdb.receiveReplyForWithMessageWait(JdbCommand.eval + 
> DEBUGGEE_RESULT,
> -                                                   DEBUGGEE_RESULT + " =");
> +                DEBUGGEE_RESULT + " =");

Hi Igor,

Overall, it is great. Your formatting tool seems to be AI. 👍 
This update fixes a lot of formatting issues.
I have no more comments so far.

-------------

PR: https://git.openjdk.java.net/jdk/pull/689

Reply via email to