`String.contains` was introduced in Java 5. Some code in jdk.hotspot.agent still uses old approach with `String.indexOf` to check if String contains specified substring. I propose to migrate such usages. Makes code shorter and easier to read.
------------- Commit messages: - [PATCH] Use String.contains() instead of String.indexOf() in jdk.hotspot.agent Changes: https://git.openjdk.java.net/jdk/pull/8966/files Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=8966&range=00 Issue: https://bugs.openjdk.java.net/browse/JDK-8287695 Stats: 19 lines in 4 files changed: 0 ins; 7 del; 12 mod Patch: https://git.openjdk.java.net/jdk/pull/8966.diff Fetch: git fetch https://git.openjdk.java.net/jdk pull/8966/head:pull/8966 PR: https://git.openjdk.java.net/jdk/pull/8966