On Mon, 9 Apr 2018, Sylvain MILOT wrote:



On Fri, 6 Apr 2018, Reuti wrote:


Am 06.04.2018 um 18:43 schrieb Sylvain MILOT:

<snip>
I found and fixed the network lag issue, as these two systems are KVM guests on an Ubuntu 16.04 server.

https://askubuntu.com/questions/496424/kvm-guest-network-problems

Yet, the qlogin/qrsh problem persists ... ideas ?

Does such a setup work on any machine? You could need several forwardings to the KVM from the main OS I think - depending on the network setup of the KVM of course.

aside from those 2 KVM guests, qlogin/qrsh works on all nodes, even those running as Xen guests.

qsub works as expected and I can connect with ssh as a privileged user, as otherwise ssh is blocked.

I have observed this behavior in the past, with SGE 8.1.9 and also with gridengine 6.2u5-1, without any virtualization involved - but the problem was sporadic.

I'm confronted with this issue again but it's currently quite consistent for these 2 systems.

I still observe some lag related to NFS, even after disabling KSM (which showed improvements when seen through iperf), so perhaps this is (also) causing a timeout of sorts.

I will investigate this NFS related lag and get back with my findings.

NFS lag is gone and qlogin/qrsh work as expected.

I guess this confirms that qlogin/qrsh are somehow sensitive to this kind of 
issue, while qsub is not.

Sylvain
_______________________________________________
SGE-discuss mailing list
SGE-discuss@liv.ac.uk
https://arc.liv.ac.uk/mailman/listinfo/sge-discuss

Reply via email to