I have experienced this a couple of times over the last couple of years, but only with minor incidents and nothing that could not be fixed easily. But now, the problem has gotten bigger and it seems that I cannot fix it persistently.

The problem is that my tags loose their parent tags. E.g. I have group-tags such as Places. Within that group I have countries such as Argentina and Andes. So Places/Argentina and Places/Andes. But now, for some images, Argentina and Andes are placed on the top level (next to Places) while for other images the tags remain correct. I.e. I now have Argentina, Andes, Places/Argentina, and Places/Andes.

Previously I have been able to move tags around and that would fix it. But now, more and more tags are having that problem, and moving this around only seems to fix it until next restart of Shotwell.

I have some xmp sidecar files (from Darktable) which also contained some tags, and I have tried to remove all tags from the image files and the xmp files (and let Shotwell handle tags via it's database only) - but that did not help.

Do you have any idea of what is causing this? Or how to debug this?

I tried to search a bit in the bug database, but no luck.

Jørn Christensen
shotwell-list mailing list

Reply via email to