Ok, next try....

> The problem is that my tags loose their parent tags. E.g. I have 
> group-tags such as Places. Within that group I have countries such
> as 
> Argentina and Andes. So Places/Argentina and Places/Andes. But now,
> for 
> some images, Argentina and Andes are placed on the top level (next
> to 
> Places) while for other images the tags remain correct. I.e. I now
> have 
> Argentina, Andes, Places/Argentina, and Places/Andes.

Can you pin-point any particular action that you are doing when this is
happening?

> 
> Previously I have been able to move tags around and that would fix
> it. 
> But now, more and more tags are having that problem, and moving this 
> around only seems to fix it until next restart of Shotwell.
> 
> I have some xmp sidecar files (from Darktable) which also contained
> some 
> tags, and I have tried to remove all tags from the image files and
> the 
> xmp files (and let Shotwell handle tags via it's database only) -
> but 
> that did not help.

Shotwell does not take xmp sidecar files into account yet.

> 
> Do you have any idea of what is causing this? Or how to debug this?

If that happens again, can you provide ~/.local/share/shotwell/photo.db
and photo.db.bak  somewhere for analysing?

> 
> I tried to search a bit in the bug database, but no luck.

Does https://bugzilla.gnome.org/show_bug.cgi?id=776387 match?

_______________________________________________
shotwell-list mailing list
shotwell-list@gnome.org
https://mail.gnome.org/mailman/listinfo/shotwell-list

Reply via email to