Dear siesta users,

I have been trying to get pojected DOS or fatband analysis from siesta
generated output files SystemLabel.fullBZ.WFSX and SystemLabel.bands.WFSX
respectively. Whenever I run mprop or fat with the newly released
siesta-4.1, I get errors. For mprop, for instance, below is the error

Reading wave-function file: slab.WFSX...
Energy units are eV
Minimum/Maximum number of wfs per k-point:  1904 1904
Min_eigval, max_eigval on WFS file:     -22.3283    248.6962
Min_eigval, max_eigval in band set :     -22.3283    248.6962
Implicit band set used: (min, max_min, max_max):   119041904
Minimum and maximum eigenvalues (based on file data and band
selection):     -22.3283    248.6962
* Maximum eigenvalue changed as per user range request:       5.0000
Minimum and maximum eigenvalues to be processed:     -22.3283      5.0000
Plotting range adequate for eigenvalue range selected:     -22.6283
Using smearing parameter:   0.100
Using    500 points in energy range
 slab.HSX nnao, no_s, nspin, nh:        1904       17136           2
Fermi energy:   -2.30203 (depends on smearing)
 Size of set_mask:         1904
 Size of set_mask:         1904
 Total number of curves processed:            2
Writing files: slab.stt ...
Curve    PDOS_1  Base orbitals and interactions:     10         2268
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image              PC                Routine            Line
mprop              000000000052C3E9  Unknown               Unknown  Unknown
mprop              000000000052ACBE  Unknown               Unknown  Unknown
mprop              00000000004E7012  Unknown               Unknown  Unknown
mprop              0000000000498293  Unknown               Unknown  Unknown
mprop              000000000049C28B  Unknown               Unknown  Unknown    00002AE6CAF2B7E0  Unknown               Unknown  Unknown
mprop              000000000048A190  Unknown               Unknown  Unknown
mprop              00000000004119C6  Unknown               Unknown  Unknown          00002AE6CB157D1D  Unknown               Unknown  Unknown
mprop              00000000004118B9  Unknown               Unknown  Unknown

Similar problems occur when I run fat. I compiled  both mprop and fat with
the same arch.make file that I used for siesta compilation.
I am suspecting a possible format problem between this new siesta-4.1 and
the code sources of mprop or fat.
I note that both mprop or fat work well with previous siesta versions or
with siesta trunk version 509.

Does anyone have an idea about where this problem may come from?

Best regards,

Responder a