Dear All:
   I am trying to plot band structure using gnubands in the Util/Bands 
directory. The bands file is generated with HPC cluster that uses ifort as a 
compiler with associated intel libraries. When I apply gnubands on the bands 
file to generate a data file to work with gnuplot, I get the following error:

At line 132 of file gnubands.f90 (unit = 5, file = 'stdin')
Fortran runtime error: Bad real number in item 1 of list input

Does gnubands work with results generated with ifort?

Assuming that the error may be due to the intel compiler ifort, I installed 
siesta locally and compiled with gfortran compiler, then tried gnubands. Then I 
get similar results, but it seems the reason now is due to libgfortran missing 
(since it is not installed on HPC). Here is the error I get:

At line 140 of file gnubands.f90 (unit = 5, file = 'stdin')
Fortran runtime error: Bad integer for item 1 in list input

Error termination. Backtrace:
#0  0x2b0f58dfb940 in read_integer
      at ../.././libgfortran/io/list_read.c:1095
#1  0x2b0f58dff8c3 in list_formatted_read_scalar
      at ../.././libgfortran/io/list_read.c:2150
#2  0x402780 in ???
#3  0x4013fe in ???
#4  0x2b0f597c5554 in ???
#5  0x40142e in ???
#6  0xffffffffffffffff in ???

I tried to download libgfortran library, but it is not available separately on 
its own.

 Your suggestions would be highly appreciated.

The bands file is attached.

Attachment: ZnO.bands
Description: ZnO.bands

SIESTA is supported by the Spanish Research Agency (AEI) and by the European 
H2020 MaX Centre of Excellence (

Responder a