Hi,

thanks for the patches! Quick review below and in the other mails.

On Thu, Feb 05, 2015 at 05:30:55PM +0100, Bartosz Golaszewski wrote:
> I forgot to mention it yesterday: the driver has been implemented
> in a single file as there is no real 'protocol' and I don't think
> it requires splitting into several compilation units. Let me know
> if I'm wrong.

Generally it's a good idea to split into api.c and protocol.[ch], yeah.
Please consider doing that for this driver as well. Having consistent
naming and split-ups across the whole codebase reduces the hassle when
we do mass-changes across all drivers; the more they look and "feel"
alike the easier and less error-prone such changes can be done.
The protocol.c file will usually contain a *_receive_data() function
and other device-specific code for talking to the hardware.

Also, please call the driver "baylibre-acme" to make it a bit clearer
and avoid a too generic name (we generally use "vendorname-devicename").

We recommend using the "new-driver" script from the sigrok-util repo to
generate a "framework" driver patch as first commit, then add the contents
in follow-up commits.

  sigrok-util/source> ./new-driver Baylibre ACME


Uwe.
-- 
http://hermann-uwe.de | http://randomprojects.org | http://sigrok.org

------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
sigrok-devel mailing list
sigrok-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sigrok-devel

Reply via email to